python3-cython: upgrade 0.29.24 -> 0.29.25

Message ID 1639401371-27716-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 8d8faad71e05703362d4004cc9ecdb93c08398ec
Headers show
Series python3-cython: upgrade 0.29.24 -> 0.29.25 | expand

Commit Message

Mingyu Wang (Fujitsu) Dec. 13, 2021, 1:16 p.m. UTC
Changelog:
================
Bugs fixed
----------
* Several incompatibilities with CPython 3.11 were resolved.
  (Github issues #4411, #4414, #4415, #4416, #4420, #4428, #4473, #4479, #4480)

* Some C compiler warnings were resolved.
  (Github issue #4439)

* C++ "std::move()" should only be used automatically in MSVC versions that support it.
  (Github issue #4191)

 * The "Py_hash_t" type failed to accept arbitrary "index" values.
   (Github issue #2752)

* Avoid copying unaligned 16-bit values since some platforms require them to be aligned.
  Use memcpy() instead to let the C compiler decide how to do it.
  (Github issue #4343)

* Cython crashed on invalid truthiness tests on C++ types without "operator bool".
  (Github issue #4348)

* The declaration of "PyUnicode_CompareWithASCIIString()" in "cpython.unicode" was incorrect.
  (Github issue #4344)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-devtools/python/python-cython.inc                  | 2 +-
 .../{python3-cython_0.29.24.bb => python3-cython_0.29.25.bb}    | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-cython_0.29.24.bb => python3-cython_0.29.25.bb} (100%)

Patch

diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
index 5a8ec2a0ff..93d6fdf13b 100644
--- a/meta/recipes-devtools/python/python-cython.inc
+++ b/meta/recipes-devtools/python/python-cython.inc
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e23fadd6ceef8c618fc1c65191d846fa"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "cdf04d07c3600860e8c2ebaad4e8f52ac3feb212453c1764a49ac08c827e8443"
+SRC_URI[sha256sum] = "a87cbe3756e7c464acf3e9420d8741e62d3b2eace0846cb39f664ad378aab284"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.24.bb b/meta/recipes-devtools/python/python3-cython_0.29.25.bb
similarity index 100%
rename from meta/recipes-devtools/python/python3-cython_0.29.24.bb
rename to meta/recipes-devtools/python/python3-cython_0.29.25.bb