mesa: upgrade 21.3.0 -> 21.3.1

Message ID 1638835602-3908-1-git-send-email-zhengrq.fnst@fujitsu.com
State Accepted, archived
Commit 1970fd5764adff10a5d7e643aeea7ce40d318f26
Headers show
Series mesa: upgrade 21.3.0 -> 21.3.1 | expand

Commit Message

zhengrq.fnst@fujitsu.com Dec. 7, 2021, 12:06 a.m. UTC
Changelog from 21.3.0
=========================================================
Bug fixes:
GPU Crash in Yuzu 6600xt 5.15
[spirv-fuzz] lower_trivial_continues_block: Assertion '!first_instr || instr_is_continue(first_instr)' failed.
[RADV] Crash in Metro Exodus in Caspain chapter and Sam’s Story
NIR validation failed after nir_copy_prop
lima: Corrupted Android-12 UI on Allwinner A64
RADV/ACO: Rendering glitches in Forza Horizon 5 windshields
dEQP-GLES31.*imulextended* compiling fp64 glsl 4.00 shader

Changes:
ir3/ra: Consider reg file size when swapping killed sources
ir3/lower_pcopy: Fix shr.b illegal copy lowering
ir3/lower_pcopy: Fix bug with “illegal” copies and swaps
docs: update sha256sum for 21.3.0
.pick_status.json: Update to 1ba231fb75be5bffd806cbd09ac285d1f8f15e3d
ci: temporarily disable lima CI
broadcom/compiler: don’t allow RF writes from signals after thrend
broadcom/compiler: fix scoreboard locking checks
broadcom/compiler: don’t move ldvary earlier if current instruction has ldunif
glsl/nir: Don’t build soft float64 when it cannot be used
intel/nir: also allow unknown format for getting the size of a storage image
iris: Make a helper function for cross-batch dependency flushing
iris: Check for cross-batch flushing whenever a buffer is newly written.
iris: Tidy code in iris_use_pinned_bo a bit
anv: don’t try to close fd = -1
intel/fs: fix shader call lowering pass
util/u_trace: refcount payloads
android: define cpp_rtti=false because libLLVM is built w/o RTTI (v2)
zink: block suballocator caching for swapchain/dmabuf images
zink: set suballocator bo size to aligned allocation size
zink: stop using VK_IMAGE_LAYOUT_PREINITIALIZED for dmabuf
zink: always set matching resource export type for dmabuf creation
zink: fix memory availability reporting
zink: fail context creation more gracefully
nir: Fix read depth for predecessors
glx/dri3: fix glXQueryContext does not return GLX_RENDER_TYPE value
aco/spill: use spills_entry instead of spills_exit to kill linear VGPRs
spirv: run nir_copy_prop before nir_rematerialize_derefs_in_use_blocks_impl
nir/dce: fix DCE of loops with a halt or return instruction in the pre-header
aco: don’t create DPP instructions with SGPR operands
android.mk: Add missing variables to the make target
radv: disable HTILE for D32S8 format and mipmaps on GFX10
radv: fix emitting VBO when vertex input dynamic state is used
radv: add a workaround to fix a segfault with Metro Exodus (Linux native)
radv: fix resetting the entire vertex input dynamic state
svga: fix bitwise/logical and mixup
lima: disasm: use last argument as a filename

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 meta/recipes-graphics/mesa/mesa.inc                           | 2 +-
 meta/recipes-graphics/mesa/{mesa_21.3.0.bb => mesa_21.3.1.bb} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-graphics/mesa/{mesa_21.3.0.bb => mesa_21.3.1.bb} (100%)

Comments

Alexander Kanavin Dec. 6, 2021, 5:11 p.m. UTC | #1
Please do not forget mesa-gl recipe as well.

Alex

On Mon, 6 Dec 2021 at 16:06, zhengruoqin <zhengrq.fnst@fujitsu.com> wrote:

> Changelog from 21.3.0
> =========================================================
> Bug fixes:
> GPU Crash in Yuzu 6600xt 5.15
> [spirv-fuzz] lower_trivial_continues_block: Assertion '!first_instr ||
> instr_is_continue(first_instr)' failed.
> [RADV] Crash in Metro Exodus in Caspain chapter and Sam’s Story
> NIR validation failed after nir_copy_prop
> lima: Corrupted Android-12 UI on Allwinner A64
> RADV/ACO: Rendering glitches in Forza Horizon 5 windshields
> dEQP-GLES31.*imulextended* compiling fp64 glsl 4.00 shader
>
> Changes:
> ir3/ra: Consider reg file size when swapping killed sources
> ir3/lower_pcopy: Fix shr.b illegal copy lowering
> ir3/lower_pcopy: Fix bug with “illegal” copies and swaps
> docs: update sha256sum for 21.3.0
> .pick_status.json: Update to 1ba231fb75be5bffd806cbd09ac285d1f8f15e3d
> ci: temporarily disable lima CI
> broadcom/compiler: don’t allow RF writes from signals after thrend
> broadcom/compiler: fix scoreboard locking checks
> broadcom/compiler: don’t move ldvary earlier if current instruction has
> ldunif
> glsl/nir: Don’t build soft float64 when it cannot be used
> intel/nir: also allow unknown format for getting the size of a storage
> image
> iris: Make a helper function for cross-batch dependency flushing
> iris: Check for cross-batch flushing whenever a buffer is newly written.
> iris: Tidy code in iris_use_pinned_bo a bit
> anv: don’t try to close fd = -1
> intel/fs: fix shader call lowering pass
> util/u_trace: refcount payloads
> android: define cpp_rtti=false because libLLVM is built w/o RTTI (v2)
> zink: block suballocator caching for swapchain/dmabuf images
> zink: set suballocator bo size to aligned allocation size
> zink: stop using VK_IMAGE_LAYOUT_PREINITIALIZED for dmabuf
> zink: always set matching resource export type for dmabuf creation
> zink: fix memory availability reporting
> zink: fail context creation more gracefully
> nir: Fix read depth for predecessors
> glx/dri3: fix glXQueryContext does not return GLX_RENDER_TYPE value
> aco/spill: use spills_entry instead of spills_exit to kill linear VGPRs
> spirv: run nir_copy_prop before nir_rematerialize_derefs_in_use_blocks_impl
> nir/dce: fix DCE of loops with a halt or return instruction in the
> pre-header
> aco: don’t create DPP instructions with SGPR operands
> android.mk: Add missing variables to the make target
> radv: disable HTILE for D32S8 format and mipmaps on GFX10
> radv: fix emitting VBO when vertex input dynamic state is used
> radv: add a workaround to fix a segfault with Metro Exodus (Linux native)
> radv: fix resetting the entire vertex input dynamic state
> svga: fix bitwise/logical and mixup
> lima: disasm: use last argument as a filename
>
> Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
> ---
>  meta/recipes-graphics/mesa/mesa.inc                           | 2 +-
>  meta/recipes-graphics/mesa/{mesa_21.3.0.bb => mesa_21.3.1.bb} | 0
>  2 files changed, 1 insertion(+), 1 deletion(-)
>  rename meta/recipes-graphics/mesa/{mesa_21.3.0.bb => mesa_21.3.1.bb}
> (100%)
>
> diff --git a/meta/recipes-graphics/mesa/mesa.inc
> b/meta/recipes-graphics/mesa/mesa.inc
> index ed60d98250..e99ec6961b 100644
> --- a/meta/recipes-graphics/mesa/mesa.inc
> +++ b/meta/recipes-graphics/mesa/mesa.inc
> @@ -21,7 +21,7 @@ SRC_URI = "
> https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
>
> file://0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch \
>             "
>
> -SRC_URI[sha256sum] =
> "a2753c09deef0ba14d35ae8a2ceff3fe5cd13698928c7bb62c2ec8736eb09ce1"
> +SRC_URI[sha256sum] =
> "2b0dc2540cb192525741d00f706dbc4586349185dafc65729c7fda0800cc474d"
>
>  UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
>
> diff --git a/meta/recipes-graphics/mesa/mesa_21.3.0.bb
> b/meta/recipes-graphics/mesa/mesa_21.3.1.bb
> similarity index 100%
> rename from meta/recipes-graphics/mesa/mesa_21.3.0.bb
> rename to meta/recipes-graphics/mesa/mesa_21.3.1.bb
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#159237):
> https://lists.openembedded.org/g/openembedded-core/message/159237
> Mute This Topic: https://lists.openembedded.org/mt/87541536/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index ed60d98250..e99ec6961b 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -21,7 +21,7 @@  SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch \
            "
 
-SRC_URI[sha256sum] = "a2753c09deef0ba14d35ae8a2ceff3fe5cd13698928c7bb62c2ec8736eb09ce1"
+SRC_URI[sha256sum] = "2b0dc2540cb192525741d00f706dbc4586349185dafc65729c7fda0800cc474d"
 
 UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
 
diff --git a/meta/recipes-graphics/mesa/mesa_21.3.0.bb b/meta/recipes-graphics/mesa/mesa_21.3.1.bb
similarity index 100%
rename from meta/recipes-graphics/mesa/mesa_21.3.0.bb
rename to meta/recipes-graphics/mesa/mesa_21.3.1.bb