sqlite3: upgrade 3.36.0 -> 3.37.0

Message ID 1638198055-118993-4-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit b1c6e95d075531998de5b73e7ec7073647d5a2d2
Headers show
Series sqlite3: upgrade 3.36.0 -> 3.37.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 29, 2021, 3 p.m. UTC
Changelog:
1.STRICT tables provide a prescriptive style of data type management, for
  developers who prefer that kind of thing.
2.When adding columns that contain a CHECK constraint or a generated column
  containing a NOT NULL constraint, the ALTER TABLE ADD COLUMN now checks new
  constraints against preexisting rows in the database and will only proceed if
  no constraints are violated.
3.Added the PRAGMA table_list statement.
4.CLI enhancements:
  a.Add the .connection command, allowing the CLI to keep multiple database
    connections open at the same time.
  b.Add the --safe command-line option that disables dot-commands and SQL
    statements that might cause side-effects that extend beyond the single
    database file named on the command-line.
  c.Performance improvements when reading SQL statements that span many lines.
5.Added the sqlite3_autovacuum_pages() interface.
6.The sqlite3_deserialize() does not and has never worked for the TEMP database.
  That limitation is now noted in the documentation.
7.The query planner now omits ORDER BY clauses on subqueries and views if
  removing those clauses does not change the semantics of the query.
8.The generate_series table-valued function extension is modified so that the
  first parameter ("START") is now required. This is done as a way to
  demonstrate how to write table-valued functions with required parameters.
  The legacy behavior is available using the -DZERO_ARGUMENT_GENERATE_SERIES
  compile-time option.
9.Added new sqlite3_changes64() and sqlite3_total_changes64() interfaces.
10.Added the SQLITE_OPEN_EXRESCODE flag option to sqlite3_open_v2().
11.Use less memory to hold the database schema.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../sqlite/{sqlite3_3.36.0.bb => sqlite3_3.37.0.bb}             | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-support/sqlite/{sqlite3_3.36.0.bb => sqlite3_3.37.0.bb} (86%)

Patch

diff --git a/meta/recipes-support/sqlite/sqlite3_3.36.0.bb b/meta/recipes-support/sqlite/sqlite3_3.37.0.bb
similarity index 86%
rename from meta/recipes-support/sqlite/sqlite3_3.36.0.bb
rename to meta/recipes-support/sqlite/sqlite3_3.37.0.bb
index 30c9445be1..68394c88b0 100644
--- a/meta/recipes-support/sqlite/sqlite3_3.36.0.bb
+++ b/meta/recipes-support/sqlite/sqlite3_3.37.0.bb
@@ -4,7 +4,7 @@  LICENSE = "PD"
 LIC_FILES_CHKSUM = "file://sqlite3.h;endline=11;md5=786d3dc581eff03f4fd9e4a77ed00c66"
 
 SRC_URI = "http://www.sqlite.org/2021/sqlite-autoconf-${SQLITE_PV}.tar.gz"
-SRC_URI[sha256sum] = "bd90c3eb96bee996206b83be7065c9ce19aef38c3f4fb53073ada0d0b69bbce3"
+SRC_URI[sha256sum] = "731a4651d4d4b36fc7d21db586b2de4dd00af31fd54fb5a9a4b7f492057479f7"
 
 # -19242 is only an issue in specific development branch commits
 CVE_CHECK_WHITELIST += "CVE-2019-19242"