popt: add ptest

Message ID 0bdd8781-1174-4002-a3b6-4b3de641d2d3@denue6es010.ebgroup.elektrobit.com
State Accepted, archived
Commit ffae118e7b1bdf704d9af0ad47809c3791b672b4
Headers show
Series popt: add ptest | expand

Commit Message

Simone Weiss April 1, 2022, 2:46 p.m. UTC
Add a ptest for popt to core-image-ptest-all. Provide a patch to popt to
adopt the test format to "simple test" and a script for running the test.
All tests passed on a trial run.

Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
---
 .../distro/include/ptest-packagelists.inc     |  1 +
 ...01-popt-test-output-format-for-ptest.patch | 68 +++++++++++++++++++
 meta/recipes-support/popt/popt/run-ptest      |  3 +
 meta/recipes-support/popt/popt_1.18.bb        | 21 +++++-
 4 files changed, 91 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
 create mode 100644 meta/recipes-support/popt/popt/run-ptest

Comments

Alexander Kanavin April 1, 2022, 3:02 p.m. UTC | #1
Please submit the patch upstream first.

Alex

On Fri 1. Apr 2022 at 16.46, Simone Weiss <simone.weiss@elektrobit.com>
wrote:

> Add a ptest for popt to core-image-ptest-all. Provide a patch to popt to
> adopt the test format to "simple test" and a script for running the test.
> All tests passed on a trial run.
>
> Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> ---
>  .../distro/include/ptest-packagelists.inc     |  1 +
>  ...01-popt-test-output-format-for-ptest.patch | 68 +++++++++++++++++++
>  meta/recipes-support/popt/popt/run-ptest      |  3 +
>  meta/recipes-support/popt/popt_1.18.bb        | 21 +++++-
>  4 files changed, 91 insertions(+), 2 deletions(-)
>  create mode 100644
> meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
>  create mode 100644 meta/recipes-support/popt/popt/run-ptest
>
> diff --git a/meta/conf/distro/include/ptest-packagelists.inc
> b/meta/conf/distro/include/ptest-packagelists.inc
> index ac3295d1aa..b51cce4d9e 100644
> --- a/meta/conf/distro/include/ptest-packagelists.inc
> +++ b/meta/conf/distro/include/ptest-packagelists.inc
> @@ -48,6 +48,7 @@ PTESTS_FAST = "\
>      opkg-ptest \
>      pango-ptest \
>      parted-ptest \
> +    popt-ptest \
>      python3-atomicwrites-ptest \
>      python3-bcrypt-ptest \
>      python3-hypothesis-ptest \
> diff --git
> a/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
> b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
> new file mode 100644
> index 0000000000..020949cc34
> --- /dev/null
> +++
> b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
> @@ -0,0 +1,68 @@
> +From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00 2001
> +From: Simone Weiss <simone.weiss@elektrobit.com>
> +Date: Mon, 13 Dec 2021 09:29:53 +0000
> +Subject: [PATCH] popt test output format for ptest
> +
> +patch test output format to match simple-test as it is used in ptests.
> +
> +Upstream-Status: Pending
> +
> +Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> +Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> +---
> + tests/testit.sh | 20 ++++++++------------
> + 1 file changed, 8 insertions(+), 12 deletions(-)
> +
> +diff --git a/tests/testit.sh b/tests/testit.sh
> +index 2a7b4aa..50b42e2 100755
> +--- a/tests/testit.sh
> ++++ b/tests/testit.sh
> +@@ -5,12 +5,11 @@ run() {
> +     name=$1; shift
> +     answer=$1; shift
> +
> +-    echo Running test $name.
> +-
> +     result=`HOME=$builddir $builddir/$prog $*`
> +     if [ "$answer" != "$result" ]; then
> +-      echo "Test \"$prog $*\" failed with: \"$result\" != \"$answer\" "
> +-      exit 2
> ++        echo "FAIL: $name"
> ++    else
> ++        echo "PASS: $name"
> +     fi
> + }
> +
> +@@ -23,17 +22,17 @@ run_diff() {
> +     out=$builddir/tmp.out
> +     diff_file=$builddir/tmp.diff
> +
> +-    echo Running test $name.
> +-
> +     $builddir/$prog $in_file > $out
> +     ret=$?
> +     diff $out $answer_file > $diff_file
> +     diff_ret=$?
> +
> +     if [ "$diff_ret" != "0" ]; then
> +-       echo "Test \"$name\" failed output is in $out, diff is:"
> +-       cat $diff_file
> +-       exit 2
> ++        echo "FAIL: $name"
> ++        echo "diff is:"
> ++        cat $diff_file
> ++    else
> ++        echo "PASS: $name"
> +     fi
> +     rm $out $diff_file
> + }
> +@@ -174,6 +173,3 @@ Help options:
> + #run_diff test3 "test3 - 51" test3-data/01.input test3-data/01.answer
> + #run_diff test3 "test3 - 52" test3-data/02.input test3-data/02.answer
> + #run_diff test3 "test3 - 53" test3-data/03.input test3-data/03.answer
> +-
> +-echo ""
> +-echo "Passed."
> +--
> +2.17.1
> +
> diff --git a/meta/recipes-support/popt/popt/run-ptest
> b/meta/recipes-support/popt/popt/run-ptest
> new file mode 100644
> index 0000000000..85754035d0
> --- /dev/null
> +++ b/meta/recipes-support/popt/popt/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +./testit.sh
> diff --git a/meta/recipes-support/popt/popt_1.18.bb
> b/meta/recipes-support/popt/popt_1.18.bb
> index 057c44f223..af8add4ad6 100644
> --- a/meta/recipes-support/popt/popt_1.18.bb
> +++ b/meta/recipes-support/popt/popt_1.18.bb
> @@ -8,9 +8,26 @@ LIC_FILES_CHKSUM =
> "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
>
>  DEPENDS = "virtual/libiconv"
>
> -SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz"
> +SRC_URI = "\
> +    http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
> +    file://0001-popt-test-output-format-for-ptest.patch \
> +    file://run-ptest \
> +"
>  SRC_URI[sha256sum] =
> "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
>
> -inherit autotools gettext
> +inherit autotools gettext ptest
> +
> +RDEPENDS_${PN}-ptest += "bash"
> +
> +do_compile_ptest() {
> +    sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
> +}
> +
> +do_install_ptest() {
> +    install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
> +    install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
> +    install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
> +    install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
> +}
>
>  BBCLASSEXTEND = "native nativesdk"
> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#163940):
> https://lists.openembedded.org/g/openembedded-core/message/163940
> Mute This Topic: https://lists.openembedded.org/mt/90180554/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Alexander Kanavin April 1, 2022, 3:16 p.m. UTC | #2
Also David's email seems incorrect?

Fehler bei der Nachrichtenzustellung an folgende Empfänger oder Gruppen:

David Niederpruem (david.niederpruem@elektrobit.com)

Die eingegebene E-Mail-Adresse konnte nicht gefunden werden.
Überprüfen Sie die E-Mail-Adresse des Empfängers, und versuchen Sie,
die Nachricht erneut zu senden. Wenn das Problem weiterhin besteht,
wenden Sie sich an Ihren E-Mail-Administrator.


Alex

On Fri, 1 Apr 2022 at 16:46, Simone Weiss <simone.weiss@elektrobit.com> wrote:
>
> Add a ptest for popt to core-image-ptest-all. Provide a patch to popt to
> adopt the test format to "simple test" and a script for running the test.
> All tests passed on a trial run.
>
> Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> ---
>  .../distro/include/ptest-packagelists.inc     |  1 +
>  ...01-popt-test-output-format-for-ptest.patch | 68 +++++++++++++++++++
>  meta/recipes-support/popt/popt/run-ptest      |  3 +
>  meta/recipes-support/popt/popt_1.18.bb        | 21 +++++-
>  4 files changed, 91 insertions(+), 2 deletions(-)
>  create mode 100644 meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
>  create mode 100644 meta/recipes-support/popt/popt/run-ptest
>
> diff --git a/meta/conf/distro/include/ptest-packagelists.inc b/meta/conf/distro/include/ptest-packagelists.inc
> index ac3295d1aa..b51cce4d9e 100644
> --- a/meta/conf/distro/include/ptest-packagelists.inc
> +++ b/meta/conf/distro/include/ptest-packagelists.inc
> @@ -48,6 +48,7 @@ PTESTS_FAST = "\
>      opkg-ptest \
>      pango-ptest \
>      parted-ptest \
> +    popt-ptest \
>      python3-atomicwrites-ptest \
>      python3-bcrypt-ptest \
>      python3-hypothesis-ptest \
> diff --git a/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
> new file mode 100644
> index 0000000000..020949cc34
> --- /dev/null
> +++ b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
> @@ -0,0 +1,68 @@
> +From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00 2001
> +From: Simone Weiss <simone.weiss@elektrobit.com>
> +Date: Mon, 13 Dec 2021 09:29:53 +0000
> +Subject: [PATCH] popt test output format for ptest
> +
> +patch test output format to match simple-test as it is used in ptests.
> +
> +Upstream-Status: Pending
> +
> +Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> +Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> +---
> + tests/testit.sh | 20 ++++++++------------
> + 1 file changed, 8 insertions(+), 12 deletions(-)
> +
> +diff --git a/tests/testit.sh b/tests/testit.sh
> +index 2a7b4aa..50b42e2 100755
> +--- a/tests/testit.sh
> ++++ b/tests/testit.sh
> +@@ -5,12 +5,11 @@ run() {
> +     name=$1; shift
> +     answer=$1; shift
> +
> +-    echo Running test $name.
> +-
> +     result=`HOME=$builddir $builddir/$prog $*`
> +     if [ "$answer" != "$result" ]; then
> +-      echo "Test \"$prog $*\" failed with: \"$result\" != \"$answer\" "
> +-      exit 2
> ++        echo "FAIL: $name"
> ++    else
> ++        echo "PASS: $name"
> +     fi
> + }
> +
> +@@ -23,17 +22,17 @@ run_diff() {
> +     out=$builddir/tmp.out
> +     diff_file=$builddir/tmp.diff
> +
> +-    echo Running test $name.
> +-
> +     $builddir/$prog $in_file > $out
> +     ret=$?
> +     diff $out $answer_file > $diff_file
> +     diff_ret=$?
> +
> +     if [ "$diff_ret" != "0" ]; then
> +-       echo "Test \"$name\" failed output is in $out, diff is:"
> +-       cat $diff_file
> +-       exit 2
> ++        echo "FAIL: $name"
> ++        echo "diff is:"
> ++        cat $diff_file
> ++    else
> ++        echo "PASS: $name"
> +     fi
> +     rm $out $diff_file
> + }
> +@@ -174,6 +173,3 @@ Help options:
> + #run_diff test3 "test3 - 51" test3-data/01.input test3-data/01.answer
> + #run_diff test3 "test3 - 52" test3-data/02.input test3-data/02.answer
> + #run_diff test3 "test3 - 53" test3-data/03.input test3-data/03.answer
> +-
> +-echo ""
> +-echo "Passed."
> +--
> +2.17.1
> +
> diff --git a/meta/recipes-support/popt/popt/run-ptest b/meta/recipes-support/popt/popt/run-ptest
> new file mode 100644
> index 0000000000..85754035d0
> --- /dev/null
> +++ b/meta/recipes-support/popt/popt/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +./testit.sh
> diff --git a/meta/recipes-support/popt/popt_1.18.bb b/meta/recipes-support/popt/popt_1.18.bb
> index 057c44f223..af8add4ad6 100644
> --- a/meta/recipes-support/popt/popt_1.18.bb
> +++ b/meta/recipes-support/popt/popt_1.18.bb
> @@ -8,9 +8,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
>
>  DEPENDS = "virtual/libiconv"
>
> -SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz"
> +SRC_URI = "\
> +    http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
> +    file://0001-popt-test-output-format-for-ptest.patch \
> +    file://run-ptest \
> +"
>  SRC_URI[sha256sum] = "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
>
> -inherit autotools gettext
> +inherit autotools gettext ptest
> +
> +RDEPENDS_${PN}-ptest += "bash"
> +
> +do_compile_ptest() {
> +    sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
> +}
> +
> +do_install_ptest() {
> +    install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
> +    install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
> +    install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
> +    install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
> +}
>
>  BBCLASSEXTEND = "native nativesdk"
> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#163940): https://lists.openembedded.org/g/openembedded-core/message/163940
> Mute This Topic: https://lists.openembedded.org/mt/90180554/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Simone Weiss April 4, 2022, 10:48 a.m. UTC | #3
Hello,

Thanks for the reply. Sure, I can also submit the patch to popt first.
Regarding David's mail address: The person does not work at my company
anymore, hence this mail address is not valid. What would be suggested
in this case?

Thanks,
Simone
As it is my first time submitting here
On Fri, 2022-04-01 at 17:16 +0200, Alexander Kanavin via
lists.openembedded.org wrote:
> CAUTION: This email originated from outside of the Elektrobit
> organization. Do not click links or open attachments unless you
> recognize the sender and know the content is safe.
> 
> 
> Also David's email seems incorrect?
> 
> Fehler bei der Nachrichtenzustellung an folgende Empfänger oder
> Gruppen:
> 
> David Niederpruem (david.niederpruem@elektrobit.com)
> 
> Die eingegebene E-Mail-Adresse konnte nicht gefunden werden.
> Überprüfen Sie die E-Mail-Adresse des Empfängers, und versuchen Sie,
> die Nachricht erneut zu senden. Wenn das Problem weiterhin besteht,
> wenden Sie sich an Ihren E-Mail-Administrator.
> 
> 
> Alex
> 
> On Fri, 1 Apr 2022 at 16:46, Simone Weiss <
> simone.weiss@elektrobit.com> wrote:
> > 
> > Add a ptest for popt to core-image-ptest-all. Provide a patch to
> > popt to
> > adopt the test format to "simple test" and a script for running the
> > test.
> > All tests passed on a trial run.
> > 
> > Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> > Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> > ---
> >  .../distro/include/ptest-packagelists.inc     |  1 +
> >  ...01-popt-test-output-format-for-ptest.patch | 68
> > +++++++++++++++++++
> >  meta/recipes-support/popt/popt/run-ptest      |  3 +
> >  meta/recipes-support/popt/popt_1.18.bb        | 21 +++++-
> >  4 files changed, 91 insertions(+), 2 deletions(-)
> >  create mode 100644 meta/recipes-support/popt/popt/0001-popt-test-
> > output-format-for-ptest.patch
> >  create mode 100644 meta/recipes-support/popt/popt/run-ptest
> > 
> > diff --git a/meta/conf/distro/include/ptest-packagelists.inc
> > b/meta/conf/distro/include/ptest-packagelists.inc
> > index ac3295d1aa..b51cce4d9e 100644
> > --- a/meta/conf/distro/include/ptest-packagelists.inc
> > +++ b/meta/conf/distro/include/ptest-packagelists.inc
> > @@ -48,6 +48,7 @@ PTESTS_FAST = "\
> >      opkg-ptest \
> >      pango-ptest \
> >      parted-ptest \
> > +    popt-ptest \
> >      python3-atomicwrites-ptest \
> >      python3-bcrypt-ptest \
> >      python3-hypothesis-ptest \
> > diff --git a/meta/recipes-support/popt/popt/0001-popt-test-output-
> > format-for-ptest.patch b/meta/recipes-support/popt/popt/0001-popt-
> > test-output-format-for-ptest.patch
> > new file mode 100644
> > index 0000000000..020949cc34
> > --- /dev/null
> > +++ b/meta/recipes-support/popt/popt/0001-popt-test-output-format-
> > for-ptest.patch
> > @@ -0,0 +1,68 @@
> > +From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00
> > 2001
> > +From: Simone Weiss <simone.weiss@elektrobit.com>
> > +Date: Mon, 13 Dec 2021 09:29:53 +0000
> > +Subject: [PATCH] popt test output format for ptest
> > +
> > +patch test output format to match simple-test as it is used in
> > ptests.
> > +
> > +Upstream-Status: Pending
> > +
> > +Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> > +Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com
> > >
> > +---
> > + tests/testit.sh | 20 ++++++++------------
> > + 1 file changed, 8 insertions(+), 12 deletions(-)
> > +
> > +diff --git a/tests/testit.sh b/tests/testit.sh
> > +index 2a7b4aa..50b42e2 100755
> > +--- a/tests/testit.sh
> > ++++ b/tests/testit.sh
> > +@@ -5,12 +5,11 @@ run() {
> > +     name=$1; shift
> > +     answer=$1; shift
> > +
> > +-    echo Running test $name.
> > +-
> > +     result=`HOME=$builddir $builddir/$prog $*`
> > +     if [ "$answer" != "$result" ]; then
> > +-      echo "Test \"$prog $*\" failed with: \"$result\" !=
> > \"$answer\" "
> > +-      exit 2
> > ++        echo "FAIL: $name"
> > ++    else
> > ++        echo "PASS: $name"
> > +     fi
> > + }
> > +
> > +@@ -23,17 +22,17 @@ run_diff() {
> > +     out=$builddir/tmp.out
> > +     diff_file=$builddir/tmp.diff
> > +
> > +-    echo Running test $name.
> > +-
> > +     $builddir/$prog $in_file > $out
> > +     ret=$?
> > +     diff $out $answer_file > $diff_file
> > +     diff_ret=$?
> > +
> > +     if [ "$diff_ret" != "0" ]; then
> > +-       echo "Test \"$name\" failed output is in $out, diff is:"
> > +-       cat $diff_file
> > +-       exit 2
> > ++        echo "FAIL: $name"
> > ++        echo "diff is:"
> > ++        cat $diff_file
> > ++    else
> > ++        echo "PASS: $name"
> > +     fi
> > +     rm $out $diff_file
> > + }
> > +@@ -174,6 +173,3 @@ Help options:
> > + #run_diff test3 "test3 - 51" test3-data/01.input test3-
> > data/01.answer
> > + #run_diff test3 "test3 - 52" test3-data/02.input test3-
> > data/02.answer
> > + #run_diff test3 "test3 - 53" test3-data/03.input test3-
> > data/03.answer
> > +-
> > +-echo ""
> > +-echo "Passed."
> > +--
> > +2.17.1
> > +
> > diff --git a/meta/recipes-support/popt/popt/run-ptest
> > b/meta/recipes-support/popt/popt/run-ptest
> > new file mode 100644
> > index 0000000000..85754035d0
> > --- /dev/null
> > +++ b/meta/recipes-support/popt/popt/run-ptest
> > @@ -0,0 +1,3 @@
> > +#!/bin/sh
> > +
> > +./testit.sh
> > diff --git a/meta/recipes-support/popt/popt_1.18.bb b/meta/recipes-
> > support/popt/popt_1.18.bb
> > index 057c44f223..af8add4ad6 100644
> > --- a/meta/recipes-support/popt/popt_1.18.bb
> > +++ b/meta/recipes-support/popt/popt_1.18.bb
> > @@ -8,9 +8,26 @@ LIC_FILES_CHKSUM = "
> > file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
> > 
> >  DEPENDS = "virtual/libiconv"
> > 
> > -SRC_URI = "
> > https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fftp.rpm.org%2Fpopt%2Freleases%2Fpopt-1.x%2F%24&amp;data=04%7C01%7C%7Cc083213936af41f0aafa08da13f29c80%7Ce764c36b012e4216910d8fd16283182d%7C0%7C0%7C637844229994294094%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=QLCrgNayolk0racWmUMDZQAEL7Qigg1yhpvovU4Bwzc%3D&amp;reserved=0{BP}.tar.gz
> > "
> > +SRC_URI = "\
> > +    
> > https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fftp.rpm.org%2Fpopt%2Freleases%2Fpopt-1.x%2F%24&amp;data=04%7C01%7C%7Cc083213936af41f0aafa08da13f29c80%7Ce764c36b012e4216910d8fd16283182d%7C0%7C0%7C637844229994294094%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=QLCrgNayolk0racWmUMDZQAEL7Qigg1yhpvovU4Bwzc%3D&amp;reserved=0{BP}.tar.gz
> >  \
> > +    file://0001-popt-test-output-format-for-ptest.patch \
> > +    file://run-ptest \
> > +"
> >  SRC_URI[sha256sum] =
> > "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
> > 
> > -inherit autotools gettext
> > +inherit autotools gettext ptest
> > +
> > +RDEPENDS_${PN}-ptest += "bash"
> > +
> > +do_compile_ptest() {
> > +    sed 's#lt-test1#test1#g' ${S}/tests/testit.sh >
> > ${B}/tests/testit.sh
> > +}
> > +
> > +do_install_ptest() {
> > +    install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
> > +    install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
> > +    install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
> > +    install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
> > +}
> > 
> >  BBCLASSEXTEND = "native nativesdk"
> > --
> > 2.17.1
> > 
> > 
> > 
> > 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#163942): 
> https://lists.openembedded.org/g/openembedded-core/message/163942
> Mute This Topic: https://lists.openembedded.org/mt/90180554/6639279
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub
>  [simone.weiss@elektrobit.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexander Kanavin April 4, 2022, 11:57 a.m. UTC | #4
Hello Simone,

if they were involved in making this patch, then signed-off-by should
be changed to their current email address. Or you can simply remove
that line if you don't know how to reach them.

Alex

On Mon, 4 Apr 2022 at 12:48, Weiß, Simone <Simone.Weiss@elektrobit.com> wrote:
>
> Hello,
>
> Thanks for the reply. Sure, I can also submit the patch to popt first.
> Regarding David's mail address: The person does not work at my company
> anymore, hence this mail address is not valid. What would be suggested
> in this case?
>
> Thanks,
> Simone
> As it is my first time submitting here
> On Fri, 2022-04-01 at 17:16 +0200, Alexander Kanavin via
> lists.openembedded.org wrote:
> > CAUTION: This email originated from outside of the Elektrobit
> > organization. Do not click links or open attachments unless you
> > recognize the sender and know the content is safe.
> >
> >
> > Also David's email seems incorrect?
> >
> > Fehler bei der Nachrichtenzustellung an folgende Empfänger oder
> > Gruppen:
> >
> > David Niederpruem (david.niederpruem@elektrobit.com)
> >
> > Die eingegebene E-Mail-Adresse konnte nicht gefunden werden.
> > Überprüfen Sie die E-Mail-Adresse des Empfängers, und versuchen Sie,
> > die Nachricht erneut zu senden. Wenn das Problem weiterhin besteht,
> > wenden Sie sich an Ihren E-Mail-Administrator.
> >
> >
> > Alex
> >
> > On Fri, 1 Apr 2022 at 16:46, Simone Weiss <
> > simone.weiss@elektrobit.com> wrote:
> > >
> > > Add a ptest for popt to core-image-ptest-all. Provide a patch to
> > > popt to
> > > adopt the test format to "simple test" and a script for running the
> > > test.
> > > All tests passed on a trial run.
> > >
> > > Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> > > Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
> > > ---
> > >  .../distro/include/ptest-packagelists.inc     |  1 +
> > >  ...01-popt-test-output-format-for-ptest.patch | 68
> > > +++++++++++++++++++
> > >  meta/recipes-support/popt/popt/run-ptest      |  3 +
> > >  meta/recipes-support/popt/popt_1.18.bb        | 21 +++++-
> > >  4 files changed, 91 insertions(+), 2 deletions(-)
> > >  create mode 100644 meta/recipes-support/popt/popt/0001-popt-test-
> > > output-format-for-ptest.patch
> > >  create mode 100644 meta/recipes-support/popt/popt/run-ptest
> > >
> > > diff --git a/meta/conf/distro/include/ptest-packagelists.inc
> > > b/meta/conf/distro/include/ptest-packagelists.inc
> > > index ac3295d1aa..b51cce4d9e 100644
> > > --- a/meta/conf/distro/include/ptest-packagelists.inc
> > > +++ b/meta/conf/distro/include/ptest-packagelists.inc
> > > @@ -48,6 +48,7 @@ PTESTS_FAST = "\
> > >      opkg-ptest \
> > >      pango-ptest \
> > >      parted-ptest \
> > > +    popt-ptest \
> > >      python3-atomicwrites-ptest \
> > >      python3-bcrypt-ptest \
> > >      python3-hypothesis-ptest \
> > > diff --git a/meta/recipes-support/popt/popt/0001-popt-test-output-
> > > format-for-ptest.patch b/meta/recipes-support/popt/popt/0001-popt-
> > > test-output-format-for-ptest.patch
> > > new file mode 100644
> > > index 0000000000..020949cc34
> > > --- /dev/null
> > > +++ b/meta/recipes-support/popt/popt/0001-popt-test-output-format-
> > > for-ptest.patch
> > > @@ -0,0 +1,68 @@
> > > +From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00
> > > 2001
> > > +From: Simone Weiss <simone.weiss@elektrobit.com>
> > > +Date: Mon, 13 Dec 2021 09:29:53 +0000
> > > +Subject: [PATCH] popt test output format for ptest
> > > +
> > > +patch test output format to match simple-test as it is used in
> > > ptests.
> > > +
> > > +Upstream-Status: Pending
> > > +
> > > +Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
> > > +Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com
> > > >
> > > +---
> > > + tests/testit.sh | 20 ++++++++------------
> > > + 1 file changed, 8 insertions(+), 12 deletions(-)
> > > +
> > > +diff --git a/tests/testit.sh b/tests/testit.sh
> > > +index 2a7b4aa..50b42e2 100755
> > > +--- a/tests/testit.sh
> > > ++++ b/tests/testit.sh
> > > +@@ -5,12 +5,11 @@ run() {
> > > +     name=$1; shift
> > > +     answer=$1; shift
> > > +
> > > +-    echo Running test $name.
> > > +-
> > > +     result=`HOME=$builddir $builddir/$prog $*`
> > > +     if [ "$answer" != "$result" ]; then
> > > +-      echo "Test \"$prog $*\" failed with: \"$result\" !=
> > > \"$answer\" "
> > > +-      exit 2
> > > ++        echo "FAIL: $name"
> > > ++    else
> > > ++        echo "PASS: $name"
> > > +     fi
> > > + }
> > > +
> > > +@@ -23,17 +22,17 @@ run_diff() {
> > > +     out=$builddir/tmp.out
> > > +     diff_file=$builddir/tmp.diff
> > > +
> > > +-    echo Running test $name.
> > > +-
> > > +     $builddir/$prog $in_file > $out
> > > +     ret=$?
> > > +     diff $out $answer_file > $diff_file
> > > +     diff_ret=$?
> > > +
> > > +     if [ "$diff_ret" != "0" ]; then
> > > +-       echo "Test \"$name\" failed output is in $out, diff is:"
> > > +-       cat $diff_file
> > > +-       exit 2
> > > ++        echo "FAIL: $name"
> > > ++        echo "diff is:"
> > > ++        cat $diff_file
> > > ++    else
> > > ++        echo "PASS: $name"
> > > +     fi
> > > +     rm $out $diff_file
> > > + }
> > > +@@ -174,6 +173,3 @@ Help options:
> > > + #run_diff test3 "test3 - 51" test3-data/01.input test3-
> > > data/01.answer
> > > + #run_diff test3 "test3 - 52" test3-data/02.input test3-
> > > data/02.answer
> > > + #run_diff test3 "test3 - 53" test3-data/03.input test3-
> > > data/03.answer
> > > +-
> > > +-echo ""
> > > +-echo "Passed."
> > > +--
> > > +2.17.1
> > > +
> > > diff --git a/meta/recipes-support/popt/popt/run-ptest
> > > b/meta/recipes-support/popt/popt/run-ptest
> > > new file mode 100644
> > > index 0000000000..85754035d0
> > > --- /dev/null
> > > +++ b/meta/recipes-support/popt/popt/run-ptest
> > > @@ -0,0 +1,3 @@
> > > +#!/bin/sh
> > > +
> > > +./testit.sh
> > > diff --git a/meta/recipes-support/popt/popt_1.18.bb b/meta/recipes-
> > > support/popt/popt_1.18.bb
> > > index 057c44f223..af8add4ad6 100644
> > > --- a/meta/recipes-support/popt/popt_1.18.bb
> > > +++ b/meta/recipes-support/popt/popt_1.18.bb
> > > @@ -8,9 +8,26 @@ LIC_FILES_CHKSUM = "
> > > file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
> > >
> > >  DEPENDS = "virtual/libiconv"
> > >
> > > -SRC_URI = "
> > > https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fftp.rpm.org%2Fpopt%2Freleases%2Fpopt-1.x%2F%24&amp;data=04%7C01%7C%7Cc083213936af41f0aafa08da13f29c80%7Ce764c36b012e4216910d8fd16283182d%7C0%7C0%7C637844229994294094%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=QLCrgNayolk0racWmUMDZQAEL7Qigg1yhpvovU4Bwzc%3D&amp;reserved=0{BP}.tar.gz
> > > "
> > > +SRC_URI = "\
> > > +
> > > https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Fftp.rpm.org%2Fpopt%2Freleases%2Fpopt-1.x%2F%24&amp;data=04%7C01%7C%7Cc083213936af41f0aafa08da13f29c80%7Ce764c36b012e4216910d8fd16283182d%7C0%7C0%7C637844229994294094%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=QLCrgNayolk0racWmUMDZQAEL7Qigg1yhpvovU4Bwzc%3D&amp;reserved=0{BP}.tar.gz
> > >  \
> > > +    file://0001-popt-test-output-format-for-ptest.patch \
> > > +    file://run-ptest \
> > > +"
> > >  SRC_URI[sha256sum] =
> > > "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
> > >
> > > -inherit autotools gettext
> > > +inherit autotools gettext ptest
> > > +
> > > +RDEPENDS_${PN}-ptest += "bash"
> > > +
> > > +do_compile_ptest() {
> > > +    sed 's#lt-test1#test1#g' ${S}/tests/testit.sh >
> > > ${B}/tests/testit.sh
> > > +}
> > > +
> > > +do_install_ptest() {
> > > +    install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
> > > +    install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
> > > +    install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
> > > +    install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
> > > +}
> > >
> > >  BBCLASSEXTEND = "native nativesdk"
> > > --
> > > 2.17.1
> > >
> > >
> > >
> > >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#163942):
> > https://lists.openembedded.org/g/openembedded-core/message/163942
> > Mute This Topic: https://lists.openembedded.org/mt/90180554/6639279
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub
> >  [simone.weiss@elektrobit.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >

Patch

diff --git a/meta/conf/distro/include/ptest-packagelists.inc b/meta/conf/distro/include/ptest-packagelists.inc
index ac3295d1aa..b51cce4d9e 100644
--- a/meta/conf/distro/include/ptest-packagelists.inc
+++ b/meta/conf/distro/include/ptest-packagelists.inc
@@ -48,6 +48,7 @@  PTESTS_FAST = "\
     opkg-ptest \
     pango-ptest \
     parted-ptest \
+    popt-ptest \
     python3-atomicwrites-ptest \
     python3-bcrypt-ptest \
     python3-hypothesis-ptest \
diff --git a/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
new file mode 100644
index 0000000000..020949cc34
--- /dev/null
+++ b/meta/recipes-support/popt/popt/0001-popt-test-output-format-for-ptest.patch
@@ -0,0 +1,68 @@ 
+From 330b77081c3a4c7ae76cb08602db385b40fa7ff7 Mon Sep 17 00:00:00 2001
+From: Simone Weiss <simone.weiss@elektrobit.com>
+Date: Mon, 13 Dec 2021 09:29:53 +0000
+Subject: [PATCH] popt test output format for ptest
+
+patch test output format to match simple-test as it is used in ptests.
+
+Upstream-Status: Pending
+    
+Signed-off-by: Simone Weiss <simone.weiss@elektrobit.com>
+Signed-off-by: David Niederpruem <david.niederpruem@elektrobit.com>
+---
+ tests/testit.sh | 20 ++++++++------------
+ 1 file changed, 8 insertions(+), 12 deletions(-)
+
+diff --git a/tests/testit.sh b/tests/testit.sh
+index 2a7b4aa..50b42e2 100755
+--- a/tests/testit.sh
++++ b/tests/testit.sh
+@@ -5,12 +5,11 @@ run() {
+     name=$1; shift
+     answer=$1; shift
+ 
+-    echo Running test $name.
+-
+     result=`HOME=$builddir $builddir/$prog $*`
+     if [ "$answer" != "$result" ]; then
+-	echo "Test \"$prog $*\" failed with: \"$result\" != \"$answer\" "
+-	exit 2
++        echo "FAIL: $name"
++    else
++        echo "PASS: $name"
+     fi
+ }
+ 
+@@ -23,17 +22,17 @@ run_diff() {
+     out=$builddir/tmp.out
+     diff_file=$builddir/tmp.diff
+ 
+-    echo Running test $name.
+-
+     $builddir/$prog $in_file > $out
+     ret=$?
+     diff $out $answer_file > $diff_file
+     diff_ret=$?
+ 
+     if [ "$diff_ret" != "0" ]; then
+-       echo "Test \"$name\" failed output is in $out, diff is:"
+-       cat $diff_file
+-       exit 2
++        echo "FAIL: $name"
++        echo "diff is:"
++        cat $diff_file
++    else
++        echo "PASS: $name"
+     fi
+     rm $out $diff_file
+ }
+@@ -174,6 +173,3 @@ Help options:
+ #run_diff test3 "test3 - 51" test3-data/01.input test3-data/01.answer
+ #run_diff test3 "test3 - 52" test3-data/02.input test3-data/02.answer
+ #run_diff test3 "test3 - 53" test3-data/03.input test3-data/03.answer
+-
+-echo ""
+-echo "Passed."
+-- 
+2.17.1
+
diff --git a/meta/recipes-support/popt/popt/run-ptest b/meta/recipes-support/popt/popt/run-ptest
new file mode 100644
index 0000000000..85754035d0
--- /dev/null
+++ b/meta/recipes-support/popt/popt/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+./testit.sh
diff --git a/meta/recipes-support/popt/popt_1.18.bb b/meta/recipes-support/popt/popt_1.18.bb
index 057c44f223..af8add4ad6 100644
--- a/meta/recipes-support/popt/popt_1.18.bb
+++ b/meta/recipes-support/popt/popt_1.18.bb
@@ -8,9 +8,26 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=cb0613c30af2a8249b8dcc67d3edb06d"
 
 DEPENDS = "virtual/libiconv"
 
-SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz"
+SRC_URI = "\
+    http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
+    file://0001-popt-test-output-format-for-ptest.patch \
+    file://run-ptest \
+"
 SRC_URI[sha256sum] = "5159bc03a20b28ce363aa96765f37df99ea4d8850b1ece17d1e6ad5c24fdc5d1"
 
-inherit autotools gettext
+inherit autotools gettext ptest
+
+RDEPENDS_${PN}-ptest += "bash"
+
+do_compile_ptest() {
+    sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
+}
+
+do_install_ptest() {
+    install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
+    install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
+    install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
+    install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
+}
 
 BBCLASSEXTEND = "native nativesdk"