diff mbox series

libtirpc: Support ipv6 in DISTRO_FEATURES

Message ID 0970d630a7876bb902557710603578d0d82d8047.1697113042.git.joerg.sommer@navimatix.de
State Accepted, archived
Commit f1109380a4fec02dba0b5bd50c77b4825faa20a2
Headers show
Series libtirpc: Support ipv6 in DISTRO_FEATURES | expand

Commit Message

Jörg Sommer Oct. 12, 2023, 12:17 p.m. UTC
If the ipv6 feature for the distribution is not set, the package should not
contain settings for ipv6. This makes rpcbind doesn't try to bind to a IPv6
socket, and complain that this fails.

Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
---
 meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb | 14 +++++++++++++-
 1 file changed, 13 insertions(+), 1 deletion(-)

Comments

Alexander Kanavin Oct. 12, 2023, 12:23 p.m. UTC | #1
If netconfig file comes from the upstream source, then it should be
correctly patched or dynamically formed at that point, and not after the
fact at installation. Why aren’t the ipv6 enable/disable options taking
care of it?

Alex

On Thu 12. Oct 2023 at 14.17, Jörg Sommer via lists.openembedded.org
<joerg.sommer=navimatix.de@lists.openembedded.org> wrote:

> If the ipv6 feature for the distribution is not set, the package should not
> contain settings for ipv6. This makes rpcbind doesn't try to bind to a IPv6
> socket, and complain that this fails.
>
> Signed-off-by: Jörg Sommer <joerg.sommer@navimatix.de>
> ---
>  meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb | 14 +++++++++++++-
>  1 file changed, 13 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> index 6980135a92..14db4a5eda 100644
> --- a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> +++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
> @@ -20,8 +20,20 @@ inherit autotools pkgconfig
>
>  EXTRA_OECONF = "--disable-gssapi"
>
> +PACKAGECONFIG ??= " \
> +    ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
> +"
> +PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
> +
>  do_install:append() {
> -       test -e ${D}${sysconfdir}/netconfig && chown root:root
> ${D}${sysconfdir}/netconfig
> +       if test -e ${D}${sysconfdir}/netconfig
> +       then
> +               if ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6',
> 'false', 'true', d)}
> +               then
> +                       sed -i '/^tcp6\|^udp6/d'
> ${D}${sysconfdir}/netconfig
> +               fi
> +               chown root:root ${D}${sysconfdir}/netconfig
> +       fi
>  }
>
>  BBCLASSEXTEND = "native nativesdk"
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#188993):
> https://lists.openembedded.org/g/openembedded-core/message/188993
> Mute This Topic: https://lists.openembedded.org/mt/101916628/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
index 6980135a92..14db4a5eda 100644
--- a/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
+++ b/meta/recipes-extended/libtirpc/libtirpc_1.3.2.bb
@@ -20,8 +20,20 @@  inherit autotools pkgconfig
 
 EXTRA_OECONF = "--disable-gssapi"
 
+PACKAGECONFIG ??= " \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
+"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
+
 do_install:append() {
-	test -e ${D}${sysconfdir}/netconfig && chown root:root ${D}${sysconfdir}/netconfig
+	if test -e ${D}${sysconfdir}/netconfig
+	then
+		if ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'false', 'true', d)}
+		then
+			sed -i '/^tcp6\|^udp6/d' ${D}${sysconfdir}/netconfig
+		fi
+		chown root:root ${D}${sysconfdir}/netconfig
+	fi
 }
 
 BBCLASSEXTEND = "native nativesdk"