diff mbox series

[mickledore,17/18] curl: ensure all ptest failures are caught

Message ID 066576439bf0799188d6f0901971639d858cfdcf.1692116535.git.steve@sakoman.com
State New
Headers show
Series [mickledore,01/18] qemu: fix CVE-2023-3301 | expand

Commit Message

Steve Sakoman Aug. 15, 2023, 4:24 p.m. UTC
From: Alexander Kanavin <alex.kanavin@gmail.com>

Piping results through sed is masking failures that aren't
picked up by sed expressions.

One such failure probes the source tree, and so isn't
relevant for target testing, and can be disabled.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 86c96cbf68d986b44fdb45e988343ce29d6b8cc7)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-support/curl/curl/disable-tests | 2 ++
 meta/recipes-support/curl/curl/run-ptest     | 2 +-
 2 files changed, 3 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl/disable-tests b/meta/recipes-support/curl/curl/disable-tests
index 92056bd8ca..b687b2bb76 100644
--- a/meta/recipes-support/curl/curl/disable-tests
+++ b/meta/recipes-support/curl/curl/disable-tests
@@ -18,6 +18,8 @@ 
 1165
 # This CRL test is looking for src files
 1185
+# This test is scanning the source tree
+1222
 # These CRL tests need --libcurl option to be enabled
 1400
 1401
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 614e822922..2c74c58f5d 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,6 @@ 
 #!/bin/sh
 cd tests
-./runtests.pl -a -n -s | sed \
+{ ./runtests.pl -a -n -s || echo "FAIL: curl" ; } | sed \
      -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
      -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
      -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'