diff mbox series

[1/3] kern-tools: fix relative path processing

Message ID 00d1b34b5d92325ea31564c0f7f4a5876f2e2edc.1666150638.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit 533720a1756454447341769c4a0969fce8d6f287
Headers show
Series [1/3] kern-tools: fix relative path processing | expand

Commit Message

Bruce Ashfield Oct. 19, 2022, 3:39 a.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

The previous fix for processing of paths with relative components, broke
uses cases that were a mix of patches and configuration fragments.

Updating the SRCREV to include a simplied fix for relative paths, and
a cleanup patch from Jose:

[
  Author: Jose Quaresma <quaresma.jose@gmail.com>
  Date:   Thu Sep 29 16:37:23 2022 +0000

      scc: only look for error in scc_output_file if it has valid content

      When process_file function fails the output of the processed script is show to
      the user, some parsing is performed as well to look for common errors so we
      can point to the right input file.

      This can only be done when the scc_output_file have some valid content
      otherwise it will show invalid messages to the user.

      Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
      Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>

  Author: Bruce Ashfield <bruce.ashfield@gmail.com>
  Date:   Wed Oct 5 19:13:33 2022 +0000

      spp: ensure that prefix check uses absolute paths

      The previous fix for this issue was too broad, and impacted
      all calls to the prefix check and removal. With this change,
      we only expand the input on scc/spp operations that may
      execute with relative paths.

      Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
]

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/kern-tools/kern-tools-native_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Jose Quaresma Nov. 2, 2022, 9:31 a.m. UTC | #1
Hi Steve,

Can this patch be backported to kirkstone?

Jose

Bruce Ashfield <bruce.ashfield@gmail.com> escreveu no dia quarta,
19/10/2022 à(s) 04:39:

> From: Bruce Ashfield <bruce.ashfield@gmail.com>
>
> The previous fix for processing of paths with relative components, broke
> uses cases that were a mix of patches and configuration fragments.
>
> Updating the SRCREV to include a simplied fix for relative paths, and
> a cleanup patch from Jose:
>
> [
>   Author: Jose Quaresma <quaresma.jose@gmail.com>
>   Date:   Thu Sep 29 16:37:23 2022 +0000
>
>       scc: only look for error in scc_output_file if it has valid content
>
>       When process_file function fails the output of the processed script
> is show to
>       the user, some parsing is performed as well to look for common
> errors so we
>       can point to the right input file.
>
>       This can only be done when the scc_output_file have some valid
> content
>       otherwise it will show invalid messages to the user.
>
>       Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
>       Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
>
>   Author: Bruce Ashfield <bruce.ashfield@gmail.com>
>   Date:   Wed Oct 5 19:13:33 2022 +0000
>
>       spp: ensure that prefix check uses absolute paths
>
>       The previous fix for this issue was too broad, and impacted
>       all calls to the prefix check and removal. With this change,
>       we only expand the input on scc/spp operations that may
>       execute with relative paths.
>
>       Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> ]
>
> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/kern-tools/kern-tools-native_git.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
> b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
> index dea7b65a7c..07d7daf5fb 100644
> --- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
> +++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
> @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "\
>
>  DEPENDS = "git-native"
>
> -SRCREV = "ba600ef61a85966596126a6e8d936971905e8749"
> +SRCREV = "6a4752ebbe7d242c02b3c74a5772926edd243626"
>  PV = "0.3+git${SRCPV}"
>
>  inherit native
> --
> 2.19.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171951):
> https://lists.openembedded.org/g/openembedded-core/message/171951
> Mute This Topic: https://lists.openembedded.org/mt/94424337/5052612
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> quaresma.jose@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Steve Sakoman Nov. 4, 2022, 2:36 p.m. UTC | #2
On Tue, Nov 1, 2022 at 11:32 PM Jose Quaresma <quaresma.jose@gmail.com> wrote:

> Can this patch be backported to kirkstone?

Yes, I will add it to my list.

Steve

> Bruce Ashfield <bruce.ashfield@gmail.com> escreveu no dia quarta, 19/10/2022 à(s) 04:39:
>>
>> From: Bruce Ashfield <bruce.ashfield@gmail.com>
>>
>> The previous fix for processing of paths with relative components, broke
>> uses cases that were a mix of patches and configuration fragments.
>>
>> Updating the SRCREV to include a simplied fix for relative paths, and
>> a cleanup patch from Jose:
>>
>> [
>>   Author: Jose Quaresma <quaresma.jose@gmail.com>
>>   Date:   Thu Sep 29 16:37:23 2022 +0000
>>
>>       scc: only look for error in scc_output_file if it has valid content
>>
>>       When process_file function fails the output of the processed script is show to
>>       the user, some parsing is performed as well to look for common errors so we
>>       can point to the right input file.
>>
>>       This can only be done when the scc_output_file have some valid content
>>       otherwise it will show invalid messages to the user.
>>
>>       Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
>>       Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
>>
>>   Author: Bruce Ashfield <bruce.ashfield@gmail.com>
>>   Date:   Wed Oct 5 19:13:33 2022 +0000
>>
>>       spp: ensure that prefix check uses absolute paths
>>
>>       The previous fix for this issue was too broad, and impacted
>>       all calls to the prefix check and removal. With this change,
>>       we only expand the input on scc/spp operations that may
>>       execute with relative paths.
>>
>>       Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
>> ]
>>
>> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
>> ---
>>  meta/recipes-kernel/kern-tools/kern-tools-native_git.bb | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
>> index dea7b65a7c..07d7daf5fb 100644
>> --- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
>> +++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
>> @@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "\
>>
>>  DEPENDS = "git-native"
>>
>> -SRCREV = "ba600ef61a85966596126a6e8d936971905e8749"
>> +SRCREV = "6a4752ebbe7d242c02b3c74a5772926edd243626"
>>  PV = "0.3+git${SRCPV}"
>>
>>  inherit native
>> --
>> 2.19.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#171951): https://lists.openembedded.org/g/openembedded-core/message/171951
>> Mute This Topic: https://lists.openembedded.org/mt/94424337/5052612
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [quaresma.jose@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>
>
> --
> Best regards,
>
> José Quaresma
diff mbox series

Patch

diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index dea7b65a7c..07d7daf5fb 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -11,7 +11,7 @@  LIC_FILES_CHKSUM = "\
 
 DEPENDS = "git-native"
 
-SRCREV = "ba600ef61a85966596126a6e8d936971905e8749"
+SRCREV = "6a4752ebbe7d242c02b3c74a5772926edd243626"
 PV = "0.3+git${SRCPV}"
 
 inherit native