diff mbox series

[1/8] Toaster: Update toaster-requirements.txt to add pytest and some plugin's

Message ID 20231030195037.232912-1-alassane.yattara@savoirfairelinux.com
State New
Headers show
Series [1/8] Toaster: Update toaster-requirements.txt to add pytest and some plugin's | expand

Commit Message

Alassane Yattara Oct. 30, 2023, 7:50 p.m. UTC
The pytest framework makes it easy to write small, readable tests, and can scale
to support complex functional testing for applications and libraries.
- Pytest-html is a plugin for pytest that generates a HTML report for test results.
- Pytest-django allows us to test Django project/applications with the pytest testing tool.
- Pytest-env is a pytest plugin that enables us to set environment variables in a pytest.ini or pyproject.toml file

Signed-off-by: Alassane Yattara <alassane.yattara@savoirfairelinux.com>
---
 toaster-requirements.txt | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Tim Orling Oct. 31, 2023, 2:22 p.m. UTC | #1
On Mon, Oct 30, 2023 at 12:51 PM Alassane Yattara <
alassane.yattara@savoirfairelinux.com> wrote:

> The pytest framework makes it easy to write small, readable tests, and can
> scale
> to support complex functional testing for applications and libraries.
> - Pytest-html is a plugin for pytest that generates a HTML report for test
> results.
>

This may be useful for local testing, but we do not use HTML in general for
test results on the AutoBuilder.


> - Pytest-django allows us to test Django project/applications with the
> pytest testing tool.
> - Pytest-env is a pytest plugin that enables us to set environment
> variables in a pytest.ini or pyproject.toml file
>
> These two seem sensible.

You didn't mention pytest-metadata, but it looks like it will be useful to
report out the system configuration:
 https://pypi.org/project/pytest-metadata/

Signed-off-by: Alassane Yattara <alassane.yattara@savoirfairelinux.com>
>

Reviewed-by: Tim Orling <tim.orling@konsulko.com>


> ---
>  toaster-requirements.txt | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/toaster-requirements.txt b/toaster-requirements.txt
> index d8e48b7f..19bf6fd2 100644
> --- a/toaster-requirements.txt
> +++ b/toaster-requirements.txt
> @@ -2,3 +2,8 @@ Django>4.2,<4.3
>  beautifulsoup4>=4.4.0
>  pytz
>  django-log-viewer==1.1.7
> +pytest==7.4.2
> +pytest-django==4.5.2
> +pytest-env==1.1.0
> +pytest-html==4.0.2
> +pytest-metadata==3.0.0
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#15326):
> https://lists.openembedded.org/g/bitbake-devel/message/15326
> Mute This Topic: https://lists.openembedded.org/mt/102283457/924729
> Group Owner: bitbake-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/bitbake-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
diff mbox series

Patch

diff --git a/toaster-requirements.txt b/toaster-requirements.txt
index d8e48b7f..19bf6fd2 100644
--- a/toaster-requirements.txt
+++ b/toaster-requirements.txt
@@ -2,3 +2,8 @@  Django>4.2,<4.3
 beautifulsoup4>=4.4.0
 pytz
 django-log-viewer==1.1.7
+pytest==7.4.2
+pytest-django==4.5.2
+pytest-env==1.1.0
+pytest-html==4.0.2
+pytest-metadata==3.0.0