diff mbox series

[1/3] arm-bsp/juno: update to use u-boot v2023.01

Message ID 20230130112425.784450-1-jon.mason@arm.com
State New
Headers show
Series [1/3] arm-bsp/juno: update to use u-boot v2023.01 | expand

Commit Message

Jon Mason Jan. 30, 2023, 11:24 a.m. UTC
Update the compressed kernel patch and drop the unnecessary custom
bootcmd patch.

Signed-off-by: Jon Mason <jon.mason@arm.com>
---
 meta-arm-bsp/conf/machine/juno.conf           |  1 -
 ...tom-bootcmd-to-autoboot-from-uEnv.tx.patch | 50 -------------------
 ...-modify-to-boot-compressed-initramfs.patch | 27 ++++++++++
 ...-modify-to-boot-compressed-initramfs.patch | 41 ---------------
 .../recipes-bsp/u-boot/u-boot_%.bbappend      |  4 +-
 5 files changed, 28 insertions(+), 95 deletions(-)
 delete mode 100644 meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch
 create mode 100644 meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch
 delete mode 100644 meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0002-configs-vexpress-modify-to-boot-compressed-initramfs.patch
diff mbox series

Patch

diff --git a/meta-arm-bsp/conf/machine/juno.conf b/meta-arm-bsp/conf/machine/juno.conf
index 4a86d4e2..43d6b3e3 100644
--- a/meta-arm-bsp/conf/machine/juno.conf
+++ b/meta-arm-bsp/conf/machine/juno.conf
@@ -18,7 +18,6 @@  IMAGE_FSTYPES += "tar.bz2 ext4 cpio.gz"
 SERIAL_CONSOLES = "115200;ttyAMA0"
 
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_u-boot ?= "2022.04"
 PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot"
 
 EXTRA_IMAGEDEPENDS += "trusted-firmware-a virtual/bootloader firmware-image-juno"
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch
deleted file mode 100644
index a6838390..00000000
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch
+++ /dev/null
@@ -1,50 +0,0 @@ 
-From 13dde05efae99c5261ed213108087d0f7ac9581e Mon Sep 17 00:00:00 2001
-From: Damodar Santhapuri <damodar.santhapuri@arm.com>
-Date: Thu, 5 Nov 2020 22:40:48 +0530
-Subject: [PATCH] arm: juno: add custom bootcmd to autoboot from uEnv.txt file
-
-enable autoboot support with custom bootcmd loads uEnv.txt
-from NOR to DRAM and import.
-
-Signed-off-by: Damodar Santhapuri <damodar.santhapuri@arm.com>
-Upstream-Status: Pending
----
- include/configs/vexpress_aemv8.h | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/include/configs/vexpress_aemv8.h b/include/configs/vexpress_aemv8.h
-index f0c5ceb3849a..cd7f6c1b9ba0 100644
---- a/include/configs/vexpress_aemv8.h
-+++ b/include/configs/vexpress_aemv8.h
-@@ -137,13 +137,13 @@
- 		"  afs load ${fdt_alt_name} ${fdt_addr_r}; "\
- 		"fi ; "\
- 		"fdt addr ${fdt_addr_r}; fdt resize; " \
--		"if afs load  ${ramdisk_name} ${ramdisk_addr_r} ; "\
-+		"if afs load  ${initrd_name} ${initrd_addr_r} ; "\
- 		"then "\
--		"  setenv ramdisk_param ${ramdisk_addr_r}; "\
-+		"  setenv initrd_param ${initrd_addr_r}; "\
- 		"else "\
--		"  setenv ramdisk_param -; "\
-+		"  setenv initrd_param -; "\
- 		"fi ; " \
--		"booti ${kernel_addr_r} ${ramdisk_param} ${fdt_addr_r}\0"
-+		"booti ${kernel_addr_r} ${initrd_param} ${fdt_addr_r}"
- #define BOOTENV_DEV_NAME_AFS(devtypeu, devtypel, instance) "afs "
- 
- #define BOOT_TARGET_DEVICES(func)	\
-@@ -164,8 +164,8 @@
- 				"kernel_name=norkern\0"	\
- 				"kernel_alt_name=Image\0"	\
- 				"kernel_addr_r=0x80080000\0" \
--				"ramdisk_name=ramdisk.img\0"	\
--				"ramdisk_addr_r=0x88000000\0"	\
-+				"initrd_name=ramdisk.img\0"	\
-+				"initrd_addr_r=0x88000000\0"	\
- 				"fdtfile=board.dtb\0" \
- 				"fdt_alt_name=juno\0" \
- 				"fdt_addr_r=0x80000000\0" \
--- 
-2.30.2
-
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch
new file mode 100644
index 00000000..0967df76
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch
@@ -0,0 +1,27 @@ 
+From 726f8b4dbd3c5b1873aad531d5e26af3acd9b9ca Mon Sep 17 00:00:00 2001
+From: Jon Mason <jdmason@kudzu.us>
+Date: Mon, 19 Dec 2022 11:36:04 -0500
+Subject: [PATCH] configs: vexpress: modify to boot compressed initramfs
+
+Signed-off-by: Jon Mason <jdmason@kudzu.us>
+Upstream-Status: Inappropriate
+---
+ include/configs/vexpress_aemv8.h | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/include/configs/vexpress_aemv8.h b/include/configs/vexpress_aemv8.h
+index 0c11b6b3331e..4ba4bebfbbae 100644
+--- a/include/configs/vexpress_aemv8.h
++++ b/include/configs/vexpress_aemv8.h
+@@ -192,8 +192,10 @@
+ #define VEXPRESS_RAMDISK_ADDR		0x8fe00000
+ 
+ #define EXTRA_ENV_NAMES							\
++	        "kernel_comp_addr_r=0x90000000\0"			\
++		"kernel_comp_size=0x3000000\0"				\
+ 		"kernel_name=norkern\0"					\
+-		"kernel_alt_name=Image\0"				\
++		"kernel_alt_name=Image.gz\0"				\
+ 		"ramdisk_name=ramdisk.img\0"				\
+ 		"fdtfile=board.dtb\0"					\
+ 		"fdt_alt_name=juno\0"
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0002-configs-vexpress-modify-to-boot-compressed-initramfs.patch b/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0002-configs-vexpress-modify-to-boot-compressed-initramfs.patch
deleted file mode 100644
index 2bf68fe6..00000000
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot/juno/0002-configs-vexpress-modify-to-boot-compressed-initramfs.patch
+++ /dev/null
@@ -1,41 +0,0 @@ 
-From 097a43223da4fa42335944295903ede2755e2dfd Mon Sep 17 00:00:00 2001
-From: Jon Mason <jdmason@kudzu.us>
-Date: Mon, 19 Dec 2022 11:36:04 -0500
-Subject: [PATCH] configs: vexpress: modify to boot compressed initramfs
-
-Signed-off-by: Jon Mason <jdmason@kudzu.us>
-Upstream-Status: Inappropriate
-
----
- configs/vexpress_aemv8a_juno_defconfig | 1 +
- include/configs/vexpress_aemv8.h       | 2 ++
- 2 files changed, 3 insertions(+)
-
-diff --git a/configs/vexpress_aemv8a_juno_defconfig b/configs/vexpress_aemv8a_juno_defconfig
-index e02124cc7f54..6ffe8f5fe67e 100644
---- a/configs/vexpress_aemv8a_juno_defconfig
-+++ b/configs/vexpress_aemv8a_juno_defconfig
-@@ -16,6 +16,7 @@ CONFIG_SYS_LOAD_ADDR=0x90000000
- CONFIG_BOOTDELAY=1
- CONFIG_USE_BOOTARGS=y
- CONFIG_BOOTARGS="console=ttyAMA0,115200n8 root=/dev/sda2 rw rootwait earlycon=pl011,0x7ff80000 debug user_debug=31 androidboot.hardware=juno loglevel=9"
-+CONFIG_BOOTCOMMAND="echo running default boot command; afs load ${kernel_name} ${kernel_addr_r} ; if test $? -eq 1; then   echo Loading ${kernel_alt_name} instead of ${kernel_name};   afs load ${kernel_alt_name} ${kernel_addr_r};fi ; afs load  ${fdtfile} ${fdt_addr_r} ; if test $? -eq 1; then   echo Loading ${fdt_alt_name} instead of ${fdtfile};   afs load ${fdt_alt_name} ${fdt_addr_r}; fi ; fdt addr ${fdt_addr_r}; fdt resize; if afs load  ${initrd_name} ${initrd_addr_r} ; then   setenv initrd_param ${initrd_addr_r};   else setenv initrd_param -; fi ; booti ${kernel_addr_r} ${initrd_param} ${fdt_addr_r}"
- # CONFIG_DISPLAY_CPUINFO is not set
- # CONFIG_DISPLAY_BOARDINFO is not set
- CONFIG_SYS_PROMPT="VExpress64# "
-diff --git a/include/configs/vexpress_aemv8.h b/include/configs/vexpress_aemv8.h
-index cd7f6c1b9ba0..c2f5eb302076 100644
---- a/include/configs/vexpress_aemv8.h
-+++ b/include/configs/vexpress_aemv8.h
-@@ -164,6 +164,8 @@
- 				"kernel_name=norkern\0"	\
- 				"kernel_alt_name=Image\0"	\
- 				"kernel_addr_r=0x80080000\0" \
-+				"kernel_comp_addr_r=0x90000000\0" \
-+				"kernel_comp_size=0x3000000\0" \
- 				"initrd_name=ramdisk.img\0"	\
- 				"initrd_addr_r=0x88000000\0"	\
- 				"fdtfile=board.dtb\0" \
--- 
-2.30.2
-
diff --git a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
index f26ab4a6..b89ea872 100644
--- a/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
+++ b/meta-arm-bsp/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -77,9 +77,7 @@  SRC_URI:append:fvp-baser-aemv8r64 = " \
 #
 # Juno Machines
 #
-SRC_URI:append:juno = " file://0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch \
-                        file://0002-configs-vexpress-modify-to-boot-compressed-initramfs.patch \
-                      "
+SRC_URI:append:juno = " file://0001-configs-vexpress-modify-to-boot-compressed-initramfs.patch"
 
 
 #