diff mbox series

[2/4] arm/trusted-firmware-m: disable fatal warnings

Message ID 20230120145647.11758-2-jon.mason@arm.com
State New
Headers show
Series [1/4] arm-bsp/trusted-firmware-m: corstone1000: TFM file clean-ups | expand

Commit Message

Jon Mason Jan. 20, 2023, 2:56 p.m. UTC
Disable fatal warnings for tfm.  This removes issues with RWX and others
when using the new binary toolchain versions.

Signed-off-by: Jon Mason <jon.mason@arm.com>
---
 .../trusted-firmware-m/files/rwx.patch        | 24 +++++++++++++++++++
 .../trusted-firmware-m_1.7.0.bb               |  1 +
 2 files changed, 25 insertions(+)
 create mode 100644 meta-arm/recipes-bsp/trusted-firmware-m/files/rwx.patch
diff mbox series

Patch

diff --git a/meta-arm/recipes-bsp/trusted-firmware-m/files/rwx.patch b/meta-arm/recipes-bsp/trusted-firmware-m/files/rwx.patch
new file mode 100644
index 00000000..b279cfea
--- /dev/null
+++ b/meta-arm/recipes-bsp/trusted-firmware-m/files/rwx.patch
@@ -0,0 +1,24 @@ 
+From 1d548c77d07fc9a83e3e9aa28a23aa19a0177e3b Mon Sep 17 00:00:00 2001
+From: Jon Mason <jon.mason@arm.com>
+Date: Wed, 18 Jan 2023 15:13:37 -0500
+Subject: [PATCH] arm/trusted-firmware-m: disable fatal warnings
+
+Signed-off-by: Jon Mason <jon.mason@arm.com>
+Upstream-Status: Inappropriate
+
+---
+ toolchain_GNUARM.cmake | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/toolchain_GNUARM.cmake b/toolchain_GNUARM.cmake
+index 7978eaca68..88395f922a 100644
+--- a/toolchain_GNUARM.cmake
++++ b/toolchain_GNUARM.cmake
+@@ -66,7 +66,6 @@ macro(tfm_toolchain_reset_linker_flags)
+         --entry=Reset_Handler
+         --specs=nano.specs
+         LINKER:-check-sections
+-        LINKER:-fatal-warnings
+         LINKER:--gc-sections
+         LINKER:--no-wchar-size-warning
+         ${MEMORY_USAGE_FLAG}
diff --git a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
index 3b4469d0..fb88596b 100644
--- a/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
+++ b/meta-arm/recipes-bsp/trusted-firmware-m/trusted-firmware-m_1.7.0.bb
@@ -20,6 +20,7 @@  SRC_URI  = "git://git.trustedfirmware.org/TF-M/trusted-firmware-m.git;protocol=h
             git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=${SRCBRANCH_mbedtls};name=mbedtls;destsuffix=git/mbedtls \
             git://github.com/mcu-tools/mcuboot.git;protocol=https;branch=${SRCBRANCH_mcuboot};name=mcuboot;destsuffix=git/mcuboot \
             git://github.com/laurencelundblade/QCBOR.git;protocol=https;branch=${SRCBRANCH_qcbor};name=qcbor;destsuffix=git/qcbor \
+            file://rwx.patch \
             "
 
 # The required dependencies are documented in tf-m/config/config_default.cmake