diff mbox series

[meta-arago,master/kirkstone] opencl: stop using "virtual/" in RPROVIDES and RDEPENDS

Message ID 20230516175913.3829-1-reatmon@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [meta-arago,master/kirkstone] opencl: stop using "virtual/" in RPROVIDES and RDEPENDS | expand

Commit Message

Ryan Eatmon May 16, 2023, 5:59 p.m. UTC
Recipes shouldn't use the "virtual/" string in RPROVIDES and RDEPENDS.

That's confusing because "virtual/" has no special meaning in
RPROVIDES and RDEPENDS (unlike in PROVIDES and DEPENDS).

Instead, using "virtual-" instead of "virtual/"
as already done in the glibc recipe.

This is inspired by a bug report on oe-core [1], and implemented in a
patch to that repo [2].

[1] https://bugzilla.yoctoproject.org/show_bug.cgi?id=14538
[2] https://git.openembedded.org/openembedded-core/commit/meta/recipes-bsp/grub/grub-bootconf_1.00.bb?id=93ac180d8c389f16964bce8bd5538d9389e970e6

Signed-off-by: Randolph Sapp <rs@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 meta-arago-extras/recipes-ti/ocl/opencl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-ti/ocl/opencl_git.bb b/meta-arago-extras/recipes-ti/ocl/opencl_git.bb
index 7a3819c2..0bdbed7e 100644
--- a/meta-arago-extras/recipes-ti/ocl/opencl_git.bb
+++ b/meta-arago-extras/recipes-ti/ocl/opencl_git.bb
@@ -40,7 +40,7 @@  DEPENDS = " virtual/libgl \
 DEPENDS:append:dra7xx = " ti-ipc virtual/kernel"
 
 RDEPENDS:${PN}-runtime += "bash ${MONITORS}"
-RDEPENDS:${PN}-dev += "virtual/libgl-dev"
+RDEPENDS:${PN}-dev += "virtual-libgl-dev"
 RDEPENDS:${PN} += "${PN}-runtime clocl bash"
 
 # Use main package to pull in full support