diff mbox series

[master/kirkstone] meta-arago: remove old deprecated long-SDKPATH hack

Message ID 20221116044437.2893722-1-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master/kirkstone] meta-arago: remove old deprecated long-SDKPATH hack | expand

Commit Message

Denys Dmytriyenko Nov. 16, 2022, 4:44 a.m. UTC
From: Denys Dmytriyenko <denys@konsulko.com>

The long-SDKPATH hack was used for pre-allocating large enough fields
in the ELF headers of nativesdk binaries, so when they are relocated
the new path to the dynamic loader and libraries would fit. This is
no longer necessary for some time, so time to remove the hack.

Change the default SDKPATHINSTALL to include the SDK/distro version.
Also drop all workarounds that were needed due to the unusual SDKPATH.

Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 meta-arago-distro/conf/distro/arago.conf             |  6 +-----
 .../recipes-devtools/perl/perl_%.bbappend            | 12 ------------
 .../recipes-devtools/python/python3_%.bbappend       | 12 ------------
 .../recipes-core/meta/meta-toolchain-arago.bb        |  2 +-
 4 files changed, 2 insertions(+), 30 deletions(-)
 delete mode 100644 meta-arago-distro/recipes-devtools/perl/perl_%.bbappend
 delete mode 100644 meta-arago-distro/recipes-devtools/python/python3_%.bbappend
diff mbox series

Patch

diff --git a/meta-arago-distro/conf/distro/arago.conf b/meta-arago-distro/conf/distro/arago.conf
index 57eeb57a..d675b077 100644
--- a/meta-arago-distro/conf/distro/arago.conf
+++ b/meta-arago-distro/conf/distro/arago.conf
@@ -28,8 +28,7 @@  SDK_NAME_PREFIX = "arago"
 SDK_VERSION = "${DISTRO_VERSION}"
 SDK_VENDOR = "-${SDK_NAME_PREFIX}"
 SDK_NAME = "${SDK_NAME_PREFIX}-${SDK_VERSION}"
-SDKPATH_REAL = "/usr/local/${SDK_NAME_PREFIX}-${SDK_VERSION}"
-SDKPATH = "${@"/tmp/"+"x"*96+"/"+"y"*96}"
+SDKPATHINSTALL = "/opt/${SDK_NAME}"
 
 IMAGE_FSTYPES += "tar.xz.md5sum"
 
@@ -214,6 +213,3 @@  LICENSE_FLAGS_ACCEPTED = "commercial_gst-ffmpeg commercial_gstreamer1.0-libav co
 
 # Do not package own copy of perl into devkit, rely on host one
 ASSUME_PROVIDED += "nativesdk-perl"
-
-# Disable empty-dirs QA check, which trips on our devkit default SDKPATH
-ERROR_QA:remove = "empty-dirs"
diff --git a/meta-arago-distro/recipes-devtools/perl/perl_%.bbappend b/meta-arago-distro/recipes-devtools/perl/perl_%.bbappend
deleted file mode 100644
index 9af89cbc..00000000
--- a/meta-arago-distro/recipes-devtools/perl/perl_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@ 
-# In arago.conf, we pre-allocate SDK path very long to reserve enough space in ELF headers
-# and then it gets replaced with a short real path at the time of SDK creation:
-# SDKPATH_REAL = "/usr/local/${SDK_NAME_PREFIX}-${SDK_VERSION}"
-# SDKPATH = "${@"/tmp/"+"x"*96+"/"+"y"*96}"
-# Unfortunately, that triggers the new shebang-size QA check in nativesdk-perl packages
-
-python() {
-    if d.getVar('CLASSOVERRIDE') == "class-nativesdk":
-        pkgs = d.getVar("PACKAGES").split()
-        for p in pkgs:
-            d.appendVar('INSANE_SKIP:%s' % (p), ' shebang-size')
-}
diff --git a/meta-arago-distro/recipes-devtools/python/python3_%.bbappend b/meta-arago-distro/recipes-devtools/python/python3_%.bbappend
deleted file mode 100644
index 2afb2b37..00000000
--- a/meta-arago-distro/recipes-devtools/python/python3_%.bbappend
+++ /dev/null
@@ -1,12 +0,0 @@ 
-# In arago.conf, we pre-allocate SDK path very long to reserve enough space in ELF headers
-# and then it gets replaced with a short real path at the time of SDK creation:
-# SDKPATH_REAL = "/usr/local/${SDK_NAME_PREFIX}-${SDK_VERSION}"
-# SDKPATH = "${@"/tmp/"+"x"*96+"/"+"y"*96}"
-# Unfortunately, that triggers the new shebang-size QA check in nativesdk-python3 packages
-
-python() {
-    if d.getVar('CLASSOVERRIDE') == "class-nativesdk":
-        pkgs = d.getVar("PACKAGES").split()
-        for p in pkgs:
-            d.appendVar('INSANE_SKIP:%s' % (p), ' shebang-size')
-}
diff --git a/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb b/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
index ab484a1e..81affa16 100644
--- a/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
+++ b/meta-arago-extras/recipes-core/meta/meta-toolchain-arago.bb
@@ -178,7 +178,7 @@  if [ "$INST_ARCH" != "$SDK_ARCH" ]; then
 	fi
 fi
 
-DEFAULT_INSTALL_DIR="${SDKPATH_REAL}"
+DEFAULT_INSTALL_DIR="${SDKPATHINSTALL}"
 TMPSDKPATH="${SDKPATH}"
 SUDO_EXEC=""
 target_sdk_dir=""