diff mbox series

[master/kirkstone,45/52] meta-arago-extras: recipes-devtools: eventdump: Fix linking against local library

Message ID 20220913040246.2365077-46-denis@denix.org
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Latest 2022.09 sync-up with Dunfell | expand

Commit Message

Denys Dmytriyenko Sept. 13, 2022, 4:02 a.m. UTC
From: Nishanth Menon <nm@ti.com>

https://github.com/TI-ECS/eventdump unfortunately is a unmaintained
project.

LDFLAGS += -L$(NFSROOT)/lib should have dependent on NFSROOT variable.
Instead this forces the eventdump to break the sandbox and attempt to
link up against the local PC's lib - which is a NO-NO for many reasons.

Reported to have failed on a Fedora system.

Bump the PR up to indicate a fix up where we have proper linkage

Reported-by: Daniel Thompson <daniel.thompson@linaro.org>
Signed-off-by: Nishanth Menon <nm@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
---
 .../eventdump/eventdump_git.bb                |  7 ++--
 ...Play_nicer_with_bitbake-OpenEmbedded.patch | 34 +++++++++++++++++++
 2 files changed, 39 insertions(+), 2 deletions(-)
 create mode 100644 meta-arago-extras/recipes-devtools/eventdump/files/0001-PATCH_Makefile_Play_nicer_with_bitbake-OpenEmbedded.patch
diff mbox series

Patch

diff --git a/meta-arago-extras/recipes-devtools/eventdump/eventdump_git.bb b/meta-arago-extras/recipes-devtools/eventdump/eventdump_git.bb
index d52d5eaf..6fc9f5df 100644
--- a/meta-arago-extras/recipes-devtools/eventdump/eventdump_git.bb
+++ b/meta-arago-extras/recipes-devtools/eventdump/eventdump_git.bb
@@ -2,12 +2,15 @@  SUMMARY = "Utility for parsing system events"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://eventdump.c;beginline=1;endline=34;md5=23b59be24a88ddc407b553035f3fd3e9"
 
-PR = "r3"
+PR = "r4"
 PV = "1.0+git${SRCPV}"
 
 SRCREV = "5db45a36a05a78ea44a4cb25312ed5ee3c2bd76d"
 
-SRC_URI = "git://github.com/TI-ECS/eventdump.git;protocol=https;branch=master"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+
+SRC_URI = "git://github.com/TI-ECS/eventdump.git;protocol=https;branch=master \
+	file://0001-PATCH_Makefile_Play_nicer_with_bitbake-OpenEmbedded.patch"
 
 S = "${WORKDIR}/git"
 
diff --git a/meta-arago-extras/recipes-devtools/eventdump/files/0001-PATCH_Makefile_Play_nicer_with_bitbake-OpenEmbedded.patch b/meta-arago-extras/recipes-devtools/eventdump/files/0001-PATCH_Makefile_Play_nicer_with_bitbake-OpenEmbedded.patch
new file mode 100644
index 00000000..b14d5bb3
--- /dev/null
+++ b/meta-arago-extras/recipes-devtools/eventdump/files/0001-PATCH_Makefile_Play_nicer_with_bitbake-OpenEmbedded.patch
@@ -0,0 +1,34 @@ 
+From e8c5094e2d59fe48ad0e7234f196d04508f53727 Mon Sep 17 00:00:00 2001
+From: Daniel Thompson <daniel.thompson@linaro.org>
+Date: Wed, 20 Jul 2022 18:05:09 +0100
+Subject: [PATCH] Makefile: Play nicer with bitbake/OpenEmbedded
+
+Unconditionally adding -L$(NFSROOT)/lib to the link line risks seriously
+confusing the linker if NFSROOT is not set (which would be common when
+building OE/bitbake) because we end up trying to link against whatever
+zany things we might find in the host /lib directory). Fix this the
+obvious way.
+
+Upstream-Status: Pending
+Signed-off-by: Daniel Thompson <daniel.thompson@linaro.org>
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index e313e50..afb5472 100755
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,9 @@
+ CC = $(CROSS_COMPILE)gcc
+ CFLAGS = -O2 -Wall
+
++ifneq ($(NFSROOT),)
+ LDFLAGS += -L$(NFSROOT)/lib
++endif
+ #LIBS += -lopenobex -lbluetooth -lmisc
+
+ OBJS = eventdump.o
+--
+2.36.1
+