kernel-devsrc: fix reproducibility and buildpaths QA warning

Message ID 20220705195509.23628-1-bruce.ashfield@gmail.com
State Accepted, archived
Commit e0a9433685397b716920fa9ad5d5a7be95c496f7
Headers show
Series kernel-devsrc: fix reproducibility and buildpaths QA warning | expand

Commit Message

Bruce Ashfield July 5, 2022, 7:55 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

We've been removing .vdso-offsets.h.cmd for quite some time, as it
is not required to regenerate scripts or to satisfy the prepare
target in the kernel source.

That being said, there is a secondary location that this file may
be found, and since we aren't detecting or removing it, we end up
with embedded build paths, which cause both reproducibility and
buildpaths QA warnings.

We can test for both files, and force remove them if present, and
we'll fix this new location of the file and not risk breaking
any old kernels.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/kernel-devsrc.bb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 76b8f8dad2..58cba9400a 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -142,8 +142,10 @@  do_install() {
 	# breaks workflows.
 	cp -a --parents include/generated/autoconf.h $kerneldir/build 2>/dev/null || :
 
-	if [ -e $kerneldir/include/generated/.vdso-offsets.h.cmd ]; then
-	    rm $kerneldir/include/generated/.vdso-offsets.h.cmd
+	if [ -e $kerneldir/include/generated/.vdso-offsets.h.cmd ] ||
+	     [ -e $kerneldir/build/include/generated/.vdso-offsets.h.cmd ]; then
+	    rm -f $kerneldir/include/generated/.vdso-offsets.h.cmd
+	    rm -f $kerneldir/build/include/generated/.vdso-offsets.h.cmd
 	fi
     )