strace: set COMPATIBLE_HOST for riscv32

Message ID 20220705070318.737747-1-mingli.yu@windriver.com
State New
Headers show
Series strace: set COMPATIBLE_HOST for riscv32 | expand

Commit Message

Yu, Mingli July 5, 2022, 7:03 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Disable the build on riscv32 as it's not supported on riscv32 [1].

[1] https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-devtools/strace/strace_5.18.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Khem Raj July 5, 2022, 1:39 p.m. UTC | #1
On 7/5/22 3:03 AM, Yu, Mingli wrote:
> From: Mingli Yu <mingli.yu@windriver.com>
>
> Disable the build on riscv32 as it's not supported on riscv32 [1].
>
> [1] https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
>
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>   meta/recipes-devtools/strace/strace_5.18.bb | 3 +++
>   1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-devtools/strace/strace_5.18.bb b/meta/recipes-devtools/strace/strace_5.18.bb
> index 08f0f1d27e..75ff58bd50 100644
> --- a/meta/recipes-devtools/strace/strace_5.18.bb
> +++ b/meta/recipes-devtools/strace/strace_5.18.bb
> @@ -18,6 +18,9 @@ SRC_URI[sha256sum] = "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
>   
>   inherit autotools ptest
>   
> +# Not yet ported to rv32
> +COMPATIBLE_HOST:riscv32 = "null"
> +

there might be more changes needed especially in package groups perhaps.

>   PACKAGECONFIG:class-target ??= "\
>       ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
>   "
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#167640): https://lists.openembedded.org/g/openembedded-core/message/167640
> Mute This Topic: https://lists.openembedded.org/mt/92180245/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Yu, Mingli July 20, 2022, 9:34 a.m. UTC | #2
Hi Khem,

On 7/5/22 21:39, Khem Raj wrote:
> [Please note: This e-mail is from an EXTERNAL e-mail address]
> 
> On 7/5/22 3:03 AM, Yu, Mingli wrote:
>> From: Mingli Yu <mingli.yu@windriver.com>
>>
>> Disable the build on riscv32 as it's not supported on riscv32 [1].
>>
>> [1] 
>> https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da 
>>
>>
>> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
>> ---
>>   meta/recipes-devtools/strace/strace_5.18.bb | 3 +++
>>   1 file changed, 3 insertions(+)
>>
>> diff --git a/meta/recipes-devtools/strace/strace_5.18.bb 
>> b/meta/recipes-devtools/strace/strace_5.18.bb
>> index 08f0f1d27e..75ff58bd50 100644
>> --- a/meta/recipes-devtools/strace/strace_5.18.bb
>> +++ b/meta/recipes-devtools/strace/strace_5.18.bb
>> @@ -18,6 +18,9 @@ SRC_URI[sha256sum] = 
>> "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
>>
>>   inherit autotools ptest
>>
>> +# Not yet ported to rv32
>> +COMPATIBLE_HOST:riscv32 = "null"
>> +
> 
> there might be more changes needed especially in package groups perhaps.

What do you mean when you mentioned package groups here?

There comes do_configure error as below:
| checking for supported architecture... NO!
| configure: error: architecture riscv32 is not supported by strace
| NOTE: The following config.log files may provide further information.
| NOTE: 
/buildarea/build/tmp-glibc/work/riscv32-wrs-linux/strace/5.18-r0/build/config.log
| ERROR: configure failed
| WARNING: exit code 1 from a shell command.

Considering no support for riscv32 until now as 
https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da, 
so we set COMPATIBLE_HOST for riscv32.

Thanks,

> 
>>   PACKAGECONFIG:class-target ??= "\
>>       ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', 
>> '', d)} \
>>   "
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#167640): 
>> https://lists.openembedded.org/g/openembedded-core/message/167640
>> Mute This Topic: https://lists.openembedded.org/mt/92180245/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub 
>> [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj July 20, 2022, 12:14 p.m. UTC | #3
On Wed, Jul 20, 2022 at 5:35 AM Yu, Mingli <mingli.yu@windriver.com> wrote:

> Hi Khem,
>
> On 7/5/22 21:39, Khem Raj wrote:
> > [Please note: This e-mail is from an EXTERNAL e-mail address]
> >
> > On 7/5/22 3:03 AM, Yu, Mingli wrote:
> >> From: Mingli Yu <mingli.yu@windriver.com>
> >>
> >> Disable the build on riscv32 as it's not supported on riscv32 [1].
> >>
> >> [1]
> >>
> https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
> >>
> >>
> >> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> >> ---
> >>   meta/recipes-devtools/strace/strace_5.18.bb | 3 +++
> >>   1 file changed, 3 insertions(+)
> >>
> >> diff --git a/meta/recipes-devtools/strace/strace_5.18.bb
> >> b/meta/recipes-devtools/strace/strace_5.18.bb
> >> index 08f0f1d27e..75ff58bd50 100644
> >> --- a/meta/recipes-devtools/strace/strace_5.18.bb
> >> +++ b/meta/recipes-devtools/strace/strace_5.18.bb
> >> @@ -18,6 +18,9 @@ SRC_URI[sha256sum] =
> >> "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
> >>
> >>   inherit autotools ptest
> >>
> >> +# Not yet ported to rv32
> >> +COMPATIBLE_HOST:riscv32 = "null"
> >> +
> >
> > there might be more changes needed especially in package groups perhaps.
>
> What do you mean when you mentioned package groups here?
>
> There comes do_configure error as below:
> | checking for supported architecture... NO!
> | configure: error: architecture riscv32 is not supported by strace
> | NOTE: The following config.log files may provide further information.
> | NOTE:
>
> /buildarea/build/tmp-glibc/work/riscv32-wrs-linux/strace/5.18-r0/build/config.log
> | ERROR: configure failed
> | WARNING: exit code 1 from a shell command.
>
> Considering no support for riscv32 until now as
>
> https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da,
>
> so we set COMPATIBLE_HOST for riscv32.


That’s fine. I think strace is added in some other places to images and
package groups you might have to remove it for rv32 from them

>
>
> Thanks,
>
> >
> >>   PACKAGECONFIG:class-target ??= "\
> >>       ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
> >> '', d)} \
> >>   "
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#167640):
> >> https://lists.openembedded.org/g/openembedded-core/message/167640
> >> Mute This Topic: https://lists.openembedded.org/mt/92180245/1997914
> >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub
> >> [raj.khem@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>
Yu, Mingli July 25, 2022, 5:56 a.m. UTC | #4
Hi Khem,

On 7/20/22 20:14, Khem Raj wrote:
> **[Please note: This e-mail is from an EXTERNAL e-mail address]
> 
> 
> 
> On Wed, Jul 20, 2022 at 5:35 AM Yu, Mingli <mingli.yu@windriver.com 
> <mailto:mingli.yu@windriver.com>> wrote:
> 
>     Hi Khem,
> 
>     On 7/5/22 21:39, Khem Raj wrote:
>      > [Please note: This e-mail is from an EXTERNAL e-mail address]
>      >
>      > On 7/5/22 3:03 AM, Yu, Mingli wrote:
>      >> From: Mingli Yu <mingli.yu@windriver.com
>     <mailto:mingli.yu@windriver.com>>
>      >>
>      >> Disable the build on riscv32 as it's not supported on riscv32 [1].
>      >>
>      >> [1]
>      >>
>     https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
>     <https://urldefense.com/v3/__https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgvWe7uKs$>
> 
>      >>
>      >>
>      >> Signed-off-by: Mingli Yu <mingli.yu@windriver.com
>     <mailto:mingli.yu@windriver.com>>
>      >> ---
>      >>   meta/recipes-devtools/strace/strace_5.18.bb
>     <https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$>
>     | 3 +++
>      >>   1 file changed, 3 insertions(+)
>      >>
>      >> diff --git a/meta/recipes-devtools/strace/strace_5.18.bb
>     <https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$>
> 
>      >> b/meta/recipes-devtools/strace/strace_5.18.bb
>     <https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$>
>      >> index 08f0f1d27e..75ff58bd50 100644
>      >> --- a/meta/recipes-devtools/strace/strace_5.18.bb
>     <https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$>
>      >> +++ b/meta/recipes-devtools/strace/strace_5.18.bb
>     <https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$>
>      >> @@ -18,6 +18,9 @@ SRC_URI[sha256sum] =
>      >> "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
>      >>
>      >>   inherit autotools ptest
>      >>
>      >> +# Not yet ported to rv32
>      >> +COMPATIBLE_HOST:riscv32 = "null"
>      >> +
>      >
>      > there might be more changes needed especially in package groups
>     perhaps.
> 
>     What do you mean when you mentioned package groups here?
> 
>     There comes do_configure error as below:
>     | checking for supported architecture... NO!
>     | configure: error: architecture riscv32 is not supported by strace
>     | NOTE: The following config.log files may provide further information.
>     | NOTE:
>     /buildarea/build/tmp-glibc/work/riscv32-wrs-linux/strace/5.18-r0/build/config.log
>     | ERROR: configure failed
>     | WARNING: exit code 1 from a shell command.
> 
>     Considering no support for riscv32 until now as
>     https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
>     <https://urldefense.com/v3/__https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgvWe7uKs$>,
> 
>     so we set COMPATIBLE_HOST for riscv32.
> 
> 
> That’s fine. I think strace is added in some other places to images and 
> package groups you might have to remove it for rv32 from them
> 

The strace for rv32 has already excluded in package group as 
https://git.openembedded.org/openembedded-core/commit/?id=bec777887e7eed9a12b08231a612aaf19b622614.

Thanks,

> 
>     Thanks,
> 
>      >
>      >>   PACKAGECONFIG:class-target ??= "\
>      >>       ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
>      >> '', d)} \
>      >>   "
>      >>
>      >> -=-=-=-=-=-=-=-=-=-=-=-
>      >> Links: You receive all messages sent to this group.
>      >> View/Reply Online (#167640):
>      >>
>     https://lists.openembedded.org/g/openembedded-core/message/167640
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/message/167640__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgnVp3icY$>
>      >> Mute This Topic:
>     https://lists.openembedded.org/mt/92180245/1997914
>     <https://urldefense.com/v3/__https://lists.openembedded.org/mt/92180245/1997914__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgRjA59ns$>
>      >> Group Owner: openembedded-core+owner@lists.openembedded.org
>     <mailto:openembedded-core%2Bowner@lists.openembedded.org>
>      >> Unsubscribe:
>     https://lists.openembedded.org/g/openembedded-core/unsub
>     <https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/unsub__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgVRirgww$>
> 
>      >> [raj.khem@gmail.com <mailto:raj.khem@gmail.com>]
>      >> -=-=-=-=-=-=-=-=-=-=-=-
>      >>
>
Khem Raj July 25, 2022, 1:25 p.m. UTC | #5
On Mon, Jul 25, 2022 at 1:56 AM Yu, Mingli <mingli.yu@windriver.com> wrote:

> Hi Khem,
>
> On 7/20/22 20:14, Khem Raj wrote:
> > **[Please note: This e-mail is from an EXTERNAL e-mail address]
> >
> >
> >
> > On Wed, Jul 20, 2022 at 5:35 AM Yu, Mingli <mingli.yu@windriver.com
> > <mailto:mingli.yu@windriver.com>> wrote:
> >
> >     Hi Khem,
> >
> >     On 7/5/22 21:39, Khem Raj wrote:
> >      > [Please note: This e-mail is from an EXTERNAL e-mail address]
> >      >
> >      > On 7/5/22 3:03 AM, Yu, Mingli wrote:
> >      >> From: Mingli Yu <mingli.yu@windriver.com
> >     <mailto:mingli.yu@windriver.com>>
> >      >>
> >      >> Disable the build on riscv32 as it's not supported on riscv32
> [1].
> >      >>
> >      >> [1]
> >      >>
> >
> https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
> >     <
> https://urldefense.com/v3/__https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgvWe7uKs$
> >
> >
> >      >>
> >      >>
> >      >> Signed-off-by: Mingli Yu <mingli.yu@windriver.com
> >     <mailto:mingli.yu@windriver.com>>
> >      >> ---
> >      >>   meta/recipes-devtools/strace/strace_5.18.bb
> >     <
> https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$
> >
> >     | 3 +++
> >      >>   1 file changed, 3 insertions(+)
> >      >>
> >      >> diff --git a/meta/recipes-devtools/strace/strace_5.18.bb
> >     <
> https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$
> >
> >
> >      >> b/meta/recipes-devtools/strace/strace_5.18.bb
> >     <
> https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$
> >
> >      >> index 08f0f1d27e..75ff58bd50 100644
> >      >> --- a/meta/recipes-devtools/strace/strace_5.18.bb
> >     <
> https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$
> >
> >      >> +++ b/meta/recipes-devtools/strace/strace_5.18.bb
> >     <
> https://urldefense.com/v3/__http://strace_5.18.bb__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLg5BtLgGc$
> >
> >      >> @@ -18,6 +18,9 @@ SRC_URI[sha256sum] =
> >      >> "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
> >      >>
> >      >>   inherit autotools ptest
> >      >>
> >      >> +# Not yet ported to rv32
> >      >> +COMPATIBLE_HOST:riscv32 = "null"
> >      >> +
> >      >
> >      > there might be more changes needed especially in package groups
> >     perhaps.
> >
> >     What do you mean when you mentioned package groups here?
> >
> >     There comes do_configure error as below:
> >     | checking for supported architecture... NO!
> >     | configure: error: architecture riscv32 is not supported by strace
> >     | NOTE: The following config.log files may provide further
> information.
> >     | NOTE:
> >
>  /buildarea/build/tmp-glibc/work/riscv32-wrs-linux/strace/5.18-r0/build/config.log
> >     | ERROR: configure failed
> >     | WARNING: exit code 1 from a shell command.
> >
> >     Considering no support for riscv32 until now as
> >
> https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da
> >     <
> https://urldefense.com/v3/__https://github.com/strace/strace/commit/69ff62ea5087506ad36a27599db088096db215da__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgvWe7uKs$
> >,
> >
> >     so we set COMPATIBLE_HOST for riscv32.
> >
> >
> > That’s fine. I think strace is added in some other places to images and
> > package groups you might have to remove it for rv32 from them
> >
>
> The strace for rv32 has already excluded in package group as
>
> https://git.openembedded.org/openembedded-core/commit/?id=bec777887e7eed9a12b08231a612aaf19b622614
> .


Thanks I am ok with this patch then

>
>
> Thanks,
>
> >
> >     Thanks,
> >
> >      >
> >      >>   PACKAGECONFIG:class-target ??= "\
> >      >>       ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth',
> 'bluez',
> >      >> '', d)} \
> >      >>   "
> >      >>
> >      >> -=-=-=-=-=-=-=-=-=-=-=-
> >      >> Links: You receive all messages sent to this group.
> >      >> View/Reply Online (#167640):
> >      >>
> >     https://lists.openembedded.org/g/openembedded-core/message/167640
> >     <
> https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/message/167640__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgnVp3icY$
> >
> >      >> Mute This Topic:
> >     https://lists.openembedded.org/mt/92180245/1997914
> >     <
> https://urldefense.com/v3/__https://lists.openembedded.org/mt/92180245/1997914__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgRjA59ns$
> >
> >      >> Group Owner: openembedded-core+owner@lists.openembedded.org
> >     <mailto:openembedded-core%2Bowner@lists.openembedded.org>
> >      >> Unsubscribe:
> >     https://lists.openembedded.org/g/openembedded-core/unsub
> >     <
> https://urldefense.com/v3/__https://lists.openembedded.org/g/openembedded-core/unsub__;!!AjveYdw8EvQ!d673WVMyl0hCL6dOFMygQ4BahOO10FPcaHhp2S9NPJswj86MPAabH2_xYSt5fUlR_1bzG8tBtYLgVRirgww$
> >
> >
> >      >> [raj.khem@gmail.com <mailto:raj.khem@gmail.com>]
> >      >> -=-=-=-=-=-=-=-=-=-=-=-
> >      >>
> >
>

Patch

diff --git a/meta/recipes-devtools/strace/strace_5.18.bb b/meta/recipes-devtools/strace/strace_5.18.bb
index 08f0f1d27e..75ff58bd50 100644
--- a/meta/recipes-devtools/strace/strace_5.18.bb
+++ b/meta/recipes-devtools/strace/strace_5.18.bb
@@ -18,6 +18,9 @@  SRC_URI[sha256sum] = "60293ea79ac9253d600cdc9be077ad2988ca22284a439c9e66be5150db
 
 inherit autotools ptest
 
+# Not yet ported to rv32
+COMPATIBLE_HOST:riscv32 = "null"
+
 PACKAGECONFIG:class-target ??= "\
     ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
 "