Patchwork [CONSOLIDATED,PULL,04/25] sanity: shift the required utils into a variable

login
register
mail settings
Submitter Saul Wold
Date Aug. 12, 2011, 7:49 a.m.
Message ID <63b0192340d3d756ed2c65934a9f1e46dd978a5f.1313134270.git.sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/9707/
State New, archived
Headers show

Comments

Saul Wold - Aug. 12, 2011, 7:49 a.m.
From: Chris Larson <chris_larson@mentor.com>

Signed-off-by: Chris Larson <chris_larson@mentor.com>
---
 meta/classes/sanity.bbclass |    4 +++-
 1 files changed, 3 insertions(+), 1 deletions(-)

Patch

diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 999e15d..d50c843 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -2,6 +2,8 @@ 
 # Sanity check the users setup for common misconfigurations
 #
 
+SANITY_REQUIRED_UTILITIES ?= "patch diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk chrpath wget cpio"
+
 def raise_sanity_error(msg):
     bb.fatal(""" Poky's config sanity checker detected a potential misconfiguration.
     Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
@@ -213,7 +215,7 @@  def check_sanity(e):
     if not check_app_exists('${BUILD_PREFIX}g++', e.data):
         missing = missing + "C++ Compiler (%sg++)," % data.getVar("BUILD_PREFIX", e.data, True)
 
-    required_utilities = "patch diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk chrpath wget cpio"
+    required_utilities = e.data.getVar('SANITY_REQUIRED_UTILITIES', True)
 
     if "qemu-native" in assume_provided:
         if not check_app_exists("qemu-arm", e.data):