Patchwork [CONSOLIDATED,PULL,01/10] scripts/runqemu: Make it run on ubuntu 11.10

login
register
mail settings
Submitter Saul Wold
Date Aug. 11, 2011, 4:29 p.m.
Message ID <c43c910efcc7a76740151e321bb148f0ea215355.1313079549.git.sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/9623/
State New, archived
Headers show

Comments

Saul Wold - Aug. 11, 2011, 4:29 p.m.
From: Khem Raj <raj.khem@gmail.com>

location of libGL has moved in ubuntu 11.10
so we look for it in the new locations

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 scripts/runqemu |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

Patch

diff --git a/scripts/runqemu b/scripts/runqemu
index 9611c64..2b8e88a 100755
--- a/scripts/runqemu
+++ b/scripts/runqemu
@@ -388,6 +388,7 @@  libgl='no'
 
 test -e /usr/lib/libGL.so -a -e /usr/lib/libGLU.so && libgl='yes'
 test -e /usr/lib64/libGL.so -a -e /usr/lib64/libGLU.so && libgl='yes'
+test -e /usr/lib/`uname -i`-linux-gnu/libGL.so -a -e /usr/lib/`uname -i`-linux-gnu/libGLU.so && libgl='yes'
 
 if [ "$libgl" != 'yes' ]; then
     echo "You need libGL.so and libGLU.so to exist in your library path to run the QEMU emulator.