[kirkstone,07/15] xxhash: fix build with gcc 12

Message ID d8e454b370089e4a33c8373742178ef4d540e848.1655666951.git.steve@sakoman.com
State Accepted, archived
Commit d8e454b370089e4a33c8373742178ef4d540e848
Headers show
Series [kirkstone,01/15] vim: Upgrade 8.2.5034 -> 8.2.5083 | expand

Commit Message

Steve Sakoman June 19, 2022, 7:30 p.m. UTC
From: Kai Kang <kai.kang@windriver.com>

It fails to compile xxhash when '-Og' is set in CFLAGS via such as set
DEBUG_BUILD = '1' in local.conf. Check and disable inline when '-Og'
exists.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 3464c67cd34acbb1a6705369e34dee8af7e348ac)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-support/xxhash/xxhash_0.8.1.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-support/xxhash/xxhash_0.8.1.bb b/meta/recipes-support/xxhash/xxhash_0.8.1.bb
index b3b9702598..222ba7b77c 100644
--- a/meta/recipes-support/xxhash/xxhash_0.8.1.bb
+++ b/meta/recipes-support/xxhash/xxhash_0.8.1.bb
@@ -14,6 +14,8 @@  SRCREV = "35b0373c697b5f160d3db26b1cbb45a0d5ba788c"
 
 S = "${WORKDIR}/git"
 
+CFLAGS += "${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Og', '-DXXH_NO_INLINE_HINTS', '', d)}"
+
 do_compile () {
 	oe_runmake all
 }