[oecore] bc: add missing bison-native dependency

Message ID 20220618175258.4655-1-f_l_k@t-online.de
State New
Headers show
Series [oecore] bc: add missing bison-native dependency | expand

Commit Message

Markus Volk June 18, 2022, 5:52 p.m. UTC
this fixes an error i encountered building for raspberrypi4 32bit:

prefix-map=/home/flk/build/poky/build-raspi/tmp/work/cortexa7t2hf-neon-vfpv4-poky-linux-gnueabi/bc/1.07.1-r0/recipe-sysroot-native=  -Wall -funsigned-char -c -o warranty.o ../../bc-1.07.1/bc/warranty.c
| ../../bc-1.07.1/ylwrap: line 176: yacc: command not found
| make[2]: *** [Makefile:429: bc.c] Error 127

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 meta/recipes-extended/bc/bc_1.07.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Richard Purdie June 21, 2022, 5:32 p.m. UTC | #1
On Sat, 2022-06-18 at 19:52 +0200, Markus Volk wrote:
> this fixes an error i encountered building for raspberrypi4 32bit:
> 
> prefix-map=/home/flk/build/poky/build-raspi/tmp/work/cortexa7t2hf-neon-vfpv4-poky-linux-gnueabi/bc/1.07.1-r0/recipe-sysroot-native=  -Wall -funsigned-char -c -o warranty.o ../../bc-1.07.1/bc/warranty.c
> > ../../bc-1.07.1/ylwrap: line 176: yacc: command not found
> > make[2]: *** [Makefile:429: bc.c] Error 127
> 
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  meta/recipes-extended/bc/bc_1.07.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
> index 1bec76bb2a..67453de822 100644
> --- a/meta/recipes-extended/bc/bc_1.07.1.bb
> +++ b/meta/recipes-extended/bc/bc_1.07.1.bb
> @@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
>                      file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
>  
>  SECTION = "base"
> -DEPENDS = "flex-native"
> +DEPENDS = "flex-native bison-native"
>  
>  SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
>             file://no-gen-libmath.patch \


The question is why you see that and nobody else has, including our
autobuilder.

I'm guessing something in your build is being rebuilt, hence the need
for bison whereas in most other builds that isn't rebuilding and hence
isn't needed.

Are you using a different configuration or extra patches or something?

I'm worried there is a reproducibility issue somewhere in here.

Cheers,

Richard
Markus Volk June 22, 2022, 7:50 a.m. UTC | #2
Am 21.06.22 um 19:32 schrieb Richard Purdie:
> On Sat, 2022-06-18 at 19:52 +0200, Markus Volk wrote:
>> this fixes an error i encountered building for raspberrypi4 32bit:
>>
>> prefix-map=/home/flk/build/poky/build-raspi/tmp/work/cortexa7t2hf-neon-vfpv4-poky-linux-gnueabi/bc/1.07.1-r0/recipe-sysroot-native=  -Wall -funsigned-char -c -o warranty.o ../../bc-1.07.1/bc/warranty.c
>>> ../../bc-1.07.1/ylwrap: line 176: yacc: command not found
>>> make[2]: *** [Makefile:429: bc.c] Error 127
>> Signed-off-by: Markus Volk <f_l_k@t-online.de>
>> ---
>>   meta/recipes-extended/bc/bc_1.07.1.bb | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
>> index 1bec76bb2a..67453de822 100644
>> --- a/meta/recipes-extended/bc/bc_1.07.1.bb
>> +++ b/meta/recipes-extended/bc/bc_1.07.1.bb
>> @@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
>>                       file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
>>   
>>   SECTION = "base"
>> -DEPENDS = "flex-native"
>> +DEPENDS = "flex-native bison-native"
>>   
>>   SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
>>              file://no-gen-libmath.patch \
>
> The question is why you see that and nobody else has, including our
> autobuilder.
>
> I'm guessing something in your build is being rebuilt, hence the need
> for bison whereas in most other builds that isn't rebuilding and hence
> isn't needed.
>
> Are you using a different configuration or extra patches or something?
>
> I'm worried there is a reproducibility issue somewhere in here.
>
> Cheers,
>
> Richard

The problem occurred after I updated the oe-core master and started an 
image rebuild. Built the  image successfully for intel and aarch64 but 
got the above error for raspberrypi4.I ran 'bitbake -c cleansstate 
bc-native bc' but the problem persisted and I added bison-native and was 
able to continue. I never had this problem before, and after checking 
again, I can say that I don't have it anymore either. My image can be 
created again even without bison-native dependency.

I didn't do any patching on bc and also didn't change its configuration.

Markus
Richard Purdie June 22, 2022, 1:29 p.m. UTC | #3
On Wed, 2022-06-22 at 09:50 +0200, Markus Volk wrote:
> Am 21.06.22 um 19:32 schrieb Richard Purdie:
> > On Sat, 2022-06-18 at 19:52 +0200, Markus Volk wrote:
> > > this fixes an error i encountered building for raspberrypi4 32bit:
> > > 
> > > prefix-map=/home/flk/build/poky/build-raspi/tmp/work/cortexa7t2hf-neon-vfpv4-poky-linux-gnueabi/bc/1.07.1-r0/recipe-sysroot-native=  -Wall -funsigned-char -c -o warranty.o ../../bc-1.07.1/bc/warranty.c
> > > > ../../bc-1.07.1/ylwrap: line 176: yacc: command not found
> > > > make[2]: *** [Makefile:429: bc.c] Error 127
> > > Signed-off-by: Markus Volk <f_l_k@t-online.de>
> > > ---
> > >   meta/recipes-extended/bc/bc_1.07.1.bb | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > 
> > > diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
> > > index 1bec76bb2a..67453de822 100644
> > > --- a/meta/recipes-extended/bc/bc_1.07.1.bb
> > > +++ b/meta/recipes-extended/bc/bc_1.07.1.bb
> > > @@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
> > >                       file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
> > >   
> > >   SECTION = "base"
> > > -DEPENDS = "flex-native"
> > > +DEPENDS = "flex-native bison-native"
> > >   
> > >   SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
> > >              file://no-gen-libmath.patch \
> > 
> > The question is why you see that and nobody else has, including our
> > autobuilder.
> > 
> > I'm guessing something in your build is being rebuilt, hence the need
> > for bison whereas in most other builds that isn't rebuilding and hence
> > isn't needed.
> > 
> > Are you using a different configuration or extra patches or something?
> > 
> > I'm worried there is a reproducibility issue somewhere in here.
> > 
> > Cheers,
> > 
> > Richard
> 
> The problem occurred after I updated the oe-core master and started an 
> image rebuild. Built the  image successfully for intel and aarch64 but 
> got the above error for raspberrypi4.I ran 'bitbake -c cleansstate 
> bc-native bc' but the problem persisted and I added bison-native and was 
> able to continue. I never had this problem before, and after checking 
> again, I can say that I don't have it anymore either. My image can be 
> created again even without bison-native dependency.
> 
> I didn't do any patching on bc and also didn't change its configuration.

Do you have the logs from the failed build? I'm wondering if there is
some clue in there about what it wanted to rebuild that needed bison?

I'm reluctant to take this change without understanding what went
wrong...

Cheers,

Richard
Markus Volk June 22, 2022, 2:30 p.m. UTC | #4
Am 22.06.22 um 15:29 schrieb Richard Purdie:
>> The problem occurred after I updated the oe-core master and started an
>> image rebuild. Built the  image successfully for intel and aarch64 but
>> got the above error for raspberrypi4.I ran 'bitbake -c cleansstate
>> bc-native bc' but the problem persisted and I added bison-native and was
>> able to continue. I never had this problem before, and after checking
>> again, I can say that I don't have it anymore either. My image can be
>> created again even without bison-native dependency.
>>
>> I didn't do any patching on bc and also didn't change its configuration.
> Do you have the logs from the failed build? I'm wondering if there is
> some clue in there about what it wanted to rebuild that needed bison?
>
> I'm reluctant to take this change without understanding what went
> wrong...
>
> Cheers,
>
> Richard

Unfortunately, I no longer have a build log of the error and cannot 
reproduce it, so I think you are right to be reluctant.

Markus

Patch

diff --git a/meta/recipes-extended/bc/bc_1.07.1.bb b/meta/recipes-extended/bc/bc_1.07.1.bb
index 1bec76bb2a..67453de822 100644
--- a/meta/recipes-extended/bc/bc_1.07.1.bb
+++ b/meta/recipes-extended/bc/bc_1.07.1.bb
@@ -10,7 +10,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                     file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
 
 SECTION = "base"
-DEPENDS = "flex-native"
+DEPENDS = "flex-native bison-native"
 
 SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
            file://no-gen-libmath.patch \