[v4] python3-cryptography: remove test_x509.py

Message ID 20220613073056.1288293-1-mingli.yu@windriver.com
State Accepted, archived
Commit dd39446dff75c6e48f4aa44ec90087f172d717d4
Headers show
Series [v4] python3-cryptography: remove test_x509.py | expand

Commit Message

Yu, Mingli June 13, 2022, 7:30 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

We already have removed --benchmark-disable option to avoid
adding python3-pytest-benchmark rdepends.

Also remove the case test_x509.py which needs benchmark feature
to avoid below failure:
 file /usr/lib64/python3-cryptography/ptest/tests/bench/test_x509.py, line 9
  def test_aki_public_bytes(benchmark):
 >       fixture 'benchmark' not found
 >       available fixtures: backend, cache, capfd, capfdbinary, caplog, capsys, capsysbinary, disable_rsa_checks, doctesty
 >       use 'pytest --fixtures [testpath]' for help on them.

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/recipes-devtools/python/python3-cryptography_37.0.2.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
index d7a720bf2b..470cf4388c 100644
--- a/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
+++ b/meta/recipes-devtools/python/python3-cryptography_37.0.2.bb
@@ -104,6 +104,9 @@  do_install_ptest() {
     install -D ${WORKDIR}/check-memfree.py ${D}${PTEST_PATH}/
     install -d ${D}${PTEST_PATH}/tests
     cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+    # remove test_x509.py as it needs benchmark and we don't
+    # want to introduce the benchmark dependency
+    rm -rf ${D}${PTEST_PATH}/tests/bench/test_x509.py
     install -d ${D}${PTEST_PATH}/tests/hazmat
     cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
     cp -r ${S}/pyproject.toml ${D}${PTEST_PATH}/