[meta-networking,v3,1/1] mdio-tools: add recipes

Message ID 20220608163628.5745-1-potin.lai.pt@gmail.com
State New
Headers show
Series [meta-networking,v3,1/1] mdio-tools: add recipes | expand

Commit Message

Potin Lai June 8, 2022, 4:36 p.m. UTC
From: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>

Self-description from the README: mdio-tools is a low-level debug tool
for communicating with devices attached to an MDIO bus.

Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
---

LINK: [v2] https://lore.kernel.org/all/20220201142608.186135-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
LINK: [v1] https://lore.kernel.org/all/20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com/

change v2 --> v3:
* update version to 1.1.1

change v1 --> v2:
* moved in recipes-support
* removed version in mdio-tools_1.0.1.inc filename

---
 .../recipes-support/mdio-tools/mdio-netlink_git.bb  | 13 +++++++++++++
 .../recipes-support/mdio-tools/mdio-tools.inc       |  9 +++++++++
 .../recipes-support/mdio-tools/mdio-tools_git.bb    |  9 +++++++++
 3 files changed, 31 insertions(+)
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools.inc
 create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb

Comments

Khem Raj June 30, 2022, 10:59 a.m. UTC | #1
This fails to build on master with latest linux-yocto for kernel.

https://errors.yoctoproject.org/Errors/Details/659130/

On Wed, Jun 8, 2022 at 12:39 PM Potin Lai <potin.lai.pt@gmail.com> wrote:
>
> From: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
>
> Self-description from the README: mdio-tools is a low-level debug tool
> for communicating with devices attached to an MDIO bus.
>
> Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
> Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
> ---
>
> LINK: [v2] https://lore.kernel.org/all/20220201142608.186135-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
> LINK: [v1] https://lore.kernel.org/all/20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
>
> change v2 --> v3:
> * update version to 1.1.1
>
> change v1 --> v2:
> * moved in recipes-support
> * removed version in mdio-tools_1.0.1.inc filename
>
> ---
>  .../recipes-support/mdio-tools/mdio-netlink_git.bb  | 13 +++++++++++++
>  .../recipes-support/mdio-tools/mdio-tools.inc       |  9 +++++++++
>  .../recipes-support/mdio-tools/mdio-tools_git.bb    |  9 +++++++++
>  3 files changed, 31 insertions(+)
>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools.inc
>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
>
> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
> new file mode 100644
> index 000000000..b50d33f90
> --- /dev/null
> +++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
> @@ -0,0 +1,13 @@
> +require mdio-tools.inc
> +
> +DEPENDS += "virtual/kernel libmnl"
> +# This module requires Linux 5.6 higher
> +
> +S = "${WORKDIR}/git/kernel"
> +
> +inherit module
> +
> +EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
> +MODULES_INSTALL_TARGET = "install"
> +
> +RPROVIDES:${PN} += "kernel-module-mdio-netlink"
> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools.inc b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> new file mode 100644
> index 000000000..a37500d93
> --- /dev/null
> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> @@ -0,0 +1,9 @@
> +DESCRIPTION = "A low-level debug tool for communicating with devices attached to an MDIO bus"
> +SECTION = "networking"
> +HOMEPAGE = "https://github.com/wkz/mdio-tools"
> +LICENSE = "GPLv2"
> +LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +
> +SRC_URI = "git://github.com/wkz/mdio-tools.git;protocol=https;branch=master"
> +SRCREV = "07cbff2d5e2de05037e5e7edd5044d678394c8d1"
> +PV = "1.1.1"
> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
> new file mode 100644
> index 000000000..cd4df3da0
> --- /dev/null
> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
> @@ -0,0 +1,9 @@
> +require mdio-tools.inc
> +
> +DEPENDS += "libmnl"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit pkgconfig autotools
> +
> +RDEPENDS:${PN} = "kernel-module-mdio-netlink"
> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97444): https://lists.openembedded.org/g/openembedded-devel/message/97444
> Mute This Topic: https://lists.openembedded.org/mt/91627189/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Potin Lai Aug. 22, 2022, 3:51 a.m. UTC | #2
On 6/30/22 18:59, Khem Raj wrote:
> This fails to build on master with latest linux-yocto for kernel.
>
> https://errors.yoctoproject.org/Errors/Details/659130/
Hi Maintainer,

The kernel config for enable MDIO feature has merged into yocto-kernel-cache.
LINK: https://git.yoctoproject.org/yocto-kernel-cache/commit/?h=yocto-5.15&id=0d58e2d6a7824df62129af91bbe9fadfdb5f9dce

This patch should compiled for qemuarm by now, and I have tested with local build.
Just wondering that how to trigger patch merging process for this patch again? should I resend this patch with new version?

Thanks,
Potin
> On Wed, Jun 8, 2022 at 12:39 PM Potin Lai <potin.lai.pt@gmail.com> wrote:
>> From: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
>>
>> Self-description from the README: mdio-tools is a low-level debug tool
>> for communicating with devices attached to an MDIO bus.
>>
>> Signed-off-by: Enguerrand de Ribaucourt <enguerrand.de-ribaucourt@savoirfairelinux.com>
>> Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
>> ---
>>
>> LINK: [v2] https://lore.kernel.org/all/20220201142608.186135-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
>> LINK: [v1] https://lore.kernel.org/all/20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
>>
>> change v2 --> v3:
>> * update version to 1.1.1
>>
>> change v1 --> v2:
>> * moved in recipes-support
>> * removed version in mdio-tools_1.0.1.inc filename
>>
>> ---
>>  .../recipes-support/mdio-tools/mdio-netlink_git.bb  | 13 +++++++++++++
>>  .../recipes-support/mdio-tools/mdio-tools.inc       |  9 +++++++++
>>  .../recipes-support/mdio-tools/mdio-tools_git.bb    |  9 +++++++++
>>  3 files changed, 31 insertions(+)
>>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
>>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools.inc
>>  create mode 100644 meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
>>
>> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
>> new file mode 100644
>> index 000000000..b50d33f90
>> --- /dev/null
>> +++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
>> @@ -0,0 +1,13 @@
>> +require mdio-tools.inc
>> +
>> +DEPENDS += "virtual/kernel libmnl"
>> +# This module requires Linux 5.6 higher
>> +
>> +S = "${WORKDIR}/git/kernel"
>> +
>> +inherit module
>> +
>> +EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
>> +MODULES_INSTALL_TARGET = "install"
>> +
>> +RPROVIDES:${PN} += "kernel-module-mdio-netlink"
>> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools.inc b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
>> new file mode 100644
>> index 000000000..a37500d93
>> --- /dev/null
>> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
>> @@ -0,0 +1,9 @@
>> +DESCRIPTION = "A low-level debug tool for communicating with devices attached to an MDIO bus"
>> +SECTION = "networking"
>> +HOMEPAGE = "https://github.com/wkz/mdio-tools"
>> +LICENSE = "GPLv2"
>> +LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
>> +
>> +SRC_URI = "git://github.com/wkz/mdio-tools.git;protocol=https;branch=master"
>> +SRCREV = "07cbff2d5e2de05037e5e7edd5044d678394c8d1"
>> +PV = "1.1.1"
>> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
>> new file mode 100644
>> index 000000000..cd4df3da0
>> --- /dev/null
>> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
>> @@ -0,0 +1,9 @@
>> +require mdio-tools.inc
>> +
>> +DEPENDS += "libmnl"
>> +
>> +S = "${WORKDIR}/git"
>> +
>> +inherit pkgconfig autotools
>> +
>> +RDEPENDS:${PN} = "kernel-module-mdio-netlink"
>> --
>> 2.17.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#97444): https://lists.openembedded.org/g/openembedded-devel/message/97444
>> Mute This Topic: https://lists.openembedded.org/mt/91627189/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Aug. 22, 2022, 5:07 a.m. UTC | #3
On Sun, Aug 21, 2022 at 8:53 PM Potin Lai <potin.lai.pt@gmail.com> wrote:

>
> On 6/30/22 18:59, Khem Raj wrote:
> > This fails to build on master with latest linux-yocto for kernel.
> >
> > https://errors.yoctoproject.org/Errors/Details/659130/
> Hi Maintainer,
>
> The kernel config for enable MDIO feature has merged into
> yocto-kernel-cache.
> LINK:
> https://git.yoctoproject.org/yocto-kernel-cache/commit/?h=yocto-5.15&id=0d58e2d6a7824df62129af91bbe9fadfdb5f9dce
>
> This patch should compiled for qemuarm by now, and I have tested with
> local build.
> Just wondering that how to trigger patch merging process for this patch
> again? should I resend this patch with new version?


Yes please send a version tested with latest master of core metadata


>
> Thanks,
> Potin
> > On Wed, Jun 8, 2022 at 12:39 PM Potin Lai <potin.lai.pt@gmail.com>
> wrote:
> >> From: Enguerrand de Ribaucourt <
> enguerrand.de-ribaucourt@savoirfairelinux.com>
> >>
> >> Self-description from the README: mdio-tools is a low-level debug tool
> >> for communicating with devices attached to an MDIO bus.
> >>
> >> Signed-off-by: Enguerrand de Ribaucourt <
> enguerrand.de-ribaucourt@savoirfairelinux.com>
> >> Signed-off-by: Potin Lai <potin.lai.pt@gmail.com>
> >> ---
> >>
> >> LINK: [v2]
> https://lore.kernel.org/all/20220201142608.186135-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
> >> LINK: [v1]
> https://lore.kernel.org/all/20220107150722.2221609-1-enguerrand.de-ribaucourt@savoirfairelinux.com/
> >>
> >> change v2 --> v3:
> >> * update version to 1.1.1
> >>
> >> change v1 --> v2:
> >> * moved in recipes-support
> >> * removed version in mdio-tools_1.0.1.inc filename
> >>
> >> ---
> >>  .../recipes-support/mdio-tools/mdio-netlink_git.bb  | 13 +++++++++++++
> >>  .../recipes-support/mdio-tools/mdio-tools.inc       |  9 +++++++++
> >>  .../recipes-support/mdio-tools/mdio-tools_git.bb    |  9 +++++++++
> >>  3 files changed, 31 insertions(+)
> >>  create mode 100644 meta-networking/recipes-support/mdio-tools/
> mdio-netlink_git.bb
> >>  create mode 100644
> meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> >>  create mode 100644 meta-networking/recipes-support/mdio-tools/
> mdio-tools_git.bb
> >>
> >> diff --git a/meta-networking/recipes-support/mdio-tools/
> mdio-netlink_git.bb b/meta-networking/recipes-support/mdio-tools/
> mdio-netlink_git.bb
> >> new file mode 100644
> >> index 000000000..b50d33f90
> >> --- /dev/null
> >> +++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
> >> @@ -0,0 +1,13 @@
> >> +require mdio-tools.inc
> >> +
> >> +DEPENDS += "virtual/kernel libmnl"
> >> +# This module requires Linux 5.6 higher
> >> +
> >> +S = "${WORKDIR}/git/kernel"
> >> +
> >> +inherit module
> >> +
> >> +EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
> >> +MODULES_INSTALL_TARGET = "install"
> >> +
> >> +RPROVIDES:${PN} += "kernel-module-mdio-netlink"
> >> diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> >> new file mode 100644
> >> index 000000000..a37500d93
> >> --- /dev/null
> >> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
> >> @@ -0,0 +1,9 @@
> >> +DESCRIPTION = "A low-level debug tool for communicating with devices
> attached to an MDIO bus"
> >> +SECTION = "networking"
> >> +HOMEPAGE = "https://github.com/wkz/mdio-tools"
> >> +LICENSE = "GPLv2"
> >> +LIC_FILES_CHKSUM =
> "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> >> +
> >> +SRC_URI = "git://
> github.com/wkz/mdio-tools.git;protocol=https;branch=master"
> >> +SRCREV = "07cbff2d5e2de05037e5e7edd5044d678394c8d1"
> >> +PV = "1.1.1"
> >> diff --git a/meta-networking/recipes-support/mdio-tools/
> mdio-tools_git.bb b/meta-networking/recipes-support/mdio-tools/
> mdio-tools_git.bb
> >> new file mode 100644
> >> index 000000000..cd4df3da0
> >> --- /dev/null
> >> +++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
> >> @@ -0,0 +1,9 @@
> >> +require mdio-tools.inc
> >> +
> >> +DEPENDS += "libmnl"
> >> +
> >> +S = "${WORKDIR}/git"
> >> +
> >> +inherit pkgconfig autotools
> >> +
> >> +RDEPENDS:${PN} = "kernel-module-mdio-netlink"
> >> --
> >> 2.17.1
> >>
> >>
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >> Links: You receive all messages sent to this group.
> >> View/Reply Online (#97444):
> https://lists.openembedded.org/g/openembedded-devel/message/97444
> >> Mute This Topic: https://lists.openembedded.org/mt/91627189/1997914
> >> Group Owner: openembedded-devel+owner@lists.openembedded.org
> >> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
> [raj.khem@gmail.com]
> >> -=-=-=-=-=-=-=-=-=-=-=-
> >>
>

Patch

diff --git a/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
new file mode 100644
index 000000000..b50d33f90
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-netlink_git.bb
@@ -0,0 +1,13 @@ 
+require mdio-tools.inc
+
+DEPENDS += "virtual/kernel libmnl"
+# This module requires Linux 5.6 higher
+
+S = "${WORKDIR}/git/kernel"
+
+inherit module
+
+EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR}"
+MODULES_INSTALL_TARGET = "install"
+
+RPROVIDES:${PN} += "kernel-module-mdio-netlink"
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools.inc b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
new file mode 100644
index 000000000..a37500d93
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools.inc
@@ -0,0 +1,9 @@ 
+DESCRIPTION = "A low-level debug tool for communicating with devices attached to an MDIO bus"
+SECTION = "networking"
+HOMEPAGE = "https://github.com/wkz/mdio-tools"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/git/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/wkz/mdio-tools.git;protocol=https;branch=master"
+SRCREV = "07cbff2d5e2de05037e5e7edd5044d678394c8d1"
+PV = "1.1.1"
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
new file mode 100644
index 000000000..cd4df3da0
--- /dev/null
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_git.bb
@@ -0,0 +1,9 @@ 
+require mdio-tools.inc
+
+DEPENDS += "libmnl"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools
+
+RDEPENDS:${PN} = "kernel-module-mdio-netlink"