[meta-ti,dunfell,v2,5/5] cnm-wave-fw: add compatible for j721s2-hs-evm

Message ID 20220607103529.13068-6-j-choudhary@ti.com
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series Add J721S2 HS platform support | expand

Commit Message

Jayesh Choudhary June 7, 2022, 10:35 a.m. UTC
Add the HS platform to the compatible list in the recipe.

Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
---
 recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | 3 ++-
 recipes-kernel/linux/kernel-rdepends.inc   | 1 +
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Nishanth Menon June 8, 2022, 6:07 p.m. UTC | #1
On 16:05-20220607, Jayesh Choudhary via lists.yoctoproject.org wrote:
> Add the HS platform to the compatible list in the recipe.
> 
> Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
> ---
>  recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | 3 ++-
>  recipes-kernel/linux/kernel-rdepends.inc   | 1 +
>  2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> index 0c432de2..83619090 100644
> --- a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> +++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
> @@ -13,7 +13,7 @@ PR = "${INC_PR}.1"
>  
>  CLEANBROKEN = "1"
>  
> -COMPATIBLE_MACHINE = "j721s2-evm"
> +COMPATIBLE_MACHINE = "j721s2-evm|j721s2-hs-evm"
>  
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
>  
> @@ -22,6 +22,7 @@ TARGET_WAVE521C = "wave521c_codec_fw.bin"
>  
>  SOURCE_WAVE521C = "wave521c_codec_fw.bin"
>  SOURCE_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin"
> +SOURCE_WAVE521C_j721s2-hs-evm = "wave521c_j721s2_codec_fw.bin"

Just curious..

Is the codec binary changing per board? if not, why not just plug it
based on SoC?

>  
>  ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}"
>  ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}"
> diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
> index 17aee4c2..2ebf4948 100644
> --- a/recipes-kernel/linux/kernel-rdepends.inc
> +++ b/recipes-kernel/linux/kernel-rdepends.inc
> @@ -45,6 +45,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
>  
>  # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
>  RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw"
> +RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-hs-evm = " cnm-wave-fw"
>  
>  # Add run-time dependency for TIFS Low Power Module stub
>  RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"
> -- 
> 2.17.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#14791): https://lists.yoctoproject.org/g/meta-ti/message/14791
> Mute This Topic: https://lists.yoctoproject.org/mt/91597545/5513541
> Group Owner: meta-ti+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [nm@ti.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Andrew Davis June 8, 2022, 7:12 p.m. UTC | #2
On 6/8/22 1:07 PM, Nishanth Menon wrote:
> On 16:05-20220607, Jayesh Choudhary via lists.yoctoproject.org wrote:
>> Add the HS platform to the compatible list in the recipe.
>>
>> Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
>> ---
>>   recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb | 3 ++-
>>   recipes-kernel/linux/kernel-rdepends.inc   | 1 +
>>   2 files changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
>> index 0c432de2..83619090 100644
>> --- a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
>> +++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
>> @@ -13,7 +13,7 @@ PR = "${INC_PR}.1"
>>   
>>   CLEANBROKEN = "1"
>>   
>> -COMPATIBLE_MACHINE = "j721s2-evm"
>> +COMPATIBLE_MACHINE = "j721s2-evm|j721s2-hs-evm"
>>   
>>   PACKAGE_ARCH = "${MACHINE_ARCH}"
>>   
>> @@ -22,6 +22,7 @@ TARGET_WAVE521C = "wave521c_codec_fw.bin"
>>   
>>   SOURCE_WAVE521C = "wave521c_codec_fw.bin"
>>   SOURCE_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin"
>> +SOURCE_WAVE521C_j721s2-hs-evm = "wave521c_j721s2_codec_fw.bin"
> 
> Just curious..
> 
> Is the codec binary changing per board? if not, why not just plug it
> based on SoC?
> 


We didn't have a SoC name for j721s2, it used the same name "j7" for
all J7 like SoCs, so we had to add specifics on a per-board basis.

Don't worry, I fixed it in master branch[0], but it would have been too
much churn for a stable like dunfell, so we just have to live with adding
for each specific board instead of per SoC for a bit longer.

[0] https://git.ti.com/cgit/arago-project/meta-ti/commit/?id=531fd1af2333fe831c70a88e7f592a11a58bf94d

Andrew


>>   
>>   ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}"
>>   ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}"
>> diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
>> index 17aee4c2..2ebf4948 100644
>> --- a/recipes-kernel/linux/kernel-rdepends.inc
>> +++ b/recipes-kernel/linux/kernel-rdepends.inc
>> @@ -45,6 +45,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
>>   
>>   # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
>>   RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw"
>> +RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-hs-evm = " cnm-wave-fw"
>>   
>>   # Add run-time dependency for TIFS Low Power Module stub
>>   RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"
>> -- 
>> 2.17.1
>>
> 
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#14791): https://lists.yoctoproject.org/g/meta-ti/message/14791
>> Mute This Topic: https://lists.yoctoproject.org/mt/91597545/5513541
>> Group Owner: meta-ti+owner@lists.yoctoproject.org
>> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [nm@ti.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
> 
>

Patch

diff --git a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index 0c432de2..83619090 100644
--- a/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -13,7 +13,7 @@  PR = "${INC_PR}.1"
 
 CLEANBROKEN = "1"
 
-COMPATIBLE_MACHINE = "j721s2-evm"
+COMPATIBLE_MACHINE = "j721s2-evm|j721s2-hs-evm"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -22,6 +22,7 @@  TARGET_WAVE521C = "wave521c_codec_fw.bin"
 
 SOURCE_WAVE521C = "wave521c_codec_fw.bin"
 SOURCE_WAVE521C_j721s2-evm = "wave521c_j721s2_codec_fw.bin"
+SOURCE_WAVE521C_j721s2-hs-evm = "wave521c_j721s2_codec_fw.bin"
 
 ALTERNATIVE_LINK_NAME[wave521c_codec_fw.bin] = "${base_libdir}/firmware/${TARGET_WAVE521C}"
 ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${base_libdir}/firmware/cnm/${TARGET_WAVE521C}"
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index 17aee4c2..2ebf4948 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -45,6 +45,7 @@  RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " vxd-dec-fw"
 
 # Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
 RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-evm = " cnm-wave-fw"
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-hs-evm = " cnm-wave-fw"
 
 # Add run-time dependency for TIFS Low Power Module stub
 RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"