[kirkstone,18/20] python3-speedtest-cli: fix RDEPENDS

Message ID 17da928a8de487a8c7f7c41eb8db7f8f00aa1564.1654282423.git.akuster808@gmail.com
State Accepted, archived
Headers show
Series [kirkstone,01/20] libcamera: fix packaging | expand

Commit Message

akuster808 June 3, 2022, 7:17 p.m. UTC
From: Bartosz Golaszewski <brgl@bgdev.pl>

There are packages missing in RDEPENDS needed to run speedtest-cli. Add
them and use += for the assignment as we don't know what inherited
classes may have added.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 3413265185dd199da0f54ef6d83abca2c8ec9b50)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
 .../recipes-devtools/python/python3-speedtest-cli_2.1.3.bb  | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
index 06d98cbe1e..472113b059 100644
--- a/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
+++ b/meta-python/recipes-devtools/python/python3-speedtest-cli_2.1.3.bb
@@ -7,4 +7,8 @@  SRC_URI[sha256sum] = "5e2773233cedb5fa3d8120eb7f97bcc4974b5221b254d33ff16e2f1d41
 
 inherit pypi setuptools3
 
-RDEPENDS:${PN} = "${PYTHON_PN}-misc"
+RDEPENDS:${PN} += " \
+    python3-misc \
+    python3-threading \
+    python3-xml \
+"