[meta-multimedia] flite: add recipe

Message ID 20220530122952.2715776-1-samuli.piippo@qt.io
State Under Review
Headers show
Series [meta-multimedia] flite: add recipe | expand

Commit Message

Samuli Piippo May 30, 2022, 12:29 p.m. UTC
CMU Flite (festival-lite) is a small, fast run-time open source
text to speech synthesis engine developed at CMU and primarily
designed for small embedded machines.

Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
 .../recipes-multimedia/flite/flite_2.2.bb     | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
 create mode 100644 meta-multimedia/recipes-multimedia/flite/flite_2.2.bb

Comments

Scott Murray May 30, 2022, 2:43 p.m. UTC | #1
On Mon, 30 May 2022, Samuli Piippo wrote:

> CMU Flite (festival-lite) is a small, fast run-time open source
> text to speech synthesis engine developed at CMU and primarily
> designed for small embedded machines.
>
> Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
> ---
>  .../recipes-multimedia/flite/flite_2.2.bb     | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
>  create mode 100644 meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
>
> diff --git a/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> new file mode 100644
> index 000000000..9ab9c0208
> --- /dev/null
> +++ b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> @@ -0,0 +1,19 @@
> +SUMMARY = "Flite: a small run-time speech synthesis engine"
> +HOMEPAGE = "http://cmuflite.org"
> +SECTION = "libs/multimedia"
> +LICENSE = "BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
> +
> +inherit autotools-brokensep
> +
> +SRC_URI = "git://github.com/festvox/flite.git;protocol=https;branch=master"
> +
> +SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
[snip]

There's no 2.3 tag, but the README.md and Makefile imply that 2.3 was
released in March 2022 (see commit 530060de), and the current voice files
on http://festvox.org/flite/packed/ are "flite-2.3".  So perhaps this
should be building that instead of the ~2 years old 2.2?

> +
> +S = "${WORKDIR}/git"
> +
> +EXTRA_OECONF += "--enable-shared"
> +
> +do_install:append() {
> +    chown -R root:root ${D}${libdir}/*

This seems a bit odd, I'm curious what prompted adding it?

> +}
>
Samuli Piippo May 31, 2022, 12:12 p.m. UTC | #2
On Mon, 30 May 2022 at 17:43, Scott Murray <scott.murray@konsulko.com>
wrote:

> On Mon, 30 May 2022, Samuli Piippo wrote:
>
> > CMU Flite (festival-lite) is a small, fast run-time open source
> > text to speech synthesis engine developed at CMU and primarily
> > designed for small embedded machines.
> >
> > Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
> > ---
> >  .../recipes-multimedia/flite/flite_2.2.bb     | 19 +++++++++++++++++++
> >  1 file changed, 19 insertions(+)
> >  create mode 100644 meta-multimedia/recipes-multimedia/flite/
> flite_2.2.bb
> >
> > diff --git a/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > new file mode 100644
> > index 000000000..9ab9c0208
> > --- /dev/null
> > +++ b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > @@ -0,0 +1,19 @@
> > +SUMMARY = "Flite: a small run-time speech synthesis engine"
> > +HOMEPAGE = "http://cmuflite.org"
> > +SECTION = "libs/multimedia"
> > +LICENSE = "BSD-3-Clause"
> > +LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
> > +
> > +inherit autotools-brokensep
> > +
> > +SRC_URI = "git://
> github.com/festvox/flite.git;protocol=https;branch=master"
> > +
> > +SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
> [snip]
>
> There's no 2.3 tag, but the README.md and Makefile imply that 2.3 was
> released in March 2022 (see commit 530060de), and the current voice files
> on http://festvox.org/flite/packed/ are "flite-2.3".  So perhaps this
> should be building that instead of the ~2 years old 2.2?
>

Hard to say if there's a specific revision that was meant to be the
release, but I could update this to 2.3 and just use the latest revision?


> > +
> > +S = "${WORKDIR}/git"
> > +
> > +EXTRA_OECONF += "--enable-shared"
> > +
> > +do_install:append() {
> > +    chown -R root:root ${D}${libdir}/*
>
> This seems a bit odd, I'm curious what prompted adding it?
>

The installed files had local user and group IDs that caused host
contamination error.
Scott Murray May 31, 2022, 3:35 p.m. UTC | #3
On Tue, 31 May 2022, Samuli Piippo wrote:

> On Mon, 30 May 2022 at 17:43, Scott Murray <scott.murray@konsulko.com>
> wrote:
>
> > On Mon, 30 May 2022, Samuli Piippo wrote:
> >
> > > CMU Flite (festival-lite) is a small, fast run-time open source
> > > text to speech synthesis engine developed at CMU and primarily
> > > designed for small embedded machines.
> > >
> > > Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
> > > ---
> > >  .../recipes-multimedia/flite/flite_2.2.bb     | 19 +++++++++++++++++++
> > >  1 file changed, 19 insertions(+)
> > >  create mode 100644 meta-multimedia/recipes-multimedia/flite/
> > flite_2.2.bb
> > >
> > > diff --git a/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > > new file mode 100644
> > > index 000000000..9ab9c0208
> > > --- /dev/null
> > > +++ b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > > @@ -0,0 +1,19 @@
> > > +SUMMARY = "Flite: a small run-time speech synthesis engine"
> > > +HOMEPAGE = "http://cmuflite.org"
> > > +SECTION = "libs/multimedia"
> > > +LICENSE = "BSD-3-Clause"
> > > +LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
> > > +
> > > +inherit autotools-brokensep
> > > +
> > > +SRC_URI = "git://
> > github.com/festvox/flite.git;protocol=https;branch=master"
> > > +
> > > +SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
> > [snip]
> >
> > There's no 2.3 tag, but the README.md and Makefile imply that 2.3 was
> > released in March 2022 (see commit 530060de), and the current voice files
> > on http://festvox.org/flite/packed/ are "flite-2.3".  So perhaps this
> > should be building that instead of the ~2 years old 2.2?
>
> Hard to say if there's a specific revision that was meant to be the
> release, but I could update this to 2.3 and just use the latest revision?

I'd be in favor of a _git recipe that set PV = "2.3+git${SRCPV}", but Khem
might have a different opinion.

> > > +
> > > +S = "${WORKDIR}/git"
> > > +
> > > +EXTRA_OECONF += "--enable-shared"
> > > +
> > > +do_install:append() {
> > > +    chown -R root:root ${D}${libdir}/*
> >
> > This seems a bit odd, I'm curious what prompted adding it?
>
> The installed files had local user and group IDs that caused host
> contamination error.

Hrm, that suggests upstream have a broken Makefile using "cp -p", it could
be worthwhile to poke them about it.  We have had a recipe for an older
version in AGL for quite a while and didn't see it, so it seems like
something changed.

Scott
Khem Raj May 31, 2022, 3:43 p.m. UTC | #4
On Tue, May 31, 2022 at 8:35 AM Scott Murray <scott.murray@konsulko.com> wrote:
>
> On Tue, 31 May 2022, Samuli Piippo wrote:
>
> > On Mon, 30 May 2022 at 17:43, Scott Murray <scott.murray@konsulko.com>
> > wrote:
> >
> > > On Mon, 30 May 2022, Samuli Piippo wrote:
> > >
> > > > CMU Flite (festival-lite) is a small, fast run-time open source
> > > > text to speech synthesis engine developed at CMU and primarily
> > > > designed for small embedded machines.
> > > >
> > > > Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
> > > > ---
> > > >  .../recipes-multimedia/flite/flite_2.2.bb     | 19 +++++++++++++++++++
> > > >  1 file changed, 19 insertions(+)
> > > >  create mode 100644 meta-multimedia/recipes-multimedia/flite/
> > > flite_2.2.bb
> > > >
> > > > diff --git a/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > > b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > > > new file mode 100644
> > > > index 000000000..9ab9c0208
> > > > --- /dev/null
> > > > +++ b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
> > > > @@ -0,0 +1,19 @@
> > > > +SUMMARY = "Flite: a small run-time speech synthesis engine"
> > > > +HOMEPAGE = "http://cmuflite.org"
> > > > +SECTION = "libs/multimedia"
> > > > +LICENSE = "BSD-3-Clause"
> > > > +LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
> > > > +
> > > > +inherit autotools-brokensep
> > > > +
> > > > +SRC_URI = "git://
> > > github.com/festvox/flite.git;protocol=https;branch=master"
> > > > +
> > > > +SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
> > > [snip]
> > >
> > > There's no 2.3 tag, but the README.md and Makefile imply that 2.3 was
> > > released in March 2022 (see commit 530060de), and the current voice files
> > > on http://festvox.org/flite/packed/ are "flite-2.3".  So perhaps this
> > > should be building that instead of the ~2 years old 2.2?
> >
> > Hard to say if there's a specific revision that was meant to be the
> > release, but I could update this to 2.3 and just use the latest revision?
>
> I'd be in favor of a _git recipe that set PV = "2.3+git${SRCPV}", but Khem
> might have a different opinion.

yeah if there is no tag then this is a better approach.

>
> > > > +
> > > > +S = "${WORKDIR}/git"
> > > > +
> > > > +EXTRA_OECONF += "--enable-shared"
> > > > +
> > > > +do_install:append() {
> > > > +    chown -R root:root ${D}${libdir}/*
> > >
> > > This seems a bit odd, I'm curious what prompted adding it?
> >
> > The installed files had local user and group IDs that caused host
> > contamination error.
>
> Hrm, that suggests upstream have a broken Makefile using "cp -p", it could
> be worthwhile to poke them about it.  We have had a recipe for an older
> version in AGL for quite a while and didn't see it, so it seems like
> something changed.

right, its perhaps in install target of makefile where it maybe the
better place to fix
it and also upstream it.

>
> Scott
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97353): https://lists.openembedded.org/g/openembedded-devel/message/97353
> Mute This Topic: https://lists.openembedded.org/mt/91429478/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
new file mode 100644
index 000000000..9ab9c0208
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/flite/flite_2.2.bb
@@ -0,0 +1,19 @@ 
+SUMMARY = "Flite: a small run-time speech synthesis engine"
+HOMEPAGE = "http://cmuflite.org"
+SECTION = "libs/multimedia"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
+
+inherit autotools-brokensep
+
+SRC_URI = "git://github.com/festvox/flite.git;protocol=https;branch=master"
+
+SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF += "--enable-shared"
+
+do_install:append() {
+    chown -R root:root ${D}${libdir}/*
+}