[meta-filesystems] overlayfs-tools: add new recipe

Message ID 20220522204207.2323510-1-uvv.mail@gmail.com
State Under Review
Headers show
Series [meta-filesystems] overlayfs-tools: add new recipe | expand

Commit Message

Vyacheslav Yurkov May 22, 2022, 8:42 p.m. UTC
From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>

This package provides maintenance tools for OverlayFS, such as vacuum,
diff, merge, and deref

Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
---
 ...-so-that-it-compiles-on-Ubuntu-20.04.patch | 41 +++++++++++++++++++
 .../overlayfs/overlayfs-tools_git.bb          | 28 +++++++++++++
 2 files changed, 69 insertions(+)
 create mode 100644 meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
 create mode 100644 meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb

Comments

Khem Raj May 23, 2022, 3:11 p.m. UTC | #1
needs some patching on musl see
https://errors.yoctoproject.org/Errors/Details/657137/

On Sun, May 22, 2022 at 1:42 PM Vyacheslav Yurkov <uvv.mail@gmail.com> wrote:
>
> From: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
>
> This package provides maintenance tools for OverlayFS, such as vacuum,
> diff, merge, and deref
>
> Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com>
> ---
>  ...-so-that-it-compiles-on-Ubuntu-20.04.patch | 41 +++++++++++++++++++
>  .../overlayfs/overlayfs-tools_git.bb          | 28 +++++++++++++
>  2 files changed, 69 insertions(+)
>  create mode 100644 meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
>  create mode 100644 meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
>
> diff --git a/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch b/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
> new file mode 100644
> index 000000000..f7490ebce
> --- /dev/null
> +++ b/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
> @@ -0,0 +1,41 @@
> +From 81b4fbb5f52044cb348534c23f10b3884972b09b Mon Sep 17 00:00:00 2001
> +From: Beat Schaer <beat.schaer@wabtec.com>
> +Date: Fri, 19 Mar 2021 08:18:58 +0100
> +Subject: [PATCH] Fixed includes so that it compiles on Ubuntu 20.04
> +
> +---
> + logic.c | 3 +--
> + main.c  | 3 ++-
> + 2 files changed, 3 insertions(+), 3 deletions(-)
> +
> +diff --git a/logic.c b/logic.c
> +index 97767f5..47ebfaa 100644
> +--- a/logic.c
> ++++ b/logic.c
> +@@ -7,8 +7,7 @@
> + #include <string.h>
> + #include <errno.h>
> + #include <unistd.h>
> +-#include <attr/xattr.h>
> +-#include <attr/attributes.h>
> ++#include <sys/xattr.h>
> + #include <fts.h>
> + #include <libgen.h>
> + #include "logic.h"
> +diff --git a/main.c b/main.c
> +index aa11239..f462b98 100644
> +--- a/main.c
> ++++ b/main.c
> +@@ -12,7 +12,8 @@
> + #include <linux/limits.h>
> + #include <stdbool.h>
> + #include <sys/stat.h>
> +-#include <attr/xattr.h>
> ++#include <sys/xattr.h>
> ++#include <errno.h>
> + #ifndef _SYS_STAT_H
> +   #include <linux/stat.h>
> + #endif
> +--
> +2.25.1
> +
> diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
> new file mode 100644
> index 000000000..b0406fbae
> --- /dev/null
> +++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
> @@ -0,0 +1,28 @@
> +DESCRIPTION = "Maintenance tools for OverlayFS"
> +HOMEPAGE = "https://github.com/kmxz/overlayfs-tools"
> +LICENSE = "WTFPL"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69"
> +
> +SRC_URI = "\
> +    git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \
> +    file://0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch \
> +"
> +
> +PV = "1.0+git${SRCPV}"
> +SRCREV = "291c7f4a3fb548d06c572700650c2e3bccb0cd27"
> +
> +S = "${WORKDIR}/git"
> +B = "${S}"
> +
> +DEPENDS += "attr"
> +EXTRA_OEMAKE += "'CC=${CC} -O2'"
> +TARGET_CC_ARCH += "${LDFLAGS}"
> +
> +do_compile () {
> +    oe_runmake
> +}
> +
> +do_install () {
> +    install -d ${D}${bindir}
> +    install -m 0755 ${B}/overlay ${D}${bindir}
> +}
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#97220): https://lists.openembedded.org/g/openembedded-devel/message/97220
> Mute This Topic: https://lists.openembedded.org/mt/91275863/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch b/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
new file mode 100644
index 000000000..f7490ebce
--- /dev/null
+++ b/meta-filesystems/recipes-utils/overlayfs/files/0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch
@@ -0,0 +1,41 @@ 
+From 81b4fbb5f52044cb348534c23f10b3884972b09b Mon Sep 17 00:00:00 2001
+From: Beat Schaer <beat.schaer@wabtec.com>
+Date: Fri, 19 Mar 2021 08:18:58 +0100
+Subject: [PATCH] Fixed includes so that it compiles on Ubuntu 20.04
+
+---
+ logic.c | 3 +--
+ main.c  | 3 ++-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/logic.c b/logic.c
+index 97767f5..47ebfaa 100644
+--- a/logic.c
++++ b/logic.c
+@@ -7,8 +7,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <unistd.h>
+-#include <attr/xattr.h>
+-#include <attr/attributes.h>
++#include <sys/xattr.h>
+ #include <fts.h>
+ #include <libgen.h>
+ #include "logic.h"
+diff --git a/main.c b/main.c
+index aa11239..f462b98 100644
+--- a/main.c
++++ b/main.c
+@@ -12,7 +12,8 @@
+ #include <linux/limits.h>
+ #include <stdbool.h>
+ #include <sys/stat.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
++#include <errno.h>
+ #ifndef _SYS_STAT_H
+   #include <linux/stat.h>
+ #endif
+-- 
+2.25.1
+
diff --git a/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
new file mode 100644
index 000000000..b0406fbae
--- /dev/null
+++ b/meta-filesystems/recipes-utils/overlayfs/overlayfs-tools_git.bb
@@ -0,0 +1,28 @@ 
+DESCRIPTION = "Maintenance tools for OverlayFS"
+HOMEPAGE = "https://github.com/kmxz/overlayfs-tools"
+LICENSE = "WTFPL"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f312a7c4d02230e8f2b537295d375c69"
+
+SRC_URI = "\
+    git://github.com/kmxz/overlayfs-tools.git;protocol=https;branch=master \
+    file://0001-Fixed-includes-so-that-it-compiles-on-Ubuntu-20.04.patch \
+"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "291c7f4a3fb548d06c572700650c2e3bccb0cd27"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+DEPENDS += "attr"
+EXTRA_OEMAKE += "'CC=${CC} -O2'"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+do_compile () {
+    oe_runmake
+}
+
+do_install () {
+    install -d ${D}${bindir}
+    install -m 0755 ${B}/overlay ${D}${bindir}
+}