[meta-security,kirkstone] lib-perl: prefix man pages to avoid conflicting with base perl

Message ID 20220520183224.2579404-1-jpuhlman@mvista.com
State Accepted, archived
Delegated to: Armin Kuster
Headers show
Series [meta-security,kirkstone] lib-perl: prefix man pages to avoid conflicting with base perl | expand

Commit Message

Jeremy Puhlman May 20, 2022, 6:32 p.m. UTC
The following occurs when pkgs-docs added to image features.

Error: Transaction test error:
  file /usr/share/man/man3/lib.3 conflicts between attempted installs of lib-perl-doc-0.63-r0.corei7_64 and perl-doc-5.34.1-r0.corei7_64

Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com>
---
 recipes-perl/perl/lib-perl_0.63.bb | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

akuster808 May 23, 2022, 8:25 p.m. UTC | #1
merged.

thanks

On 5/20/22 11:32, Jeremy Puhlman wrote:
> The following occurs when pkgs-docs added to image features.
>
> Error: Transaction test error:
>    file /usr/share/man/man3/lib.3 conflicts between attempted installs of lib-perl-doc-0.63-r0.corei7_64 and perl-doc-5.34.1-r0.corei7_64
>
> Signed-off-by: Jeremy A. Puhlman <jpuhlman@mvista.com>
> ---
>   recipes-perl/perl/lib-perl_0.63.bb | 7 +++++++
>   1 file changed, 7 insertions(+)
>
> diff --git a/recipes-perl/perl/lib-perl_0.63.bb b/recipes-perl/perl/lib-perl_0.63.bb
> index 4c964d5..25d0890 100644
> --- a/recipes-perl/perl/lib-perl_0.63.bb
> +++ b/recipes-perl/perl/lib-perl_0.63.bb
> @@ -26,3 +26,10 @@ do_compile() {
>   	export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
>   	cpan_do_compile
>   }
> +
> +do_install:append() {
> +   # Man pages here conflict wtih the main perl documentation
> +   for page in ${D}${mandir}/man*/*; do
> +        mv $page $(dirname $page)/${BPN}-$(basename $page)
> +    done
> +}
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#57148): https://lists.yoctoproject.org/g/yocto/message/57148
> Mute This Topic: https://lists.yoctoproject.org/mt/91237492/3616698
> Group Owner: yocto+owner@lists.yoctoproject.org
> Unsubscribe: https://lists.yoctoproject.org/g/yocto/unsub [akuster808@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/recipes-perl/perl/lib-perl_0.63.bb b/recipes-perl/perl/lib-perl_0.63.bb
index 4c964d5..25d0890 100644
--- a/recipes-perl/perl/lib-perl_0.63.bb
+++ b/recipes-perl/perl/lib-perl_0.63.bb
@@ -26,3 +26,10 @@  do_compile() {
 	export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
 	cpan_do_compile
 }
+
+do_install:append() {
+   # Man pages here conflict wtih the main perl documentation
+   for page in ${D}${mandir}/man*/*; do
+        mv $page $(dirname $page)/${BPN}-$(basename $page)
+    done
+}