Patchwork [CONSOLIDATED,PULL,06/16] default-versions: Update pulseaudio as arm no longer needs a seperate backport

login
register
mail settings
Submitter Saul Wold
Date July 22, 2011, 7:25 a.m.
Message ID <094c87f1cc2f3c987a4975a420994ace4529c521.1311318447.git.sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/8277/
State New, archived
Headers show

Comments

Saul Wold - July 22, 2011, 7:25 a.m.
Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/conf/distro/include/default-versions.inc |    4 +---
 1 files changed, 1 insertions(+), 3 deletions(-)
Koen Kooi - July 22, 2011, 7:52 a.m.
Op 22 jul. 2011, om 09:25 heeft Saul Wold het volgende geschreven:

> Signed-off-by: Saul Wold <sgw@linux.intel.com>
> ---
> meta/conf/distro/include/default-versions.inc |    4 +---
> 1 files changed, 1 insertions(+), 3 deletions(-)
> 
> diff --git a/meta/conf/distro/include/default-versions.inc b/meta/conf/distro/include/default-versions.inc
> index 377aba5..e3ef1e6 100644
> --- a/meta/conf/distro/include/default-versions.inc
> +++ b/meta/conf/distro/include/default-versions.inc
> @@ -1,9 +1,7 @@
> #
> # Default preferred versions
> #
> -PULSEAUDIOVERSION ?= "0.9.22"
> -PULSEAUDIOVERSION_arm ?= "0.9.15"
> -PREFERRED_VERSION_pulseaudio ?= "${PULSEAUDIOVERSION}"
> +PREFERRED_VERSION_pulseaudio ?= "0.9.23"

If you do that you need to rebuild things linking against pulse as well, e.g. gst-plugins-good. I haven't checked if gst actually depends on pull in oe-core though.

Patch

diff --git a/meta/conf/distro/include/default-versions.inc b/meta/conf/distro/include/default-versions.inc
index 377aba5..e3ef1e6 100644
--- a/meta/conf/distro/include/default-versions.inc
+++ b/meta/conf/distro/include/default-versions.inc
@@ -1,9 +1,7 @@ 
 #
 # Default preferred versions
 #
-PULSEAUDIOVERSION ?= "0.9.22"
-PULSEAUDIOVERSION_arm ?= "0.9.15"
-PREFERRED_VERSION_pulseaudio ?= "${PULSEAUDIOVERSION}"
+PREFERRED_VERSION_pulseaudio ?= "0.9.23"
 
 # Force the python versions in one place
 PYTHON_BASEVERSION ?= "2.6"