[meta-python,01/16] python3-toolz: new package

Message ID 20220512084152.1388464-2-brgl@bgdev.pl
State Under Review
Headers show
Series python: add a bunch of packages for interacting with ethereum blockchains | expand

Commit Message

Bartosz Golaszewski May 12, 2022, 8:41 a.m. UTC
Add a recipe for toolz: a set of utility functions for iterators,
functions, and dictionaries.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
 .../packagegroups/packagegroup-meta-python.bb      |  1 +
 .../python/python3-toolz_0.11.2.bb                 | 14 ++++++++++++++
 2 files changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index bee529805..5edec8f68 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -405,6 +405,7 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-thrift \
     python3-tinyrecord \
     python3-tornado \
+    python3-toolz \
     python3-tqdm \
     python3-trafaret \
     python3-trafaret-config \
diff --git a/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb b/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb
new file mode 100644
index 000000000..a597641e5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-toolz_0.11.2.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "A set of utility functions for iterators, functions, and dictionaries."
+HOMEPAGE = "https://github.com/pytoolz/toolz"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=ca09cab178326d18433aae982d1edf5d"
+
+SRC_URI[sha256sum] = "6b312d5e15138552f1bda8a4e66c30e236c831b612b2bf0005f8a1df10a4bc33"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    python3-json \
+    python3-math \
+"