Patchwork [meta-oe,1/2] collectd: make amqp plugin a selectable feature

login
register
mail settings
Submitter Maciej Borzecki
Date Aug. 14, 2014, 3:31 p.m.
Message ID <1408030303-742-2-git-send-email-maciej.borzecki@open-rnd.pl>
Download mbox | patch
Permalink /patch/78241/
State Accepted, archived
Headers show

Comments

Maciej Borzecki - Aug. 14, 2014, 3:31 p.m.
The version of rabbitmq-c that collectd is compatible with, is older
than currently available 0.5.0. This results in build errors
triggerred by API deprecation at rabbitmq-c side. Make amqp
plugin a selectable feature, disabled by default.

Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl>
Signed-off-by: Maciek Borzecki <maciek.borzecki@gmail.com>
---
 meta-oe/recipes-extended/collectd/collectd_5.2.2.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb b/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
index 6b9b7bd..30279c2 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.2.2.bb
@@ -30,6 +30,8 @@  PACKAGECONFIG[modbus] = "--enable-modbus,--disable-modbus,libmodbus"
 PACKAGECONFIG[libowcapi] = "--with-libowcapi,--without-libowcapi,owfs"
 PACKAGECONFIG[sensors] = "--enable-sensors --with-libsensors=yes, \
         --disable-sensors --with-libsensors=no,lmsensors"
+PACKAGECONFIG[amqp] = "--enable-amqp --with-librabbitmq=yes, \
+        --disable-amqp --with-librabbitmq=no,rabbitmq-c"
 
 EXTRA_OECONF = " \
                 ${FPLAYOUT} \