Patchwork qemu: Add PACKAGECONFIG for glx

login
register
mail settings
Submitter Richard Purdie
Date Aug. 14, 2014, 2:26 p.m.
Message ID <1408026413.22187.113.camel@ted>
Download mbox | patch
Permalink /patch/78231/
State Accepted
Commit 42f0ffe6f8147bf20f58a47b3f150d922dcfc14d
Headers show

Comments

Richard Purdie - Aug. 14, 2014, 2:26 p.m.
With the configuration for sdl and glx, the virtual/libx11 in DEPENDS
no longer makes any sense at all, the dependency comes through the
various graphics backends. Therefore drop it. The glx PACKAGECONFIG
is added for completeness. We avoid a floating dependency on mesa.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

Patch

diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index e6f9e38..aaec58a 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -1,8 +1,7 @@ 
 SUMMARY = "Fast open source processor emulator"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "glib-2.0 zlib pixman \
-           ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
+DEPENDS = "glib-2.0 zlib pixman"
 DEPENDS_class-native = "zlib-native glib-2.0-native pixman-native"
 DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-glib-2.0 nativesdk-pixman"
 RDEPENDS_${PN}_class-nativesdk = "nativesdk-libsdl"
@@ -103,6 +102,7 @@  PACKAGECONFIG[ssh2] = "--enable-libssh2,--disable-libssh2,libssh2,"
 PACKAGECONFIG[libusb] = "--enable-libusb,--disable-libusb,libusb1"
 PACKAGECONFIG[fdt] = "--enable-fdt,--disable-fdt,dtc"
 PACKAGECONFIG[alsa] = ",,alsa-lib"
+PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
 
 EXTRA_OECONF += "${@bb.utils.contains('PACKAGECONFIG', 'alsa', '--audio-drv-list=oss,alsa', '', d)}"