Patchwork gdk-pixbuf(-native): Fix build by disabling introspection

login
register
mail settings
Submitter Andreas Müller
Date July 16, 2011, 10:48 p.m.
Message ID <1310856514-12964-1-git-send-email-schnitzeltony@gmx.de>
Download mbox | patch
Permalink /patch/7721/
State New, archived
Headers show

Comments

Andreas Müller - July 16, 2011, 10:48 p.m.
Error message was:
| /home/Superandy/tmp/oe-core-eglibc/sysroots/x86_64-linux/usr/bin/g-ir-compiler  --includedir=. GdkPixbuf-2.0.gir -o GdkPixbuf-2.0.typelib
| /usr/share/gir-1.0/GLib-2.0.gir:9:1: error: Unsupported version '1.1'
| /usr/share/gir-1.0/GLib-2.0.gir:9:39: error: Unsupported version '1.1'
| error parsing file GdkPixbuf-2.0.gir: Failed to parse included gir GLib-2.0
| make[4]: *** [GdkPixbuf-2.0.typelib] Error 1

Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de>
---
 meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)
Tom Rini - July 17, 2011, 2:25 p.m.
On 07/16/2011 03:48 PM, Andreas Mueller wrote:
> Error message was:
> | /home/Superandy/tmp/oe-core-eglibc/sysroots/x86_64-linux/usr/bin/g-ir-compiler  --includedir=. GdkPixbuf-2.0.gir -o GdkPixbuf-2.0.typelib
> | /usr/share/gir-1.0/GLib-2.0.gir:9:1: error: Unsupported version '1.1'
> | /usr/share/gir-1.0/GLib-2.0.gir:9:39: error: Unsupported version '1.1'
> | error parsing file GdkPixbuf-2.0.gir: Failed to parse included gir GLib-2.0
> | make[4]: *** [GdkPixbuf-2.0.typelib] Error 1
> 
> Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de>

Sounds like gnome.bbclass is out of sync and we need both
--enable-introspection=no and --disable-scrollkeeper.
Saul Wold - July 20, 2011, 4:47 p.m.
On 07/16/2011 03:48 PM, Andreas Mueller wrote:
> Error message was:
> | /home/Superandy/tmp/oe-core-eglibc/sysroots/x86_64-linux/usr/bin/g-ir-compiler  --includedir=. GdkPixbuf-2.0.gir -o GdkPixbuf-2.0.typelib
> | /usr/share/gir-1.0/GLib-2.0.gir:9:1: error: Unsupported version '1.1'
> | /usr/share/gir-1.0/GLib-2.0.gir:9:39: error: Unsupported version '1.1'
> | error parsing file GdkPixbuf-2.0.gir: Failed to parse included gir GLib-2.0
> | make[4]: *** [GdkPixbuf-2.0.typelib] Error 1
>
> Signed-off-by: Andreas Mueller<schnitzeltony@gmx.de>
> ---
>   meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb |    3 ++-
>   1 files changed, 2 insertions(+), 1 deletions(-)
>
> diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> index 8b6314f..e3f5977 100644
> --- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> @@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
>   SECTION = "libs"
>
>   DEPENDS = "libpng glib-2.0 jpeg"
> -PR = "r0"
> +PR = "r1"
>
>   SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.22/gdk-pixbuf-${PV}.tar.gz \
>              file://hardcoded_libtool.patch;patch=1 \
> @@ -26,6 +26,7 @@ LIBV = "2.10.0"
>   EXTRA_OECONF = "\
>     --without-libtiff \
>     --with-libpng \
> +  --disable-introspection \
>   "
>
>   FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \

Merged into oe-core

There was a comment from Tom about gnome.bbclass, are you looking into that?

Sau!
Andreas Müller - July 20, 2011, 11:14 p.m.
On Wednesday, July 20, 2011 06:47:54 PM you wrote:
> On 07/16/2011 03:48 PM, Andreas Mueller wrote:
> > Error message was:
> > | /home/Superandy/tmp/oe-core-eglibc/sysroots/x86_64-linux/usr/bin/g-ir-c
> > | ompiler  --includedir=. GdkPixbuf-2.0.gir -o GdkPixbuf-2.0.typelib
> > | /usr/share/gir-1.0/GLib-2.0.gir:9:1: error: Unsupported version '1.1'
> > | /usr/share/gir-1.0/GLib-2.0.gir:9:39: error: Unsupported version '1.1'
> > | error parsing file GdkPixbuf-2.0.gir: Failed to parse included gir
> > | GLib-2.0 make[4]: *** [GdkPixbuf-2.0.typelib] Error 1
> > 
> > Signed-off-by: Andreas Mueller<schnitzeltony@gmx.de>
> > ---
> > 
> >   meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb |    3 ++-
> >   1 files changed, 2 insertions(+), 1 deletions(-)
> > 
> > diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> > b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb index
> > 8b6314f..e3f5977 100644
> > --- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> > +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
> > @@ -9,7 +9,7 @@ LIC_FILES_CHKSUM =
> > "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
> > 
> >   SECTION = "libs"
> >   
> >   DEPENDS = "libpng glib-2.0 jpeg"
> > 
> > -PR = "r0"
> > +PR = "r1"
> > 
> >   SRC_URI =
> >   "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.22/gdk-pixbuf-${
> >   PV}.tar.gz \
> >   
> >              file://hardcoded_libtool.patch;patch=1 \
> > 
> > @@ -26,6 +26,7 @@ LIBV = "2.10.0"
> > 
> >   EXTRA_OECONF = "\
> >   
> >     --without-libtiff \
> >     --with-libpng \
> > 
> > +  --disable-introspection \
> > 
> >   "
> >   
> >   FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
> 
> Merged into oe-core
> 
> There was a comment from Tom about gnome.bbclass, are you looking into
> that?

On Sunday, July 17, 2011 04:25:48 PM Tom Rini wrote:
> Sounds like gnome.bbclass is out of sync and we need both
> --enable-introspection=no and --disable-scrollkeeper.

--enable-introspection=no: 
I grepped around in oe-core for recipes with gobject-introspection disabled (did 
not care of other layers - e.g meta-oe has its own gnome-bbclass with "--enable-
introspection=no").

If I am not mistaken we have the following recipes requiring gnome.bbclass:
1. json-glib_0.12.4.bb:EXTRA_OECONF = "--disable-introspection"
2. mutter.inc:	         --without-introspection \

and the following *not* requiring gnome.bbclass
1. polkit-gnome_0.101.bb:                 --disable-introspection "
2. polkit_0.101.bb:EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --
disable-man-pages --disable-gtk-doc --disable-introspection"
3. gupnp_0.16.1.bb:EXTRA_OECONF = "--disable-introspection"
4. gssdp_0.10.0.bb:EXTRA_OECONF = "--disable-introspection"
5. gdk-pixbuf/gdk-pixbuf_2.22.1.bb:  --disable-introspection \
6. python-pygobject_2.27.91.bb:EXTRA_OECONF += "--disable-introspection"
7. clutter-box2d-1.6_0.10.0.bb:BASE_CONF += "--disable-introspection"
8. clutter_git.bb:BASE_CONF += "--disable-introspection"
9. clutter-1.6_1.6.14.bb:BASE_CONF += "--disable-introspection"
10. udev_145.bb:EXTRA_OECONF = "--with-udev-prefix= --disable-extras --disable-
introspection"

Currenly a move of --enable-introspection=no to gnome.bbclass would 'clean' 2 
recipes but affect all requiring gnome.bbclass. Most victims of gobject-
introspection are not requiring gnome.bbclass. 
My personal opinion: As long as we have not more gnome recipes (e.g from meta-
oe): Leave --enable-introspection=no in the recipes affected.
Best solution: Let's make gobject-introspection cross capable :-)

 --disable-scrollkeeper: 
Sorry but can anybody (e.g. Tom?) give a hint what this is about/for?

Andreas
Tom Rini - July 20, 2011, 11:48 p.m.
On 07/20/2011 04:14 PM, Andreas Mueller wrote:
> On Wednesday, July 20, 2011 06:47:54 PM you wrote:
>> On 07/16/2011 03:48 PM, Andreas Mueller wrote:
>>> Error message was:
>>> | /home/Superandy/tmp/oe-core-eglibc/sysroots/x86_64-linux/usr/bin/g-ir-c
>>> | ompiler  --includedir=. GdkPixbuf-2.0.gir -o GdkPixbuf-2.0.typelib
>>> | /usr/share/gir-1.0/GLib-2.0.gir:9:1: error: Unsupported version '1.1'
>>> | /usr/share/gir-1.0/GLib-2.0.gir:9:39: error: Unsupported version '1.1'
>>> | error parsing file GdkPixbuf-2.0.gir: Failed to parse included gir
>>> | GLib-2.0 make[4]: *** [GdkPixbuf-2.0.typelib] Error 1
>>>
>>> Signed-off-by: Andreas Mueller<schnitzeltony@gmx.de>
>>> ---
>>>
>>>   meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb |    3 ++-
>>>   1 files changed, 2 insertions(+), 1 deletions(-)
>>>
>>> diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
>>> b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb index
>>> 8b6314f..e3f5977 100644
>>> --- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
>>> +++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
>>> @@ -9,7 +9,7 @@ LIC_FILES_CHKSUM =
>>> "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
>>>
>>>   SECTION = "libs"
>>>   
>>>   DEPENDS = "libpng glib-2.0 jpeg"
>>>
>>> -PR = "r0"
>>> +PR = "r1"
>>>
>>>   SRC_URI =
>>>   "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.22/gdk-pixbuf-${
>>>   PV}.tar.gz \
>>>   
>>>              file://hardcoded_libtool.patch;patch=1 \
>>>
>>> @@ -26,6 +26,7 @@ LIBV = "2.10.0"
>>>
>>>   EXTRA_OECONF = "\
>>>   
>>>     --without-libtiff \
>>>     --with-libpng \
>>>
>>> +  --disable-introspection \
>>>
>>>   "
>>>   
>>>   FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
>>
>> Merged into oe-core
>>
>> There was a comment from Tom about gnome.bbclass, are you looking into
>> that?
> 
> On Sunday, July 17, 2011 04:25:48 PM Tom Rini wrote:
>> Sounds like gnome.bbclass is out of sync and we need both
>> --enable-introspection=no and --disable-scrollkeeper.
> 
> --enable-introspection=no: 
> I grepped around in oe-core for recipes with gobject-introspection disabled (did 
> not care of other layers - e.g meta-oe has its own gnome-bbclass with "--enable-
> introspection=no").

And it requires meta-oe to have its own copy of gnome.bbclass and to
make sure we don't get new recipes wrong in oe-core.

>  --disable-scrollkeeper: 
> Sorry but can anybody (e.g. Tom?) give a hint what this is about/for?

iirc "gnome" documentation stuff that's also wrong / not working in
certain cases.  I don't recall exactly but I'm pretty sure we did it
with good reason in oe.dev :)

Patch

diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
index 8b6314f..e3f5977 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.22.1.bb
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
 SECTION = "libs"
 
 DEPENDS = "libpng glib-2.0 jpeg"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gdk-pixbuf/2.22/gdk-pixbuf-${PV}.tar.gz \
            file://hardcoded_libtool.patch;patch=1 \
@@ -26,6 +26,7 @@  LIBV = "2.10.0"
 EXTRA_OECONF = "\
   --without-libtiff \
   --with-libpng \
+  --disable-introspection \
 "
 
 FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \