Patchwork Subversion does not support http protocol anymore

login
register
mail settings
Submitter Stefan sat
Date July 25, 2014, 6:30 p.m.
Message ID <53D2A234.60303@telenet.be>
Download mbox | patch
Permalink /patch/76691/
State New
Headers show

Comments

Stefan sat - July 25, 2014, 6:30 p.m.
Hello since a certain time native subversion build of 
openembedded-oe-core does not support http protocol anymore.

I found out that it is just the missing neon-config script file.

Whitout this the subversion_1.7.10.bb builds whitout neon support.

It was just ok by removing binconfig-disabled by 
meta/recipes-support/neon/neon_0.30.0.bb

Then rebuild neon and subversion.

Included git patch file

Thank's
Martin Jansa - July 25, 2014, 8:13 p.m.
On Fri, Jul 25, 2014 at 08:30:12PM +0200, Stefan sat wrote:
> Hello since a certain time native subversion build of 
> openembedded-oe-core does not support http protocol anymore.
> 
> I found out that it is just the missing neon-config script file.
> 
> Whitout this the subversion_1.7.10.bb builds whitout neon support.
> 
> It was just ok by removing binconfig-disabled by 
> meta/recipes-support/neon/neon_0.30.0.bb
> 
> Then rebuild neon and subversion.
> 
> Included git patch file

Wasn't it fixed recently by adding serf to oe-core?

> From 23996da1c500a6851e98f93706b09dd819f17312 Mon Sep 17 00:00:00 2001
> From: Christophe Van Reusel <christophe@stefan2l>
> Date: Fri, 25 Jul 2014 19:01:28 +0200
> Subject: [PATCH] Changed neon bb file to not inherit binconfig-disabled
> 
> neon-config script file needed to compile subversion with http support.
> 
>  Committer: Christophe Van Reusel <stefansat@telenet.be>
> 
>  Changes to be committed:
> 
> 	modified:   meta/recipes-support/neon/neon_0.30.0.bb
> ---
>  meta/recipes-support/neon/neon_0.30.0.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-support/neon/neon_0.30.0.bb b/meta/recipes-support/neon/neon_0.30.0.bb
> index 61bd7d9..c257215 100644
> --- a/meta/recipes-support/neon/neon_0.30.0.bb
> +++ b/meta/recipes-support/neon/neon_0.30.0.bb
> @@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "2962cfcb5d30f3272e3d2fa0e473434419770a3801afe3d46e5d165078
>  
>  BINCONFIG = "${bindir}/neon-config"
>  
> -inherit autotools binconfig-disabled lib_package pkgconfig
> +inherit autotools lib_package pkgconfig
>  
>  EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
>  EXTRA_OECONF += "--without-gssapi"
> -- 
> 1.9.1
> 

> -- 
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
Saul Wold - July 25, 2014, 8:28 p.m.
On 07/25/2014 11:30 AM, Stefan sat wrote:
> Hello since a certain time native subversion build of
> openembedded-oe-core does not support http protocol anymore.
>
> I found out that it is just the missing neon-config script file.
>
> Whitout this the subversion_1.7.10.bb builds whitout neon support.
>
> It was just ok by removing binconfig-disabled by
> meta/recipes-support/neon/neon_0.30.0.bb
>
> Then rebuild neon and subversion.
>
> Included git patch file
>

Richard recently updated subversion to 1.8.9, which uses serf instead of 
neon.  If this patch is for Daisy, please update it as mentioned here.

Can you please add a Signed-off-by: and use git format-patch, also look 
at this wiki:

http://www.openembedded.org/wiki/Commit_Patch_Message_Guidelines

Please format the commit message correctly and then re-submit with a 
[daisy] tag if appropriate.

Thanks
	Sau!

> Thank's
>
>
Stefan sat - July 25, 2014, 10:55 p.m.
Op 25-07-14 om 22:28 schreef Saul Wold:
> On 07/25/2014 11:30 AM, Stefan sat wrote:
>> Hello since a certain time native subversion build of
>> openembedded-oe-core does not support http protocol anymore.
>>
>> I found out that it is just the missing neon-config script file.
>>
>> Whitout this the subversion_1.7.10.bb builds whitout neon support.
>>
>> It was just ok by removing binconfig-disabled by
>> meta/recipes-support/neon/neon_0.30.0.bb
>>
>> Then rebuild neon and subversion.
>>
>> Included git patch file
>>
>
> Richard recently updated subversion to 1.8.9, which uses serf instead 
> of neon.  If this patch is for Daisy, please update it as mentioned here.
>
> Can you please add a Signed-off-by: and use git format-patch, also 
> look at this wiki:
>
> http://www.openembedded.org/wiki/Commit_Patch_Message_Guidelines
>
> Please format the commit message correctly and then re-submit with a 
> [daisy] tag if appropriate.
>
> Thanks
>     Sau!
>
>> Thank's
>>
>>
>
I just saw that the used openembedded-core in openpli-4.0 is not up to 
date with the current master, and so still has the head rev where 
subversion_1.7.10 was used . But by neon the binconfig-disabled was 
inherited. No with 1.8.9 neon is not needed any more

sorry, disregard the patch

Thanks anyway.

Patch

From 23996da1c500a6851e98f93706b09dd819f17312 Mon Sep 17 00:00:00 2001
From: Christophe Van Reusel <christophe@stefan2l>
Date: Fri, 25 Jul 2014 19:01:28 +0200
Subject: [PATCH] Changed neon bb file to not inherit binconfig-disabled

neon-config script file needed to compile subversion with http support.

 Committer: Christophe Van Reusel <stefansat@telenet.be>

 Changes to be committed:

	modified:   meta/recipes-support/neon/neon_0.30.0.bb
---
 meta/recipes-support/neon/neon_0.30.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta/recipes-support/neon/neon_0.30.0.bb b/meta/recipes-support/neon/neon_0.30.0.bb
index 61bd7d9..c257215 100644
--- a/meta/recipes-support/neon/neon_0.30.0.bb
+++ b/meta/recipes-support/neon/neon_0.30.0.bb
@@ -16,7 +16,7 @@  SRC_URI[sha256sum] = "2962cfcb5d30f3272e3d2fa0e473434419770a3801afe3d46e5d165078
 
 BINCONFIG = "${bindir}/neon-config"
 
-inherit autotools binconfig-disabled lib_package pkgconfig
+inherit autotools lib_package pkgconfig
 
 EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
 EXTRA_OECONF += "--without-gssapi"
-- 
1.9.1