musl: Upgrade to tip of trunk

Message ID 20220504204709.2705089-1-raj.khem@gmail.com
State Accepted, archived
Commit e3c2bc571e173e230cd3942888bdcf6423f14a2e
Headers show
Series musl: Upgrade to tip of trunk | expand

Commit Message

Khem Raj May 4, 2022, 8:47 p.m. UTC
brings in pre-work for submitting rv32 port

* 6e9d2370 use __fstat instead of __fstatat with AT_EMPTY_PATH in __map_file
* 05a55868 provide an internal namespace-safe __fstat
* fb10dc28 only use fstatat and others legacy stat syscalls if they exist
* 2b754a54 drop direct use of stat syscalls in internal __map_file
* c9ba0769 provide an internal namespace-safe __fstatat
* 7edbcbeb drop direct use of stat syscalls in fchmodat
* 9a937495 drop use of stat operation in temporary file name generation
* 12a757b3 only fallback to gettimeofday/settimeofday syscalls if they exist
* 41149ea8 only use getrlimit/setrlimit syscalls if they exist
* 8910efd0 don't remap internal-use syscall macros to nonexistent time32 syscalls
* 03f71251 remove ARMSUBARCH relic from configure
* 55b727d7 add missing POSIX confstr keys for pthread CFLAGS/LDFLAGS
* 8cf87b30 fix incorrect parameter name in internal netlink.h RTA_OK macro

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/musl/musl_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 4b854013608..fde5fc0ccec 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@ 
 require musl.inc
 inherit linuxloader
 
-SRCREV = "7a43f6fea9081bdd53d8a11cef9e9fab0348c53d"
+SRCREV = "6e9d2370c7559af80b32a91f20898f41597e093b"
 
 BASEVER = "1.2.3"