Patchwork sanity.bbclass: Update minimum git version to 1.7.8

login
register
mail settings
Submitter Richard Purdie
Date July 4, 2014, 10:49 a.m.
Message ID <1404470990.4852.1.camel@ted>
Download mbox | patch
Permalink /patch/75013/
State Accepted
Commit 47309419d3da43c7ceff5857df3a64bc23cb2b6b
Headers show

Comments

Richard Purdie - July 4, 2014, 10:49 a.m.
To quote "Maxin B. John" <maxin.john@enea.com>:

git version 1.7.8 added the --list option to git-branch. Since we depend on this
option in git.py, the minimum requiremnt for git should be updated to Git
1.7.8+

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Maxin B. John - July 7, 2014, 10:58 a.m.
Hi,

On Fri, Jul 04, 2014 at 11:49:50AM +0100, Richard Purdie wrote:
> To quote "Maxin B. John" <maxin.john@enea.com>:
> 
> git version 1.7.8 added the --list option to git-branch. Since we depend on this
> option in git.py, the minimum requiremnt for git should be updated to Git
> 1.7.8+
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> 
> diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
> index 4b42b17..ed65814 100644
> --- a/meta/classes/sanity.bbclass
> +++ b/meta/classes/sanity.bbclass
> @@ -386,15 +386,15 @@ def check_tar_version(sanity_data):
>          return "Your version of tar is older than 1.24 and has bugs which will break builds. Please install a newer version of tar.\n"
>      return None
>  
> -# We use git parameters and functionality only found in 1.7.5 or later
> +# We use git parameters and functionality only found in 1.7.8 or later
>  def check_git_version(sanity_data):
>      from distutils.version import LooseVersion
>      status, result = oe.utils.getstatusoutput("git --version 2> /dev/null")
>      if status != 0:
>          return "Unable to execute git --version, exit code %s\n" % status
>      version = result.split()[2]
> -    if LooseVersion(version) < LooseVersion("1.7.5"):
> -        return "Your version of git is older than 1.7.5 and has bugs which will break builds. Please install a newer version of git.\n"
> +    if LooseVersion(version) < LooseVersion("1.7.8"):
> +        return "Your version of git is older than 1.7.8 and has bugs which will break builds. Please install a newer version of git.\n"
>      return None
>  
>  # Check the required perl modules which may not be installed by default

Ah, I missed this part. Thanks for updating it!

Reviewed-by: Maxin B. John <maxin.john@enea.com>

Best Regards,
Maxin

Patch

diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 4b42b17..ed65814 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -386,15 +386,15 @@  def check_tar_version(sanity_data):
         return "Your version of tar is older than 1.24 and has bugs which will break builds. Please install a newer version of tar.\n"
     return None
 
-# We use git parameters and functionality only found in 1.7.5 or later
+# We use git parameters and functionality only found in 1.7.8 or later
 def check_git_version(sanity_data):
     from distutils.version import LooseVersion
     status, result = oe.utils.getstatusoutput("git --version 2> /dev/null")
     if status != 0:
         return "Unable to execute git --version, exit code %s\n" % status
     version = result.split()[2]
-    if LooseVersion(version) < LooseVersion("1.7.5"):
-        return "Your version of git is older than 1.7.5 and has bugs which will break builds. Please install a newer version of git.\n"
+    if LooseVersion(version) < LooseVersion("1.7.8"):
+        return "Your version of git is older than 1.7.8 and has bugs which will break builds. Please install a newer version of git.\n"
     return None
 
 # Check the required perl modules which may not be installed by default