[meta-python] python3-wxgtk4: Needs x11 for sip module

Message ID 20220501162137.2438749-1-raj.khem@gmail.com
State New
Headers show
Series [meta-python] python3-wxgtk4: Needs x11 for sip module | expand

Commit Message

Khem Raj May 1, 2022, 4:21 p.m. UTC
sip/cpp/sip_corewxWindow.cpp requires gdk/gdkx.h which wont be built
when gtk is built without x11, therefore require x11 when building this
recipe, if gdkx.h is removed form includes then it fails

../../../../sip/cpp/sip_corewxWindow.cpp:56:16: error: unknown type name 'XID'
        static XID GetXWindow(const wxWindow* wxwin) {
               ^
../../../../sip/cpp/sip_corewxWindow.cpp:59:28: error: use of undeclared identifier 'GDK_WINDOW_XID'
                    return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_wxwindow));
                           ^
../../../../sip/cpp/sip_corewxWindow.cpp:64:28: error: use of undeclared identifier 'GDK_WINDOW_XID'
                    return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_widget));
                           ^
so it is using it and will need some work to get it going without x11
until then disable building it on non-x11 distros

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Robert Yang <liezhi.yang@windriver.com>
---
 .../recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index 3583acc9cd..6ec92c2cec 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -18,7 +18,7 @@  S = "${WORKDIR}/wxPython-${PV}"
 
 inherit pypi setuptools3 pkgconfig features_check
 
-ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "x11"
 
 export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"