[kirkstone,08/34] seatd: Disable overflow warning as error on ppc64/musl

Message ID d97c8462b364946ac3172fc09a2398e8246a20b2.1651246310.git.steve@sakoman.com
State Accepted, archived
Commit d97c8462b364946ac3172fc09a2398e8246a20b2
Headers show
Series [kirkstone,01/34] e2fsprogs: fix CVE-2022-1304 | expand

Commit Message

Steve Sakoman April 29, 2022, 4 p.m. UTC
From: Khem Raj <raj.khem@gmail.com>

Disabling the warning is easier fix then trying to fix it
in musl which results in ABI breakage and disabling the Werror
gets us along by doing minimal change, also see [1]

[1] https://todo.sr.ht/~kennylevinsen/seatd/10

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 381cf11b994d2bf40ac8781e18b5eac17b3b6cb0)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-core/seatd/seatd_0.6.4.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-core/seatd/seatd_0.6.4.bb b/meta/recipes-core/seatd/seatd_0.6.4.bb
index a38f8c2152..601736adef 100644
--- a/meta/recipes-core/seatd/seatd_0.6.4.bb
+++ b/meta/recipes-core/seatd/seatd_0.6.4.bb
@@ -13,6 +13,9 @@  S = "${WORKDIR}/git"
 
 inherit meson pkgconfig update-rc.d
 
+# https://www.openwall.com/lists/musl/2020/01/20/3
+CFLAGS:append:libc-musl:powerpc64le = " -Wno-error=overflow"
+
 PACKAGECONFIG ?= " \
 	${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
 	libseat-builtin \