[18/18] stress-ng: upgrade 0.13.12 -> 0.14.00

Message ID 20220427084009.3406717-18-alex@linutronix.de
State Accepted, archived
Commit 2a80cb997aea02497ef359725b6f72536c904a2b
Headers show
Series [01/18] libxml2: update patch status | expand

Commit Message

Alexander Kanavin April 27, 2022, 8:40 a.m. UTC
Disable apparmor via empty config file creation.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../stress-ng/0001-Makefile-quote-CC.patch    | 41 +++++++++++++++++++
 ...ess-ng_0.13.12.bb => stress-ng_0.14.00.bb} | 11 ++++-
 2 files changed, 50 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-extended/stress-ng/stress-ng/0001-Makefile-quote-CC.patch
 rename meta/recipes-extended/stress-ng/{stress-ng_0.13.12.bb => stress-ng_0.14.00.bb} (76%)

Comments

Luca Ceresoli May 5, 2022, 1:57 p.m. UTC | #1
Hi Alexander,

Il giorno Wed, 27 Apr 2022 10:40:09 +0200
"Alexander Kanavin" <alex.kanavin@gmail.com> ha scritto:

> Disable apparmor via empty config file creation.
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>

We have a build failure while testing with this patch:

  .../ld: cannot find -lapparmor: No such file or directory

https://autobuilder.yoctoproject.org/typhoon/#/builders/40/builds/5169/steps/14/logs/stdio
Alexander Kanavin May 5, 2022, 3:18 p.m. UTC | #2
On Thu, 5 May 2022 at 15:58, Luca Ceresoli <luca.ceresoli@bootlin.com> wrote:
> Il giorno Wed, 27 Apr 2022 10:40:09 +0200
> "Alexander Kanavin" <alex.kanavin@gmail.com> ha scritto:
>
> > Disable apparmor via empty config file creation.
> >
> > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
>
> We have a build failure while testing with this patch:
>
>   .../ld: cannot find -lapparmor: No such file or directory
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/40/builds/5169/steps/14/logs/stdio

Thanks, I just sent a followup patch that should address the issue.

Alex

Patch

diff --git a/meta/recipes-extended/stress-ng/stress-ng/0001-Makefile-quote-CC.patch b/meta/recipes-extended/stress-ng/stress-ng/0001-Makefile-quote-CC.patch
new file mode 100644
index 0000000000..498a024830
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng/0001-Makefile-quote-CC.patch
@@ -0,0 +1,41 @@ 
+From f6162ced588c17c1141a8f6154475a299a2ebc0d Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Tue, 26 Apr 2022 22:35:35 +0200
+Subject: [PATCH] Makefile: quote CC
+
+It can contain command line options, and therefore spaces, and so
+needs to be quoted.
+
+Upstream-Status: Submitted [https://github.com/ColinIanKing/stress-ng/pull/188]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ Makefile        | 2 +-
+ Makefile.config | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 501093f5..8a454edd 100644
+--- a/Makefile
++++ b/Makefile
+@@ -432,7 +432,7 @@ stress-ng: $(OBJS)
+ 	$(V)sync
+ 
+ config.h:
+-	$(MAKE) CC=$(CC) STATIC=$(STATIC) -f Makefile.config
++	$(MAKE) CC="$(CC)" STATIC=$(STATIC) -f Makefile.config
+ 
+ .PHONY:
+ makeconfig: config.h
+diff --git a/Makefile.config b/Makefile.config
+index b76d0903..f03f7a85 100644
+--- a/Makefile.config
++++ b/Makefile.config
+@@ -69,7 +69,7 @@ else
+ endif
+ 
+ 
+-MAKE_OPTS=CC=$(CC) -f Makefile.config --no-print-directory
++MAKE_OPTS=CC="$(CC)" -f Makefile.config --no-print-directory
+ 
+ comma = ,
+ 
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.13.12.bb b/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
similarity index 76%
rename from meta/recipes-extended/stress-ng/stress-ng_0.13.12.bb
rename to meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
index fe177a4de0..ada35dbc4c 100644
--- a/meta/recipes-extended/stress-ng/stress-ng_0.13.12.bb
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.14.00.bb
@@ -5,8 +5,10 @@  HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
 LICENSE = "GPL-2.0-only"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
 
-SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
-SRCREV = "f59bcb2fe1e25042e77d5e4942f72bfa026fa305"
+SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
+           file://0001-Makefile-quote-CC.patch \
+           "
+SRCREV = "ec7f6c4731a54f0e515bef7f7e84ef9e9b8125a2"
 S = "${WORKDIR}/git"
 
 DEPENDS = "coreutils-native"
@@ -18,6 +20,11 @@  RCONFLICTS:${PN} = "stress"
 
 inherit bash-completion
 
+do_configure:prepend() {
+    mkdir -p configs
+    touch configs/HAVE_APPARMOR
+}
+
 do_install() {
     oe_runmake DESTDIR=${D} install
     ln -s stress-ng ${D}${bindir}/stress