Patchwork [0/3] mesa upgrade

login
register
mail settings
Submitter Valentin Popa
Date May 13, 2014, 2:59 p.m.
Message ID <cover.1399993010.git.valentin.popa@intel.com>
Download mbox
Permalink /patch/72109/
State New
Headers show

Pull-request

git://git.yoctoproject.org/poky-contrib vpopa/mesa

Comments

Valentin Popa - May 13, 2014, 2:59 p.m.
mesa upgrade to 10.1.3

The following changes since commit 40551859671a1c9da26cfdcda34da952c66ac8c2:

  qemu/local.conf.sample: Add sdl PACKAGECONFIG (2014-05-13 08:02:04 +0100)

are available in the git repository at:

  git://git.yoctoproject.org/poky-contrib vpopa/mesa
  http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=vpopa/mesa

Valentin Popa (3):
  dri3proto: add it to oe-core
  libxshmfence: add it to oe-core
  mesa: upgrade to 10.1.3

 .../mesa/{mesa-gl_9.2.5.bb => mesa-gl_10.1.3.bb}   |  0
 meta/recipes-graphics/mesa/mesa.inc                | 35 +++++++++++++---------
 .../mesa/{mesa_9.2.5.bb => mesa_10.1.3.bb}         |  4 +--
 meta/recipes-graphics/mesa/mesa_git.bb             |  4 +--
 meta/recipes-graphics/xorg-lib/libxshmfence_1.1.bb | 17 +++++++++++
 meta/recipes-graphics/xorg-proto/dri3proto_1.0.bb  | 14 +++++++++
 6 files changed, 56 insertions(+), 18 deletions(-)
 rename meta/recipes-graphics/mesa/{mesa-gl_9.2.5.bb => mesa-gl_10.1.3.bb} (100%)
 rename meta/recipes-graphics/mesa/{mesa_9.2.5.bb => mesa_10.1.3.bb} (82%)
 create mode 100644 meta/recipes-graphics/xorg-lib/libxshmfence_1.1.bb
 create mode 100644 meta/recipes-graphics/xorg-proto/dri3proto_1.0.bb
Otavio Salvador - May 14, 2014, 8:34 p.m.
On Tue, May 13, 2014 at 12:28 PM, Burton, Ross <ross.burton@intel.com> wrote:
> As this is a major release of Mesa I'm expecting breakage somewhere...
>  Can BSP maintainers please test these patches if their machines build
> Mesa?  I'm expecting machines that use mesa-gl to break if they don't
> just use the pure software drivers (so that's at least EMGD and if I
> recall correctly some ARM drivers).

Yes; we'll give it a try in meta-fsl-arm.
Martin Jansa - June 4, 2014, 5:12 p.m.
On Wed, Jun 04, 2014 at 03:24:34PM +0100, Burton, Ross wrote:
> On 4 June 2014 13:52, Martin Jansa <martin.jansa@gmail.com> wrote:
> > Sorry for hi-jacking the thread, but since today even the older 9.2.5 is
> > failing to find native python-libxml2
> >
> > config.log:
> > configure:8059: checking for python2
> > configure:8075: found
> > /OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/python-native/python2
> > configure:8086: result: python2
> > configure:8103: checking python2 module: libxml2
> > configure:8112: result: no
> > configure:8118: error: failed to find required module libxml2
> >
> > Any idea why it started to fail now?
> 
> Great.  Can you share the config.log?

This is from config.log, do you want whole file?
Ross Burton - June 6, 2014, 4:15 p.m.
On 4 June 2014 13:52, Martin Jansa <martin.jansa@gmail.com> wrote:
> Sorry for hi-jacking the thread, but since today even the older 9.2.5 is
> failing to find native python-libxml2
>
> config.log:
> configure:8059: checking for python2
> configure:8075: found
> /OE/build/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/python-native/python2
> configure:8086: result: python2
> configure:8103: checking python2 module: libxml2
> configure:8112: result: no
> configure:8118: error: failed to find required module libxml2
>
> Any idea why it started to fail now?

Something else must have lost a python-libxml2 dependency recently
because Mesa needs it but doesn't have a declared dependency.

Ross