Patchwork attr: Fix uclibc builds

login
register
mail settings
Submitter Richard Purdie
Date May 6, 2014, 1:49 p.m.
Message ID <1399384154.12731.151.camel@ted>
Download mbox | patch
Permalink /patch/71605/
State New
Headers show

Comments

Richard Purdie - May 6, 2014, 1:49 p.m.
attr needs libintl headers and libs. Add in the missing dependency and
the missing linker flag.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
Khem Raj - May 6, 2014, 5:43 p.m.
Richard


On Tue, May 6, 2014 at 6:49 AM, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> attr needs libintl headers and libs. Add in the missing dependency and
> the missing linker flag.
>
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
> diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
> index 873c1ff..63964e75 100644
> --- a/meta/recipes-support/attr/attr.inc
> +++ b/meta/recipes-support/attr/attr.inc
> @@ -2,7 +2,7 @@ SUMMARY = "Utilities for manipulating filesystem extended attributes"
>  HOMEPAGE = "http://savannah.nongnu.org/projects/attr/"
>  SECTION = "libs"
>
> -DEPENDS = "ncurses"
> +DEPENDS = "ncurses virtual/libintl"
>

may be something like
http://git.openembedded.org/openembedded-core-contrib/commit/?h=kraj/musl&id=6c67b40e4784e12ed6a71ab4696710b913e55455

is needed here.

Secondly we already have

LDFLAGS_append_libc-uclibc = "${@['', ' -lintl '][(d.getVar('PN',
True) == d.getVar('BPN', True)) and (d.getVar('USE_NLS', True) ==
'yes')]}"

in ea-acl.inc




>  LICENSE = "LGPLv2.1+ & GPLv2+"
>  LICENSE_${PN} = "GPLv2+"
> @@ -17,6 +17,8 @@ SRC_URI = "http://download.savannah.gnu.org/releases/attr/${BP}.src.tar.gz \
>
>  require ea-acl.inc
>
> +LDFLAGS_append_libc-uclibc = " -lintl"
> +
>  # libdir should point to .la
>  do_install_append() {
>         sed -i ${D}${libdir}/libattr.la -e \
>
>
> --
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
Richard Purdie - May 6, 2014, 8:37 p.m.
On Tue, 2014-05-06 at 10:43 -0700, Khem Raj wrote:
> Richard
> 
> 
> On Tue, May 6, 2014 at 6:49 AM, Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
> > attr needs libintl headers and libs. Add in the missing dependency and
> > the missing linker flag.
> >
> > Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> > ---
> > diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
> > index 873c1ff..63964e75 100644
> > --- a/meta/recipes-support/attr/attr.inc
> > +++ b/meta/recipes-support/attr/attr.inc
> > @@ -2,7 +2,7 @@ SUMMARY = "Utilities for manipulating filesystem extended attributes"
> >  HOMEPAGE = "http://savannah.nongnu.org/projects/attr/"
> >  SECTION = "libs"
> >
> > -DEPENDS = "ncurses"
> > +DEPENDS = "ncurses virtual/libintl"
> >
> 
> may be something like
> http://git.openembedded.org/openembedded-core-contrib/commit/?h=kraj/musl&id=6c67b40e4784e12ed6a71ab4696710b913e55455
> 
> is needed here.
> 
> Secondly we already have
> 
> LDFLAGS_append_libc-uclibc = "${@['', ' -lintl '][(d.getVar('PN',
> True) == d.getVar('BPN', True)) and (d.getVar('USE_NLS', True) ==
> 'yes')]}"
> 
> in ea-acl.inc

Hmm, I hadn't seen that. The trouble is that I'm setting up uclibc as a
multilib and this conditional may be wrong, we may need to rethink the
PN == BPN as it isn't in the multilib case.

Cheers,

Richard
Khem Raj - May 6, 2014, 8:48 p.m.
On Tue, May 6, 2014 at 1:37 PM, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> PN == BPN as it isn't in the multilib case.

we may not need that any more since back than we did not differentiate
between native and target recipes.

Patch

diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
index 873c1ff..63964e75 100644
--- a/meta/recipes-support/attr/attr.inc
+++ b/meta/recipes-support/attr/attr.inc
@@ -2,7 +2,7 @@  SUMMARY = "Utilities for manipulating filesystem extended attributes"
 HOMEPAGE = "http://savannah.nongnu.org/projects/attr/"
 SECTION = "libs"
 
-DEPENDS = "ncurses"
+DEPENDS = "ncurses virtual/libintl"
 
 LICENSE = "LGPLv2.1+ & GPLv2+"
 LICENSE_${PN} = "GPLv2+"
@@ -17,6 +17,8 @@  SRC_URI = "http://download.savannah.gnu.org/releases/attr/${BP}.src.tar.gz \
 
 require ea-acl.inc
 
+LDFLAGS_append_libc-uclibc = " -lintl"
+
 # libdir should point to .la
 do_install_append() {
 	sed -i ${D}${libdir}/libattr.la -e \