Patchwork [meta-fsl-demos] packagegroup-fsl-tools-gpu: Stop installing fsl-gpu-sdk for non-X11 backends

login
register
mail settings
Submitter Otavio Salvador
Date April 19, 2014, 3:14 p.m.
Message ID <1397920465-15858-1-git-send-email-otavio@ossystems.com.br>
Download mbox | patch
Permalink /patch/70685/
State Accepted
Delegated to: Otavio Salvador
Headers show

Comments

Otavio Salvador - April 19, 2014, 3:14 p.m.
The fsl-gpu-sdk is broken for all backends but X11 so we ensure to
include it only when 'x11' distro feature is in use.

The failure has been found when building the 'fsl-image-machine-test'
for all backends at O.S. Systems for testing, this is not a fix but a
workaround and I expect this to be fixed by Freescale in an upcoming
release.

Change-Id: Ica6821a66de7bedb87510ac171ff1b7ba383b21b
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
 recipes-fsl/packagegroups/packagegroup-fsl-tools-gpu.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Otavio Salvador - April 19, 2014, 3:16 p.m.
On Sat, Apr 19, 2014 at 12:14 PM, Otavio Salvador
<otavio@ossystems.com.br> wrote:
> The fsl-gpu-sdk is broken for all backends but X11 so we ensure to
> include it only when 'x11' distro feature is in use.
>
> The failure has been found when building the 'fsl-image-machine-test'
> for all backends at O.S. Systems for testing, this is not a fix but a
> workaround and I expect this to be fixed by Freescale in an upcoming
> release.
>
> Change-Id: Ica6821a66de7bedb87510ac171ff1b7ba383b21b
> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>

I sent it here as it makes clear a issue with the fsl-gpu-sdk, which
needs fixing.

I am running this in our autobuilder and will merged as soon as it
finish building.

Patch

diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-tools-gpu.bb b/recipes-fsl/packagegroups/packagegroup-fsl-tools-gpu.bb
index a28293c..fc8ee7a 100644
--- a/recipes-fsl/packagegroups/packagegroup-fsl-tools-gpu.bb
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-tools-gpu.bb
@@ -16,7 +16,7 @@  SOC_TOOLS_GPU_mx5 = " \
 SOC_TOOLS_GPU_mx6 = " \
     gpu-viv-bin-mx6q \
     gpu-viv-g2d \
-    fsl-gpu-sdk \
+    ${@base_contains('DISTRO_FEATURES', 'x11', 'fsl-gpu-sdk', '', d)} \
 "
 
 RDEPENDS_${PN} = " \