Patchwork [meta-qt5] populate_sdk_qt5.bbclass: Fix PACKAGE_GROUP deprecation warning

login
register
mail settings
Submitter Jacob Kroon
Date April 15, 2014, 5:12 p.m.
Message ID <1397581965-24301-1-git-send-email-jacob.kroon@mikrodidakt.se>
Download mbox | patch
Permalink /patch/70601/
State Accepted, archived
Headers show

Comments

Jacob Kroon - April 15, 2014, 5:12 p.m.
Fixes the following warning:

WARNING: PACKAGE_GROUP is deprecated, please use FEATURE_PACKAGES instead

Signed-off-by: Jacob Kroon <jacob.kroon@mikrodidakt.se>
---
 classes/populate_sdk_qt5.bbclass | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Martin Jansa - April 20, 2014, 10:34 a.m.
On Tue, Apr 15, 2014 at 07:12:45PM +0200, Jacob Kroon wrote:
> Fixes the following warning:
> 
> WARNING: PACKAGE_GROUP is deprecated, please use FEATURE_PACKAGES instead

It's correct patch, but I'm a bit tempted to take this patch after
branching daisy, because some people are using latest meta-qt5 with
older oe-core releases and this undoing this change is easy to miss
(unlike e.g. cmake .bbappends which fail when not updated for correct
oe-core releases).

What do you think?

Alternatively we can add wiki page about using latest meta-qt5 with
older oe-core and just document this there.

> Signed-off-by: Jacob Kroon <jacob.kroon@mikrodidakt.se>
> ---
>  classes/populate_sdk_qt5.bbclass | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/classes/populate_sdk_qt5.bbclass b/classes/populate_sdk_qt5.bbclass
> index c921983..7b31bbb 100644
> --- a/classes/populate_sdk_qt5.bbclass
> +++ b/classes/populate_sdk_qt5.bbclass
> @@ -53,4 +53,4 @@ toolchain_create_sdk_env_script_append () {
>      echo 'HostBinaries = ${SDKPATHNATIVE}${OE_QMAKE_PATH_HOST_BINS}' >> $qtconf
>  }
>  
> -PACKAGE_GROUP_qtcreator-debug = "packagegroup-qt5-qtcreator-debug"
> +FEATURE_PACKAGES_qtcreator-debug = "packagegroup-qt5-qtcreator-debug"
> -- 
> 1.9.0
> 
> -- 
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
Jacob Kroon - April 20, 2014, 1:54 p.m.
Hi Martin,

On Sun, Apr 20, 2014 at 12:34 PM, Martin Jansa <martin.jansa@gmail.com>wrote:

> On Tue, Apr 15, 2014 at 07:12:45PM +0200, Jacob Kroon wrote:
> > Fixes the following warning:
> >
> > WARNING: PACKAGE_GROUP is deprecated, please use FEATURE_PACKAGES instead
>
> It's correct patch, but I'm a bit tempted to take this patch after
> branching daisy, because some people are using latest meta-qt5 with
> older oe-core releases and this undoing this change is easy to miss
> (unlike e.g. cmake .bbappends which fail when not updated for correct
> oe-core releases).
>
> What do you think?
>
>
I think I follow you. So the deprecation happened in commit
d703e07ea5056624101e1bc48f10d25b602635e9, 2014-03-07, so I guess only
daisy/master will give the warning. For older oe-core releases with
meta-qt5 master, this patch could silently break stuff I can imagine. So
like you propose, keeping this one for master only, after branching daisy,
seems like a good idea to me.

/Jacob
Otavio Salvador - April 20, 2014, 8:21 p.m.
Hello Martin,

On Sun, Apr 20, 2014 at 7:34 AM, Martin Jansa <martin.jansa@gmail.com> wrote:
> On Tue, Apr 15, 2014 at 07:12:45PM +0200, Jacob Kroon wrote:
>> Fixes the following warning:
>>
>> WARNING: PACKAGE_GROUP is deprecated, please use FEATURE_PACKAGES instead
>
> It's correct patch, but I'm a bit tempted to take this patch after
> branching daisy, because some people are using latest meta-qt5 with
> older oe-core releases and this undoing this change is easy to miss
> (unlike e.g. cmake .bbappends which fail when not updated for correct
> oe-core releases).
>
> What do you think?
>
> Alternatively we can add wiki page about using latest meta-qt5 with
> older oe-core and just document this there.

I am one of those guys using it with older releases. However I think
we ought to have it clean so I am in favor of merging as this is
really a nice fix.
Otavio Salvador - April 20, 2014, 8:23 p.m.
On Sun, Apr 20, 2014 at 10:54 AM, Jacob Kroon <jacob.kroon@gmail.com> wrote:
> Hi Martin,
>
> On Sun, Apr 20, 2014 at 12:34 PM, Martin Jansa <martin.jansa@gmail.com>wrote:
>
>> On Tue, Apr 15, 2014 at 07:12:45PM +0200, Jacob Kroon wrote:
>> > Fixes the following warning:
>> >
>> > WARNING: PACKAGE_GROUP is deprecated, please use FEATURE_PACKAGES instead
>>
>> It's correct patch, but I'm a bit tempted to take this patch after
>> branching daisy, because some people are using latest meta-qt5 with
>> older oe-core releases and this undoing this change is easy to miss
>> (unlike e.g. cmake .bbappends which fail when not updated for correct
>> oe-core releases).
>>
>> What do you think?
>>
>>
> I think I follow you. So the deprecation happened in commit
> d703e07ea5056624101e1bc48f10d25b602635e9, 2014-03-07, so I guess only
> daisy/master will give the warning. For older oe-core releases with
> meta-qt5 master, this patch could silently break stuff I can imagine. So
> like you propose, keeping this one for master only, after branching daisy,
> seems like a good idea to me.

I prefer to drop the warning in daisy. It is always bad to have
warnings during the build and we ought to have it clean. As I said,
this will indeed break people but not many people are using this class
as this is quite new.

Patch

diff --git a/classes/populate_sdk_qt5.bbclass b/classes/populate_sdk_qt5.bbclass
index c921983..7b31bbb 100644
--- a/classes/populate_sdk_qt5.bbclass
+++ b/classes/populate_sdk_qt5.bbclass
@@ -53,4 +53,4 @@  toolchain_create_sdk_env_script_append () {
     echo 'HostBinaries = ${SDKPATHNATIVE}${OE_QMAKE_PATH_HOST_BINS}' >> $qtconf
 }
 
-PACKAGE_GROUP_qtcreator-debug = "packagegroup-qt5-qtcreator-debug"
+FEATURE_PACKAGES_qtcreator-debug = "packagegroup-qt5-qtcreator-debug"