Patchwork pulseaudio: disable HAL support and enable udev support

login
register
mail settings
Submitter Koen Kooi
Date July 5, 2011, 4:57 p.m.
Message ID <1309885051-17651-1-git-send-email-koen@dominion.thruhere.net>
Download mbox | patch
Permalink /patch/7001/
State New, archived
Headers show

Comments

Koen Kooi - July 5, 2011, 4:57 p.m.
HAL is deprecated and udev should be used with pulseaudio 0.9.22. THe .23 release from 2 weeks ago already removed HAL support.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
---
 meta/recipes-multimedia/pulseaudio/pulseaudio.inc  |    6 +++---
 .../pulseaudio/pulseaudio_0.9.22.bb                |    2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)
Richard Purdie - July 7, 2011, 12:42 p.m.
On Tue, 2011-07-05 at 18:57 +0200, Koen Kooi wrote:
> HAL is deprecated and udev should be used with pulseaudio 0.9.22. THe .23 release from 2 weeks ago already removed HAL support.
> 
> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>

Merged to master, thanks.

Richard

Patch

diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
index e46b716..ab7e867 100644
--- a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
@@ -7,9 +7,9 @@  LIC_FILES_CHKSUM = "file://GPL;md5=4325afd396febcb659c36b49533135d4 \
                     file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
                     file://src/modules/bluetooth/proximity-helper.c;beginline=1;endline=25;md5=e4cc710e40a4d900c2c294167bc58270 \
                     file://src/pulsecore/vector.h;beginline=1;endline=21;md5=1b561f0a2ca47b1fa49862a6ccaacff1"
-DEPENDS = "libatomics-ops liboil avahi libsamplerate0 libsndfile1 libtool hal virtual/libx11"
+DEPENDS = "libatomics-ops liboil avahi libsamplerate0 libsndfile1 libtool virtual/libx11"
 # optional
-DEPENDS += "alsa-lib glib-2.0 dbus consolekit hal"
+DEPENDS += "udev alsa-lib glib-2.0 dbus consolekit"
 
 SRC_URI = "http://0pointer.de/lennart/projects/pulseaudio/pulseaudio-${PV}.tar.gz \
            file://gcc4-compile-fix.patch;patch=1 \
@@ -26,7 +26,7 @@  EXTRA_OECONF = "\
 		--with-glib \
 		--with-alsa \
 		--with-oss \
-		--with-hal \
+		--without-hal \
 "
 
 PARALLEL_MAKE = ""
diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio_0.9.22.bb b/meta/recipes-multimedia/pulseaudio/pulseaudio_0.9.22.bb
index 863beda..5124bd7 100644
--- a/meta/recipes-multimedia/pulseaudio/pulseaudio_0.9.22.bb
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio_0.9.22.bb
@@ -1,6 +1,6 @@ 
 require pulseaudio.inc
 
-PR = "r1"
+PR = "r2"
 
 DEPENDS += "gdbm speex"