Patchwork [meta-fsl-arm-extra,v2,1/2] linux-wandboard (3.10.17): Update SRCREV to 4a8ad4

login
register
mail settings
Submitter John Weber
Date March 25, 2014, 5:44 p.m.
Message ID <1395769498-26682-1-git-send-email-rjohnweber@gmail.com>
Download mbox | patch
Permalink /patch/69165/
State Changes Requested
Delegated to: Otavio Salvador
Headers show

Comments

John Weber - March 25, 2014, 5:44 p.m.
Update Wandboard 3.10.17 kernel to commit 4a8ad4, which includes an update
to the DTS to enable all mxcfb devices and a fix for the sgtl5000 driver.

Signed-off-by: John Weber <rjohnweber@gmail.com>
---
changes in v2: Changed SRCREV to pick up sgtl5000 driver fixes

 recipes-kernel/linux/linux-wandboard_3.10.17.bb |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Trevor Woerner - March 25, 2014, 6:30 p.m.
Hi John,

I was _just_ about to reply to V1 when V2 came along... ;-)

Here are my steps:

    $ repo init -u
    https://github.com/Freescale/fsl-community-bsp-platform -b master
    $ repo sync

Then I edit my conf/local.conf to add:

    IMAGE_INSTALL_append = " \
            memtester \
            alsa-utils \
            alsa-tools \
            evtest \
            imx-test \
            perl \
            lmbench \
            glmark2 \
            mesa-demos \
            gst-meta-audio \
            gst-meta-video \
            gst-plugins-good-video4linux2 \
            wpa-supplicant \
            dropbear \
            iperf \
            "
    PREFERRED_VERSION_linux-wandboard = "3.10.17"
    SRCBRANCH_pn-linux-wandboard = "wandboard_imx_3.10.17_1.0.0_beta"
    SRCREV_pn-linux-wandboard = "4a8ad4e16bbc17be82e95ffcd4241e21d441efbd"

then I perform

    $ bitbake core-image-x11

and dd that to a microSD.

I copy sintel_trailer-1080p.mp4 to a USB drive, insert it, it mounts,
then I try to use gst-launch to run it but I get:

    root@wandboard-dual:~# gst-launch playbin2
    uri="file:///media/sda1/sintel_trailer-1080p.mp4"
    audio-sink="alsasink device=hw:0,0"
    Setting pipeline to PAUSED ...
    Pipeline is PREROLLING ...
    Missing element: Quicktime demuxer
    WARNING: from element
    /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder
    available for type 'video/quicktime, variant=(string)iso'.
    Additional debug info:
    /SSD/build/fsl/build-wandboard-dual/MASTER-tmp/work/cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi/gst-plugins-base/0.10.36-r8/gst-plugins-base-0.10.36/gst/playback/gsturidecodebin.c(874):
    unknown_type_cb (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
    ERROR: from element
    /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
    Your GStreamer installation is missing a plug-in.
    Additional debug info:
    /SSD/build/fsl/build-wandboard-dual/MASTER-tmp/work/cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi/gst-plugins-base/0.10.36-r8/gst-plugins-base-0.10.36/gst/playback/gstdecodebin2.c(3576):
    gst_decode_bin_expose ():
    /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
    no suitable plugins found
    ERROR: pipeline doesn't want to preroll.
    Setting pipeline to NULL ...
    Freeing pipeline ...

Any thoughts?
Fabio Estevam - March 25, 2014, 6:36 p.m.
On Tue, Mar 25, 2014 at 3:30 PM, Trevor Woerner
<trevor.woerner@linaro.org> wrote:

> I copy sintel_trailer-1080p.mp4 to a USB drive, insert it, it mounts,
> then I try to use gst-launch to run it but I get:
>
>     root@wandboard-dual:~# gst-launch playbin2
>     uri="file:///media/sda1/sintel_trailer-1080p.mp4"
>     audio-sink="alsasink device=hw:0,0"
>     Setting pipeline to PAUSED ...
>     Pipeline is PREROLLING ...
>     Missing element: Quicktime demuxer

Looks like that the Gstreaner qtdemux plugin has not been installed.

Regards,

Fabio Estevam
John Weber - March 25, 2014, 6:43 p.m.
Hi Trevor,

I'm not sure what is missing, but here's my conf/local.conf.  It's probably 
larger than it needs to be.  :-)

CORE_IMAGE_EXTRA_INSTALL_append = "iperf glive gst-plugins-good-isomp4 memtester 
alsa-utils alsa-tools evtest imx-test perl lmbench glmark2 mesa-demos 
gst-meta-audio gst-meta-video gst-plugins-good-udp gst-plugins-good-rtp 
gst-plugins-good-rtpmanager gst-plugins-good-rtsp gst-plugins-good-video4linux2 
libconfig wpa-supplicant dropbear"

John

On 3/25/14, 1:30 PM, Trevor Woerner wrote:
> Hi John,
>
> I was _just_ about to reply to V1 when V2 came along... ;-)
>
> Here are my steps:
>
>      $ repo init -u
>      https://github.com/Freescale/fsl-community-bsp-platform -b master
>      $ repo sync
>
> Then I edit my conf/local.conf to add:
>
>      IMAGE_INSTALL_append = " \
>              memtester \
>              alsa-utils \
>              alsa-tools \
>              evtest \
>              imx-test \
>              perl \
>              lmbench \
>              glmark2 \
>              mesa-demos \
>              gst-meta-audio \
>              gst-meta-video \
>              gst-plugins-good-video4linux2 \
>              wpa-supplicant \
>              dropbear \
>              iperf \
>              "
>      PREFERRED_VERSION_linux-wandboard = "3.10.17"
>      SRCBRANCH_pn-linux-wandboard = "wandboard_imx_3.10.17_1.0.0_beta"
>      SRCREV_pn-linux-wandboard = "4a8ad4e16bbc17be82e95ffcd4241e21d441efbd"
>
> then I perform
>
>      $ bitbake core-image-x11
>
> and dd that to a microSD.
>
> I copy sintel_trailer-1080p.mp4 to a USB drive, insert it, it mounts,
> then I try to use gst-launch to run it but I get:
>
>      root@wandboard-dual:~# gst-launch playbin2
>      uri="file:///media/sda1/sintel_trailer-1080p.mp4"
>      audio-sink="alsasink device=hw:0,0"
>      Setting pipeline to PAUSED ...
>      Pipeline is PREROLLING ...
>      Missing element: Quicktime demuxer
>      WARNING: from element
>      /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0: No decoder
>      available for type 'video/quicktime, variant=(string)iso'.
>      Additional debug info:
>      /SSD/build/fsl/build-wandboard-dual/MASTER-tmp/work/cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi/gst-plugins-base/0.10.36-r8/gst-plugins-base-0.10.36/gst/playback/gsturidecodebin.c(874):
>      unknown_type_cb (): /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0
>      ERROR: from element
>      /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
>      Your GStreamer installation is missing a plug-in.
>      Additional debug info:
>      /SSD/build/fsl/build-wandboard-dual/MASTER-tmp/work/cortexa9hf-vfp-neon-mx6-poky-linux-gnueabi/gst-plugins-base/0.10.36-r8/gst-plugins-base-0.10.36/gst/playback/gstdecodebin2.c(3576):
>      gst_decode_bin_expose ():
>      /GstPlayBin2:playbin20/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20:
>      no suitable plugins found
>      ERROR: pipeline doesn't want to preroll.
>      Setting pipeline to NULL ...
>      Freeing pipeline ...
>
> Any thoughts?
Trevor Woerner - March 25, 2014, 7:29 p.m.
Thank you John and Fabio, it works now :-)

Patch

diff --git a/recipes-kernel/linux/linux-wandboard_3.10.17.bb b/recipes-kernel/linux/linux-wandboard_3.10.17.bb
index 4ecd7f1..61f5438 100644
--- a/recipes-kernel/linux/linux-wandboard_3.10.17.bb
+++ b/recipes-kernel/linux/linux-wandboard_3.10.17.bb
@@ -8,7 +8,7 @@  DEPENDS += "lzop-native bc-native"
 
 # Wandboard branch - based on 3.10.17_1.0.0_beta from Freescale git
 SRCBRANCH = "wandboard_imx_3.10.17_1.0.0_beta"
-SRCREV = "92461eb9aa0f946e3acbd64826eac94bef8fc23a"
+SRCREV = "4a8ad4e16bbc17be82e95ffcd4241e21d441efbd"
 LOCALVERSION = "-1.0.0-wandboard"