xorg-app: Tweak handling of compression changes in SRC_URI

Message ID 20220420115509.2525431-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 21547dd5319f27a8f7f20a80e39478f816b4bbe0
Headers show
Series xorg-app: Tweak handling of compression changes in SRC_URI | expand

Commit Message

Richard Purdie April 20, 2022, 11:55 a.m. UTC
Rather than duplicating SRC_URI, change the compression to a variable.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb | 3 +--
 meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb    | 3 +--
 meta/recipes-graphics/xorg-app/xorg-app-common.inc  | 3 ++-
 meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb      | 3 +--
 4 files changed, 5 insertions(+), 7 deletions(-)

Comments

Luca Ceresoli April 21, 2022, 9:31 a.m. UTC | #1
Hi Richard,

Il giorno Wed, 20 Apr 2022 12:55:09 +0100
"Richard Purdie" <richard.purdie@linuxfoundation.org> ha scritto:

> Rather than duplicating SRC_URI, change the compression to a variable.
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb | 3 +--
>  meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb    | 3 +--
>  meta/recipes-graphics/xorg-app/xorg-app-common.inc  | 3 ++-
>  meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb      | 3 +--
>  4 files changed, 5 insertions(+), 7 deletions(-)
> 
> diff --git a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb
> b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb index
> 573b05128e4..cd658ab219c 100644 ---
> a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb +++
> b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb @@ -15,8 +15,7
> @@ RPROVIDES:${PN} += "mkfontdir" 
>  BBCLASSEXTEND = "native"
>  
> -SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz"
> -
>  LIC_FILES_CHKSUM =
> "file://COPYING;md5=99b1e1269aba5179139b9e4380fc0934" 
> +SRC_URI_EXT = "xz"
>  SRC_URI[sha256sum] =
> "8ae3fb5b1fe7436e1f565060acaa3e2918fe745b0e4979b5593968914fe2d5c4"
> diff --git a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb
> b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb index
> fa0fe36451a..e75a840b7de 100644 ---
> a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb +++
> b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb @@ -8,14 +8,13 @@
> predefined values for various parameters used in communicating
> between \ clients and the server, and the different types of screens
> and visuals \ that are available." -SRC_URI =
> "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz" -
>  LIC_FILES_CHKSUM =
> "file://COPYING;md5=f3d09e6b9e203a1af489e16c708f4fb3" DEPENDS +=
> "libxtst libxext libxxf86vm libxi libxrender libxinerama libdmx
> libxau libxcomposite" PE = "1" 
>  SRC_URI += "file://disable-xkb.patch"
>  
> +SRC_URI_EXT = "xz"
>  SRC_URI[sha256sum] =
> "356d5fd62f3e98ee36d6becf1b32d4ab6112d618339fb4b592ccffbd9e0fc206" 
>  EXTRA_OECONF = "--disable-xkb"
> diff --git a/meta/recipes-graphics/xorg-app/xorg-app-common.inc
> b/meta/recipes-graphics/xorg-app/xorg-app-common.inc index
> 1c64e20aac7..6a9ebe842de 100644 ---
> a/meta/recipes-graphics/xorg-app/xorg-app-common.inc +++
> b/meta/recipes-graphics/xorg-app/xorg-app-common.inc @@ -8,7 +8,8 @@
> DEPENDS = "util-macros-native virtual/libx11" # depends on
> virtual/libx11 REQUIRED_DISTRO_FEATURES = "x11"
>  
> -SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.bz2"
> +SRC_URI_EXT = ".bz2"
> +SRC_URI =
> "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.${SRC_URI_EXT}" 

There's an extra '.' in ".bz2" that causes fetch failures.

https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/725/steps/12/logs/errors

stdio: WARNING: xkbcomp-1.4.5-r0 do_fetch: Failed to fetch URL
https://www.x.org/releases//individual/app/xkbcomp-1.4.5.tar..bz2,
attempting MIRRORS if available

I'm dropping this patch from my master-next branch for now.
Richard Purdie April 21, 2022, 9:54 a.m. UTC | #2
On Thu, 2022-04-21 at 11:31 +0200, Luca Ceresoli wrote:
> Hi Richard,
> 
> Il giorno Wed, 20 Apr 2022 12:55:09 +0100
> "Richard Purdie" <richard.purdie@linuxfoundation.org> ha scritto:
> 
> > Rather than duplicating SRC_URI, change the compression to a variable.
> > 
> > Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> > ---
> >  meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb | 3 +--
> >  meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb    | 3 +--
> >  meta/recipes-graphics/xorg-app/xorg-app-common.inc  | 3 ++-
> >  meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb      | 3 +--
> >  4 files changed, 5 insertions(+), 7 deletions(-)
> > 
> > diff --git a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb
> > b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb index
> > 573b05128e4..cd658ab219c 100644 ---
> > a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb +++
> > b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb @@ -15,8 +15,7
> > @@ RPROVIDES:${PN} += "mkfontdir" 
> >  BBCLASSEXTEND = "native"
> >  
> > -SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz"
> > -
> >  LIC_FILES_CHKSUM =
> > "file://COPYING;md5=99b1e1269aba5179139b9e4380fc0934" 
> > +SRC_URI_EXT = "xz"
> >  SRC_URI[sha256sum] =
> > "8ae3fb5b1fe7436e1f565060acaa3e2918fe745b0e4979b5593968914fe2d5c4"
> > diff --git a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb
> > b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb index
> > fa0fe36451a..e75a840b7de 100644 ---
> > a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb +++
> > b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb @@ -8,14 +8,13 @@
> > predefined values for various parameters used in communicating
> > between \ clients and the server, and the different types of screens
> > and visuals \ that are available." -SRC_URI =
> > "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz" -
> >  LIC_FILES_CHKSUM =
> > "file://COPYING;md5=f3d09e6b9e203a1af489e16c708f4fb3" DEPENDS +=
> > "libxtst libxext libxxf86vm libxi libxrender libxinerama libdmx
> > libxau libxcomposite" PE = "1" 
> >  SRC_URI += "file://disable-xkb.patch"
> >  
> > +SRC_URI_EXT = "xz"
> >  SRC_URI[sha256sum] =
> > "356d5fd62f3e98ee36d6becf1b32d4ab6112d618339fb4b592ccffbd9e0fc206" 
> >  EXTRA_OECONF = "--disable-xkb"
> > diff --git a/meta/recipes-graphics/xorg-app/xorg-app-common.inc
> > b/meta/recipes-graphics/xorg-app/xorg-app-common.inc index
> > 1c64e20aac7..6a9ebe842de 100644 ---
> > a/meta/recipes-graphics/xorg-app/xorg-app-common.inc +++
> > b/meta/recipes-graphics/xorg-app/xorg-app-common.inc @@ -8,7 +8,8 @@
> > DEPENDS = "util-macros-native virtual/libx11" # depends on
> > virtual/libx11 REQUIRED_DISTRO_FEATURES = "x11"
> >  
> > -SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.bz2"
> > +SRC_URI_EXT = ".bz2"
> > +SRC_URI =
> > "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.${SRC_URI_EXT}" 
> 
> There's an extra '.' in ".bz2" that causes fetch failures.
> 
> https://autobuilder.yoctoproject.org/typhoon/#/builders/117/builds/725/steps/12/logs/errors
> 
> stdio: WARNING: xkbcomp-1.4.5-r0 do_fetch: Failed to fetch URL
> https://www.x.org/releases//individual/app/xkbcomp-1.4.5.tar..bz2,
> attempting MIRRORS if available
> 
> I'm dropping this patch from my master-next branch for now.

There is an updated version in master-next.

Cheers,

Richard

Patch

diff --git a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb
index 573b05128e4..cd658ab219c 100644
--- a/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb
+++ b/meta/recipes-graphics/xorg-app/mkfontscale_1.2.2.bb
@@ -15,8 +15,7 @@  RPROVIDES:${PN} += "mkfontdir"
 
 BBCLASSEXTEND = "native"
 
-SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz"
-
 LIC_FILES_CHKSUM = "file://COPYING;md5=99b1e1269aba5179139b9e4380fc0934"
 
+SRC_URI_EXT = "xz"
 SRC_URI[sha256sum] = "8ae3fb5b1fe7436e1f565060acaa3e2918fe745b0e4979b5593968914fe2d5c4"
diff --git a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb
index fa0fe36451a..e75a840b7de 100644
--- a/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb
+++ b/meta/recipes-graphics/xorg-app/xdpyinfo_1.3.3.bb
@@ -8,14 +8,13 @@  predefined values for various parameters used in communicating between \
 clients and the server, and the different types of screens and visuals \
 that are available."
 
-SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz"
-
 LIC_FILES_CHKSUM = "file://COPYING;md5=f3d09e6b9e203a1af489e16c708f4fb3"
 DEPENDS += "libxtst libxext libxxf86vm libxi libxrender libxinerama libdmx libxau libxcomposite"
 PE = "1"
 
 SRC_URI += "file://disable-xkb.patch"
 
+SRC_URI_EXT = "xz"
 SRC_URI[sha256sum] = "356d5fd62f3e98ee36d6becf1b32d4ab6112d618339fb4b592ccffbd9e0fc206"
 
 EXTRA_OECONF = "--disable-xkb"
diff --git a/meta/recipes-graphics/xorg-app/xorg-app-common.inc b/meta/recipes-graphics/xorg-app/xorg-app-common.inc
index 1c64e20aac7..6a9ebe842de 100644
--- a/meta/recipes-graphics/xorg-app/xorg-app-common.inc
+++ b/meta/recipes-graphics/xorg-app/xorg-app-common.inc
@@ -8,7 +8,8 @@  DEPENDS = "util-macros-native virtual/libx11"
 # depends on virtual/libx11
 REQUIRED_DISTRO_FEATURES = "x11"
 
-SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.bz2"
+SRC_URI_EXT = ".bz2"
+SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.${SRC_URI_EXT}"
 
 inherit autotools pkgconfig features_check
 
diff --git a/meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb b/meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb
index 57b43ff28c4..0e0347f768b 100644
--- a/meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb
+++ b/meta/recipes-graphics/xorg-app/xrandr_1.5.1.bb
@@ -11,8 +11,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=fe1608bdb33cf8c62a4438f7d34679b3"
 DEPENDS += "libxrandr libxrender"
 PE = "1"
 
-SRC_URI = "${XORG_MIRROR}/individual/app/${BPN}-${PV}.tar.xz"
-
+SRC_URI_EXT = "xz"
 SRC_URI[md5sum] = "fe40f7a4fd39dd3a02248d3e0b1972e4"
 SRC_URI[sha256sum] = "7bc76daf9d72f8aff885efad04ce06b90488a1a169d118dea8a2b661832e8762"