Patchwork [V2] pulseaudio: Make it compatible with systemd-209

login
register
mail settings
Submitter Khem Raj
Date March 18, 2014, 9:18 p.m.
Message ID <1395177536-1245-1-git-send-email-raj.khem@gmail.com>
Download mbox | patch
Permalink /patch/68853/
State New
Headers show

Comments

Khem Raj - March 18, 2014, 9:18 p.m.
From: Martin Jansa <martin.jansa@gmail.com>

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...c-Check-only-for-libsystemd-not-libsystem.patch | 30 ++++++++++++++++++++++
 .../pulseaudio/pulseaudio_5.0.bb                   |  1 +
 2 files changed, 31 insertions(+)
 create mode 100644 meta/recipes-multimedia/pulseaudio/pulseaudio/0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch

Patch

diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio/0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch b/meta/recipes-multimedia/pulseaudio/pulseaudio/0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch
new file mode 100644
index 0000000..467cd2c
--- /dev/null
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio/0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch
@@ -0,0 +1,30 @@ 
+From 002b16f0f2176b4c685e210e335bf69c02563ede Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Sat, 22 Feb 2014 18:03:10 +0100
+Subject: [PATCH] configure.ac: Check only for libsystemd not libsystemd-login
+
+* they were merged into libsystemd in systemd-209
+
+Upstream-Status: Pending (it would need to be conditional on systemd version for upstream to accept this)
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 388fae2..fff7a83 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1160,7 +1160,7 @@ AC_ARG_ENABLE([systemd],
+     AS_HELP_STRING([--disable-systemd],[Disable optional systemd support]))
+ 
+ AS_IF([test "x$enable_systemd" != "xno"],
+-    [PKG_CHECK_MODULES(SYSTEMD, [ libsystemd-login ], HAVE_SYSTEMD=1, HAVE_SYSTEMD=0)],
++    [PKG_CHECK_MODULES(SYSTEMD, [ libsystemd ], HAVE_SYSTEMD=1, HAVE_SYSTEMD=0)],
+     HAVE_SYSTEMD=0)
+ 
+ AS_IF([test "x$enable_systemd" = "xyes" && test "x$HAVE_SYSTEMD" = "x0"],
+-- 
+1.8.5.3
+
diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio_5.0.bb b/meta/recipes-multimedia/pulseaudio/pulseaudio_5.0.bb
index f02359a..8d8c421 100644
--- a/meta/recipes-multimedia/pulseaudio/pulseaudio_5.0.bb
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio_5.0.bb
@@ -1,6 +1,7 @@ 
 require pulseaudio.inc
 
 SRC_URI = "http://freedesktop.org/software/pulseaudio/releases/pulseaudio-${PV}.tar.xz \
+           file://0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch \
            file://volatiles.04_pulse"
 SRC_URI[md5sum] = "c43749838612f4860465e83ed62ca38e"
 SRC_URI[sha256sum] = "99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939"