Patchwork [meta-xfce,v3] recipes-xfce/libxfce4ui: depends and autotools fixes

login
register
mail settings
Submitter stephen.arnold42
Date March 18, 2014, 4:34 a.m.
Message ID <1395117284-22655-1-git-send-email-stephen.arnold42@gmail.com>
Download mbox | patch
Permalink /patch/68783/
State Accepted, archived
Headers show

Comments

stephen.arnold42 - March 18, 2014, 4:34 a.m.
Note: this patch (v3) obseletes previous versions

libxfce4ui_4.10.0.bb: Upstream changes required autotools and gettext (intl) 
fixes, as well as moving the autogen stuff to a separate task.  Full depends 
were also added (2 were converted to PACKAGECONFIG options) along with a 
vendor config option.

Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com>

---
 meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)
Andreas Müller - March 18, 2014, 8:46 a.m.
On Tue, Mar 18, 2014 at 5:34 AM, Stephen Arnold
<stephen.arnold42@gmail.com> wrote:
> Note: this patch (v3) obseletes previous versions
>
> libxfce4ui_4.10.0.bb: Upstream changes required autotools and gettext (intl)
> fixes, as well as moving the autogen stuff to a separate task.  Full depends
> were also added (2 were converted to PACKAGECONFIG options) along with a
> vendor config option.
>
> Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com>
>
> ---
>  meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb | 14 ++++++++++----
>  1 file changed, 10 insertions(+), 4 deletions(-)
>
> diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
> index cc63a9f..1e141c4 100644
> --- a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
> +++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
> @@ -2,9 +2,9 @@ SUMMARY = "Xfce4 Widget library and X Window System interaction"
>  SECTION = "x11/libs"
>  LICENSE = "GPLv2"
>  LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
> -DEPENDS = "gtk+ intltool libxfce4util startup-notification xfconf glade3"
> +DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf xfce4-dev-tools virtual/libx11 libsm libice"
>
> -inherit xfce
> +inherit autotools gettext xfce
>
>  SRC_URI = " \
>      git://git.xfce.org/xfce/libxfce4ui;protocol=git \
> @@ -15,9 +15,13 @@ SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
>  PV = "4.10.0+git${SRCPV}"
>  S = "${WORKDIR}/git"
>
> -EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
> +EXTRA_OECONF += "--enable-maintainer-mode --disable-debug  --with-vendor-info=${DISTRO}"
>
> -do_configure_prepend() {
> +PACKAGECONFIG ??= ""
> +PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
> +PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
> +
> +do_src_prepare() {
>         NOCONFIGURE=yes ./autogen.sh
>  }
>
> @@ -27,3 +31,5 @@ FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
>  PACKAGES += "${PN}-glade"
>  FILES_${PN}-glade = "${libdir}/glade3 \
>                       ${datadir}/glade3"
> +
> +addtask do_src_prepare before do_configure after do_patch
> --
I asked that for lxdm already - maybe I missed something: Why do you
create an extra task and do not use do_configure_prepend() ?

Andreas
stephen.arnold42 - March 18, 2014, 9:19 a.m.
Because it only works in a separate task (see previous email).



On Tue, Mar 18, 2014 at 1:46 AM, Andreas Müller <
schnitzeltony@googlemail.com> wrote:

> On Tue, Mar 18, 2014 at 5:34 AM, Stephen Arnold
> <stephen.arnold42@gmail.com> wrote:
> > Note: this patch (v3) obseletes previous versions
> >
> > libxfce4ui_4.10.0.bb: Upstream changes required autotools and gettext
> (intl)
> > fixes, as well as moving the autogen stuff to a separate task.  Full
> depends
> > were also added (2 were converted to PACKAGECONFIG options) along with a
> > vendor config option.
> >
> > Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com>
> >
> > ---
> >  meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb | 14
> ++++++++++----
> >  1 file changed, 10 insertions(+), 4 deletions(-)
> >
> > diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bbb/meta-xfce/recipes-xfce/libxfce4ui/
> libxfce4ui_4.10.0.bb
> > index cc63a9f..1e141c4 100644
> > --- a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
> > +++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
> > @@ -2,9 +2,9 @@ SUMMARY = "Xfce4 Widget library and X Window System
> interaction"
> >  SECTION = "x11/libs"
> >  LICENSE = "GPLv2"
> >  LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
> > -DEPENDS = "gtk+ intltool libxfce4util startup-notification xfconf
> glade3"
> > +DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf
> xfce4-dev-tools virtual/libx11 libsm libice"
> >
> > -inherit xfce
> > +inherit autotools gettext xfce
> >
> >  SRC_URI = " \
> >      git://git.xfce.org/xfce/libxfce4ui;protocol=git \
> > @@ -15,9 +15,13 @@ SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
> >  PV = "4.10.0+git${SRCPV}"
> >  S = "${WORKDIR}/git"
> >
> > -EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
> > +EXTRA_OECONF += "--enable-maintainer-mode --disable-debug
>  --with-vendor-info=${DISTRO}"
> >
> > -do_configure_prepend() {
> > +PACKAGECONFIG ??= ""
> > +PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
> > +PACKAGECONFIG[startup-notification] =
> "--enable-startup-notification,--disable-startup-notification,startup-notification"
> > +
> > +do_src_prepare() {
> >         NOCONFIGURE=yes ./autogen.sh
> >  }
> >
> > @@ -27,3 +31,5 @@ FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
> >  PACKAGES += "${PN}-glade"
> >  FILES_${PN}-glade = "${libdir}/glade3 \
> >                       ${datadir}/glade3"
> > +
> > +addtask do_src_prepare before do_configure after do_patch
> > --
> I asked that for lxdm already - maybe I missed something: Why do you
> create an extra task and do not use do_configure_prepend() ?
>
> Andreas
> --
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>
stephen.arnold42 - March 20, 2014, 6:02 a.m.
Sorry, maybe you did miss the previous one; if the task is changed to
do_configure_prepend, then it fails like below; if you remove autotools
from inherit, then it fails in a different way.

do_confgure_prepend autogen error:

Poky ["raspberrypi"] >>> bitbake libxfce4ui -c build
NOTE: Started PRServer with DBfile:
/home/sarnold/poky/build-rpihf/cache/prserv.sqlite3, IP: 127.0.0.1, PORT:
53789, PID: 25973
Loading cache: 100% |###########################################| ETA:
00:00:00
Loaded 2113 entries from dependency cache.
Parsing recipes: 100% |#########################################| Time:
00:00:00
Parsing of 1663 .bb files complete (1661 cached, 2 parsed). 2100 targets,
45 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies

Build Configuration:
BB_VERSION        = "1.21.1"
BUILD_SYS         = "x86_64-linux"
NATIVELSBSTRING   = "Ubuntu-12.04"
TARGET_SYS        = "arm-poky-linux-gnueabi"
MACHINE           = "raspberrypi"
DISTRO            = "poky"
DISTRO_VERSION    = "1.5+snapshot-20140320"
TUNE_FEATURES     = "armv6 vfp callconvention-hard arm1176jzfs
no-thumb-interwork"
TARGET_FPU        = "vfp"
meta
meta-yocto
meta-yocto-bsp    = "master:387349d29a824d318474ce4cc05d342dcde46621"
meta-raspberrypi  = "master:364da37b0db31aa21b1717e5a294e73a8a426d94"
meta-alt-desktop-extras = "master:fdffcf33fed9f2806daa6f10326e0e8a2e81eae7"
meta-erlang       = "master:986fda4a4cd3ac521897206ba39fe4d9f42e50b9"
meta-oe
meta-gnome
meta-networking
meta-filesystems
meta-multimedia
meta-efl
meta-xfce         = "master:c25e5ab9335a024aaf7963d7dfb0d3ae7b163f0b"

NOTE: Preparing runqueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
ERROR: Function failed: do_configure (log file is located at
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/temp/log.do_configure.27954)
ERROR: Logfile of failure stored in:
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/temp/log.do_configure.27954
Log data follows:
| DEBUG: Executing python function sysroot_cleansstate
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/icons/hicolor/48x48/apps/xfce4-logo.png
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/22x22/actions/widget-libxfce4ui-xfce-titled-dialog.png
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/16x16/actions/widget-libxfce4ui-xfce-titled-dialog.png
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/catalogs/libxfce4ui.xml
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/catalogs/
libxfce4ui.xml.in
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/libxfce4ui-config.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-gdk-extensions.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/libxfce4ui.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-dialogs.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/libxfce4ui-enum-types.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-spawn.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-sm-client.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-titled-dialog.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/xfce-gtk-extensions.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/xfce-shortcuts-grabber.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/xfce-shortcuts-xfwm4.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/xfce-shortcuts-provider.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/xfce-shortcuts.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/xfce-shortcut-dialog.h
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/
libxfce4ui-1.la
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4kbd-private-2.so
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4ui-1.so
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/
libxfce4kbd-private-2.la
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4kbd-private-2.so.0
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4ui-1.so.0
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4kbd-private-2.so.0.0.0
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/libxfce4ui-1.so.0.0.0
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/pkgconfig/libxfce4ui-1.pc
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/pkgconfig/libxfce4kbd-private-2.pc
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/glade3/modules/
libxfce4uiglade.la
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/glade3/modules/libxfce4uiglade.so
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/libxfce4kbd-private/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/16x16/actions/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/22x22/actions/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/libxfce4ui/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4kbd-private-2/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/16x16/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/22x22/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/icons/hicolor/48x48/apps/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/hicolor/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/libxfce4ui-1/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/icons/hicolor/48x48/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/catalogs/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/pixmaps/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/icons/hicolor/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/glade3/modules/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/pkgconfig/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/xfce4/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/glade3/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/icons/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/glade3/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/include/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/lib/
| DEBUG: Removing manifest:
/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/
| DEBUG: Python function sysroot_cleansstate finished
| DEBUG: SITE files ['endian-little', 'bit-32', 'arm-common',
'common-linux', 'common-glibc', 'arm-linux', 'arm-linux-gnueabi', 'common']
| DEBUG: Executing shell function autotools_preconfigure
| DEBUG: Shell function autotools_preconfigure finished
| DEBUG: Executing python function autotools_copy_aclocals
| DEBUG: Python function autotools_copy_aclocals finished
| DEBUG: Executing shell function do_configure
| Preparing package directory
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/git...
| Creating
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/git/aclocal.m4...
| Running glib-gettextize --force --copy...
| Copying file po/Makefile.in.in
|
| Please add the files
|   codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
|   progtest.m4
| from the
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/aclocal
directory to your autoconf macro directory
| or directly to your aclocal.m4 file.
| You will also need config.guess and config.sub, which you can get from
| ftp://ftp.gnu.org/pub/gnu/config/.
|
| Running intltoolize --automake --copy --force
| Patching file 'po/Makefile.in.in'
| Running libtoolize --force --copy...
| libtoolize: putting auxiliary files in `.'.
| libtoolize: copying file `./ltmain.sh'
| libtoolize: You should add the contents of the following files to
`aclocal.m4':
| libtoolize:
`/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/aclocal/libtool.m4'
| libtoolize:
`/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/aclocal/ltoptions.m4'
| libtoolize:
`/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/aclocal/ltversion.m4'
| libtoolize:
`/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/aclocal/ltsugar.m4'
| libtoolize:
`/home/sarnold/poky/build-rpihf/tmp/sysroots/raspberrypi/usr/share/aclocal/lt~obsolete.m4'
| libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.acand
| libtoolize: rerunning libtoolize, to keep the correct libtool macros
in-tree.
| libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
| Running gtkdocize --copy...
| Running aclocal   -I
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/xfce4/dev-tools/m4macros...
| configure.ac:230: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/xfce4/dev-tools/m4macros/xdt-features.m4:39:
XDT_SUPPORTED_FLAGS is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/xfce4/dev-tools/m4macros/xdt-features.m4:59:
XDT_FEATURE_DEBUG is expanded from...
| configure.ac:230: the top level
| configure.ac:246: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/xfce4/dev-tools/m4macros/xdt-features.m4:39:
XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:246: the top level
| configure.ac:250: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| configure.ac:250: the top level
| configure.ac:279: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/sysroots/x86_64-linux/usr/share/xfce4/dev-tools/m4macros/xdt-features.m4:39:
XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:279: the top level
| Running autoheader...
| configure.ac:230: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| aclocal.m4:11129: XDT_FEATURE_DEBUG is expanded from...
| configure.ac:230: the top level
| configure.ac:246: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:246: the top level
| configure.ac:250: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| configure.ac:250: the top level
| configure.ac:279: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:279: the top level
| Running automake --force-missing --add-missing --copy --gnu...
| configure.ac:230: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| aclocal.m4:11129: XDT_FEATURE_DEBUG is expanded from...
| configure.ac:230: the top level
| configure.ac:246: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:246: the top level
| configure.ac:250: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| configure.ac:250: the top level
| configure.ac:279: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:279: the top level
| configure.ac:56: installing './compile'
| configure.ac:43: installing './config.guess'
| configure.ac:43: installing './config.sub'
| configure.ac:48: installing './install-sh'
| configure.ac:48: installing './missing'
| Makefile.am:10: warning: whitespace following trailing backslash
| Makefile.am: installing './INSTALL'
| glade/Makefile.am: installing './depcomp'
| parallel-tests: installing './test-driver'
| Running autoconf...
| configure.ac:230: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| aclocal.m4:11129: XDT_FEATURE_DEBUG is expanded from...
| configure.ac:230: the top level
| configure.ac:246: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:246: the top level
| configure.ac:250: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| configure.ac:250: the top level
| configure.ac:279: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/lang.m4:193:
AC_LANG_CONFTEST is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2584:
_AC_COMPILE_IFELSE is expanded from...
|
/home/sarnold/poky/build-rpihf/tmp/work/x86_64-linux/autoconf-native/2.69-r11/autoconf-2.69/lib/autoconf/general.m4:2600:
AC_COMPILE_IFELSE is expanded from...
| aclocal.m4:11109: XDT_SUPPORTED_FLAGS is expanded from...
| configure.ac:279: the top level
|
| Skipping configure process.
| automake (GNU automake) 1.14
| Copyright (C) 2013 Free Software Foundation, Inc.
| License GPLv2+: GNU GPL version 2 or later <
http://gnu.org/licenses/gpl-2.0.html>
| This is free software: you are free to change and redistribute it.
| There is NO WARRANTY, to the extent permitted by law.
|
| Written by Tom Tromey <tromey@redhat.com>
|        and Alexandre Duret-Lutz <adl@gnu.org>.
| AUTOV is 1
| NOTE: Executing intltoolize --copy --force --automake
| NOTE: Executing ACLOCAL="aclocal
--system-acdir=/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/git/aclocal-copy/"
autoreconf --verbose --install --force --exclude=autopoint
| autoreconf: Entering directory `.'
| autoreconf: configure.ac: not using Gettext
| autoreconf: running: aclocal
--system-acdir=/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/git/aclocal-copy/
--force
| aclocal: error: couldn't open directory
'/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/git/aclocal-copy/':
No such file or directory
| autoreconf: aclocal failed with exit status: 1
| ERROR: autoreconf execution failed.
| WARNING:
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/temp/run.do_configure.27954:1
exit 1 from
|   exit 1
| ERROR: Function failed: do_configure (log file is located at
/home/sarnold/poky/build-rpihf/tmp/work/arm1176jzfshf-vfp-poky-linux-gnueabi/libxfce4ui/4.10.0+gitAUTOINC+530b72f50f-r0/temp/log.do_configure.27954)
ERROR: Task 5
(/home/sarnold/poky/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/
libxfce4ui_4.10.0.bb, do_configure) failed with exit code '1'
NOTE: Tasks Summary: Attempted 1705 tasks of which 1701 didn't need to be
rerun and 1 failed.
NOTE: Writing buildhistory
No currently running tasks (1704 of 1712)

Summary: 1 task failed:
  /home/sarnold/poky/meta-openembedded/meta-xfce/recipes-xfce/libxfce4ui/
libxfce4ui_4.10.0.bb, do_configure
Summary: There was 1 ERROR message shown, returning a non-zero exit code.
Poky ["raspberrypi"] >>>



On Tue, Mar 18, 2014 at 2:19 AM, Stephen Arnold
<stephen.arnold42@gmail.com>wrote:

> Because it only works in a separate task (see previous email).
>
>
>
> On Tue, Mar 18, 2014 at 1:46 AM, Andreas Müller <
> schnitzeltony@googlemail.com> wrote:
>
>> On Tue, Mar 18, 2014 at 5:34 AM, Stephen Arnold
>> <stephen.arnold42@gmail.com> wrote:
>> > Note: this patch (v3) obseletes previous versions
>> >
>> > libxfce4ui_4.10.0.bb: Upstream changes required autotools and gettext
>> (intl)
>> > fixes, as well as moving the autogen stuff to a separate task.  Full
>> depends
>> > were also added (2 were converted to PACKAGECONFIG options) along with a
>> > vendor config option.
>> >
>> > Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com>
>> >
>> > ---
>> >  meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb | 14
>> ++++++++++----
>> >  1 file changed, 10 insertions(+), 4 deletions(-)
>> >
>> > diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bbb/meta-xfce/recipes-xfce/libxfce4ui/
>> libxfce4ui_4.10.0.bb
>> > index cc63a9f..1e141c4 100644
>> > --- a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
>> > +++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
>> > @@ -2,9 +2,9 @@ SUMMARY = "Xfce4 Widget library and X Window System
>> interaction"
>> >  SECTION = "x11/libs"
>> >  LICENSE = "GPLv2"
>> >  LIC_FILES_CHKSUM =
>> "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
>> > -DEPENDS = "gtk+ intltool libxfce4util startup-notification xfconf
>> glade3"
>> > +DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf
>> xfce4-dev-tools virtual/libx11 libsm libice"
>> >
>> > -inherit xfce
>> > +inherit autotools gettext xfce
>> >
>> >  SRC_URI = " \
>> >      git://git.xfce.org/xfce/libxfce4ui;protocol=git \
>> > @@ -15,9 +15,13 @@ SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
>> >  PV = "4.10.0+git${SRCPV}"
>> >  S = "${WORKDIR}/git"
>> >
>> > -EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
>> > +EXTRA_OECONF += "--enable-maintainer-mode --disable-debug
>>  --with-vendor-info=${DISTRO}"
>> >
>> > -do_configure_prepend() {
>> > +PACKAGECONFIG ??= ""
>> > +PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
>> > +PACKAGECONFIG[startup-notification] =
>> "--enable-startup-notification,--disable-startup-notification,startup-notification"
>> > +
>> > +do_src_prepare() {
>> >         NOCONFIGURE=yes ./autogen.sh
>> >  }
>> >
>> > @@ -27,3 +31,5 @@ FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
>> >  PACKAGES += "${PN}-glade"
>> >  FILES_${PN}-glade = "${libdir}/glade3 \
>> >                       ${datadir}/glade3"
>> > +
>> > +addtask do_src_prepare before do_configure after do_patch
>> > --
>> I asked that for lxdm already - maybe I missed something: Why do you
>> create an extra task and do not use do_configure_prepend() ?
>>
>> Andreas
>> --
>> _______________________________________________
>> Openembedded-devel mailing list
>> Openembedded-devel@lists.openembedded.org
>> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>>
>
>
Khem Raj - March 20, 2014, 6:11 a.m.
On Mon, Mar 17, 2014 at 9:34 PM, Stephen Arnold
<stephen.arnold42@gmail.com> wrote:
> -EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
> +EXTRA_OECONF += "--enable-maintainer-mode --disable-debug  --with-vendor-info=${DISTRO}"
>
> -do_configure_prepend() {
> +PACKAGECONFIG ??= ""
> +PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
> +PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
> +
> +do_src_prepare() {
>         NOCONFIGURE=yes ./autogen.sh
>  }
>
> @@ -27,3 +31,5 @@ FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
>  PACKAGES += "${PN}-glade"
>  FILES_${PN}-glade = "${libdir}/glade3 \
>                       ${datadir}/glade3"
> +
> +addtask do_src_prepare before do_configure after do_patch


well just override complete do_configure since you are regenerating everything
something like below might do the trick.

do_configure() {
        ./autogen.sh --noconfigure
        oe_runconf
}

Patch

diff --git a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
index cc63a9f..1e141c4 100644
--- a/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/libxfce4ui/libxfce4ui_4.10.0.bb
@@ -2,9 +2,9 @@  SUMMARY = "Xfce4 Widget library and X Window System interaction"
 SECTION = "x11/libs"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=252890d9eee26aab7b432e8b8a616475"
-DEPENDS = "gtk+ intltool libxfce4util startup-notification xfconf glade3"
+DEPENDS = "perl-native glib-2.0 gtk+ intltool libxfce4util xfconf xfce4-dev-tools virtual/libx11 libsm libice"
 
-inherit xfce
+inherit autotools gettext xfce
 
 SRC_URI = " \
     git://git.xfce.org/xfce/libxfce4ui;protocol=git \
@@ -15,9 +15,13 @@  SRCREV = "530b72f50fcbd8cb4b970fcc97be0321bf78183e"
 PV = "4.10.0+git${SRCPV}"
 S = "${WORKDIR}/git"
 
-EXTRA_OECONF += "--enable-maintainer-mode --disable-debug"
+EXTRA_OECONF += "--enable-maintainer-mode --disable-debug  --with-vendor-info=${DISTRO}"
 
-do_configure_prepend() {
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gladeui] = "--enable-gladeui,--disable-gladeui,glade3"
+PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
+
+do_src_prepare() {
        NOCONFIGURE=yes ./autogen.sh
 }
 
@@ -27,3 +31,5 @@  FILES_${PN}-dev += "${libdir}/glade3/modules/*.la \
 PACKAGES += "${PN}-glade"
 FILES_${PN}-glade = "${libdir}/glade3 \
                      ${datadir}/glade3"
+
+addtask do_src_prepare before do_configure after do_patch