seatd: Disable overflow warning as error on ppc64/musl

Message ID 20220420013648.3101309-1-raj.khem@gmail.com
State Accepted, archived
Commit 381cf11b994d2bf40ac8781e18b5eac17b3b6cb0
Headers show
Series seatd: Disable overflow warning as error on ppc64/musl | expand

Commit Message

Khem Raj April 20, 2022, 1:36 a.m. UTC
Disabling the warning is easier fix then trying to fix it
in musl which results in ABI breakage and disabling the Werror
gets us along by doing minimal change, also see [1]

[1] https://todo.sr.ht/~kennylevinsen/seatd/10

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-core/seatd/seatd_0.6.4.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-core/seatd/seatd_0.6.4.bb b/meta/recipes-core/seatd/seatd_0.6.4.bb
index a38f8c21524..601736adef1 100644
--- a/meta/recipes-core/seatd/seatd_0.6.4.bb
+++ b/meta/recipes-core/seatd/seatd_0.6.4.bb
@@ -13,6 +13,9 @@  S = "${WORKDIR}/git"
 
 inherit meson pkgconfig update-rc.d
 
+# https://www.openwall.com/lists/musl/2020/01/20/3
+CFLAGS:append:libc-musl:powerpc64le = " -Wno-error=overflow"
+
 PACKAGECONFIG ?= " \
 	${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
 	libseat-builtin \