Patchwork populate_sdk_deb: Fix meta-toolchain-sdk with amd64 ARCH

login
register
mail settings
Submitter Ricardo Ribalda Delgado
Date March 11, 2014, 5:22 p.m.
Message ID <1394558557-4962-1-git-send-email-ricardo.ribalda@gmail.com>
Download mbox | patch
Permalink /patch/68437/
State New
Headers show

Comments

Ricardo Ribalda Delgado - March 11, 2014, 5:22 p.m.
Map SDK_ARCH x86_64 to DEB_SDK_ARCH amd64

Without this patch meta-toolchain-gmae fails to do_populate_sdk

| The following packages have unmet dependencies:
|  nativesdk-packagegroup-sdk-host : Depends: nativesdk-autoconf but it
is not installable
|                                    Depends: nativesdk-libtool but it
is not installable
|                                    Depends: nativesdk-shadow but it is
not installable
|                                    Depends: nativesdk-unfs-server but
it is not installable
|                                    Depends: nativesdk-makedevs but it
is not installable
|                                    Depends: nativesdk-automake but it
is not installable
|                                    Depends: nativesdk-qemu but it is
not installable
|                                    Depends: nativesdk-pkgconfig but it
is not installable
|                                    Depends: nativesdk-pseudo but it is
not installable
|                                    Depends: nativesdk-qemu-helper but
it is not installable
|                                    Depends: nativesdk-opkg but it is
not installable
|  packagegroup-cross-canadian-qt5022 : Depends:
gdb-cross-canadian-x86-64 but it is not installable
|                                       Depends:
binutils-cross-canadian-x86-64 but it is not installable
|                                       Depends:
gcc-cross-canadian-x86-64 but it is not installable
|                                       Depends: meta-environment-qt5022
but it is not installable

Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
---
 meta/classes/populate_sdk_deb.bbclass | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/classes/populate_sdk_deb.bbclass b/meta/classes/populate_sdk_deb.bbclass
index ebb842b..aa2b6eb 100644
--- a/meta/classes/populate_sdk_deb.bbclass
+++ b/meta/classes/populate_sdk_deb.bbclass
@@ -6,6 +6,9 @@  DEB_SDK_ARCH = "${@[d.getVar('SDK_ARCH', True), "i386"]\
                 [d.getVar('SDK_ARCH', True) in \
                 ["x86", "i486", "i586", "i686", "pentium"]]}"
 
+DEB_SDK_ARCH = "${@[d.getVar('SDK_ARCH', True), "amd64"]\
+                [d.getVar('SDK_ARCH', True) == "x86_64"]}"
+
 do_populate_sdk[lockfiles] += "${DEPLOY_DIR_DEB}/deb.lock"
 
 populate_sdk_post_deb () {