[meta-python] python3-nocaselist: upgrade 1.0.4 -> 1.0.5

Message ID 1649901388-13842-1-git-send-email-zhengrq.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-nocaselist: upgrade 1.0.4 -> 1.0.5 | expand

Commit Message

zhengrq.fnst@fujitsu.com April 14, 2022, 1:56 a.m. UTC
License-Update: type of file changed
 "ASCII text, with CRLF line terminators" -> "ASCII text"

Changelog:
=========
Bug fixes:
----------
Mitigated the coveralls HTTP status 422 by pinning coveralls-python to <3.0.0 (issue #55).
Fixed a dependency error that caused importlib-metadata to be installed on Python 3.8, while it is included in the Python base.
Fixed new issues raised by Pylint 2.10.
Disabled new Pylint issue ‘consider-using-f-string’, since f-strings were introduced only in Python 3.6.
Fixed install error of wrapt 1.13.0 on Python 2.7 on Windows due to lack of MS Visual C++ 9.0 on GitHub Actions, by pinning it to <1.13.
Fixed TypeError when running Sphinx due to using docutils 0.18 on Python 2.7.
Fixed error when installing virtualenv in install test on Python 2.7.
Fixed that the added setup.py commands (test, leaktest, installtest) were not displayed. They are now displayed at verbosity level 1 (using ‘-v’).

Enhancements:
------------
Enhanced test matrix on GitHub Actions to always include Python 2.7 and Python 3.4 on Ubuntu and Windows, and Python 2.7 and Python 3.5 on macOS.
Support for Python 3.10: Added Python 3.10 in GitHub Actions tests, and in package metadata.

Cleanup:
-----------
Removed old tools that were needed on Travis and Appveyor but no longer on GitHub Actions: remove_duplicate_setuptools.py, retry.bat

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 .../recipes-devtools/python/python3-nocaselist_1.0.4.bb   | 8 --------
 .../recipes-devtools/python/python3-nocaselist_1.0.5.bb   | 8 ++++++++
 2 files changed, 8 insertions(+), 8 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-nocaselist_1.0.4.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-nocaselist_1.0.5.bb

Patch

diff --git a/meta-python/recipes-devtools/python/python3-nocaselist_1.0.4.bb b/meta-python/recipes-devtools/python/python3-nocaselist_1.0.4.bb
deleted file mode 100644
index 60c79c22a8..0000000000
--- a/meta-python/recipes-devtools/python/python3-nocaselist_1.0.4.bb
+++ /dev/null
@@ -1,8 +0,0 @@ 
-SUMMARY = "A case-insensitive list for Python"
-HOMEPAGE = "https://nocaselist.readthedocs.io/en/latest/"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d229da563da18fe5d58cd95a6467d584"
-
-SRC_URI[sha256sum] = "73a9c0659e7135c66e46a6ab06e2cb637ce9248d73c690ebd31afb72a4e03ac0"
-
-inherit pypi setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-nocaselist_1.0.5.bb b/meta-python/recipes-devtools/python/python3-nocaselist_1.0.5.bb
new file mode 100644
index 0000000000..22b8825801
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nocaselist_1.0.5.bb
@@ -0,0 +1,8 @@ 
+SUMMARY = "A case-insensitive list for Python"
+HOMEPAGE = "https://nocaselist.readthedocs.io/en/latest/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[sha256sum] = "e1c12ca2ae9d345b34948f2c8f60e3894619e2be2ed28b4ecc5e7f1dea117d1d"
+
+inherit pypi setuptools3