Patchwork [meta-qt5,dora] qtbase.inc: PACKAGECONFIG[gstreamer] gst-plugins-base dependency missing

login
register
mail settings
Submitter Andre McCurdy
Date Feb. 13, 2014, 2:35 a.m.
Message ID <1392258928-32123-1-git-send-email-armccurdy@gmail.com>
Download mbox | patch
Permalink /patch/66667/
State Accepted, archived
Headers show

Comments

Andre McCurdy - Feb. 13, 2014, 2:35 a.m.
When testing for GStreamer support, the qtbase 5.1.1 configure script
tries to determine pkg-config information for both gstreamer-0.10 and
gstreamer-plugins-base-0.10.

If either one is unavailable then the configure test fails (with the
slightly confusing error that gst/gst.h can't be found, even when the
gstreamer header files are present in sysroot).

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
---
 recipes-qt/qt5/qtbase.inc | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/recipes-qt/qt5/qtbase.inc b/recipes-qt/qt5/qtbase.inc
index 7018c69..71da726 100644
--- a/recipes-qt/qt5/qtbase.inc
+++ b/recipes-qt/qt5/qtbase.inc
@@ -104,7 +104,7 @@  PACKAGECONFIG[iconv] = "-iconv,-no-iconv,virtual/libiconv"
 PACKAGECONFIG[xkb] = "-xkb,-no-xkb,libxkbcommon"
 PACKAGECONFIG[evdev] = "-evdev,-no-evdev"
 # depends on glib
-PACKAGECONFIG[gstreamer] = "-gstreamer,-no-gstreamer,gstreamer"
+PACKAGECONFIG[gstreamer] = "-gstreamer,-no-gstreamer,gstreamer gst-plugins-base"
 PACKAGECONFIG[fontconfig] = "-fontconfig,-no-fontconfig,fontconfig"
 PACKAGECONFIG[gtkstyle] = "-gtkstyle,-no-gtkstyle,gtk+"
 PACKAGECONFIG[directfb] = "-directfb,-no-directfb,directfb"